Jump to content

Sony Vaio VGN-NR10E Progress (help needed!)


3 posts in this topic

Recommended Posts

Hey all! This is my first post here so you will have to point me in the right direction on the forums if I screw up!


So I have this circa 2007 Sony Vaio (VGN-NR10E) that I decided to install OSX on. For reference, so far OS X 10.6.8 is installed and updated using ###### and a legit Snow Leopard retail DVD. It now boots flawlessly every time with the chameleon bootloader.


Specs + progress list:

  • Intel Pentium Dual core T2310 1.46GHz - Working and recognised
  • Intel GMA X3100 Graphics chipset - Working and recognised, although is somewhat slow + lacks brightness control
  • Display (1280x800) - Working with res set by SwitchResX
  • Unknown Motherboard - Working with unmodified DSDT but could need work?
  • 2GB DDR2 - Working and recognised
  • Ethernet adapter (Marvell? possibly Intel) - Not working
  • Atheros (unknown model) WLAN - Not working
  • Card Readers - Untested
  • USB Devices - Working and recognised
  • Synaptics Trackpad + Keyboard - Working, but no gestures

A few notes on the latest developments:

  1. Trackpad prefpane installed as described with the new kexts (http://www.osx86.net...&id=1448&page=9) However I have no gesture support at all. Both keyboard and trackpad work, but I would at least like some sort of scrolling function! NOW BOTH KEYBOARD AND TRACKPAD ONLY WORK AFTER THE OCCASIONAL BOOT
  2. 'About this Mac' crashes with log out when clicked
  3. Although display and graphics are working correctly and I have X3100 recognised with new kexts, there is no brightness control. Is there a third party tool I could use for this? It is also very laggy with animation and stuff.
  4. Menu bar lacks transparency. The option checkbox is not there in Preferences > Desktop. It was a very bright white colour almost like in tiger, which i forced to correct with the Terminal line "sudo defaults write /System/Library/LaunchDaemons/com.apple.WindowServer 'EnvironmentVariables' -dict 'CI_NO_BACKGROUND_IMAGE' 0" and although that got it back to normal, there is still no transparency DONE
  5. NO internet connectivity whatsoever. I have tried several Ethernet kexts with no luck, and also several Atheros kexts. Last time I tried some Atheros kexts they were replacements/patches for

    IO8211 etc, and it caused a kernel panic on boot that I could not fix, so I had to start from square one.

  6. Boot screen is in incorrect resolution. I have added 'Graphics mode' strings to the boot.plist files with zero luck or change.

Can anyone help me with any of my issues? Any input is greatly appreciated! Also, please excuse the formatting and lack of numbering for my problems, the editor doesnt save it!

Edited by Danlat
Link to comment
Share on other sites


  • Create New...