Jump to content

The good ole Asus G73JH


1 post in this topic

Recommended Posts

Hello insanelymac forums!


This is my first post, but have been reading for months and months and finally took the blue pill, err red pill. whichever one :P


I have the Asus G73JH-RBBX05 notebook. (If you are familiar, it is the Best Buy version, but mine is upgraded)


Core i7-720QM (Best Buy standard)

1GB GDDR5 ATI Mobility Radeon HD5870 (Best Buy standard)

(2) 500GB Seagate Momentus 7200.4 HDD's (upgraded)

16GB Patriot DDR3 1600Mhz RAM (upgraded from 6GB)


I am also using Hazards 10.6.2 distro. (I know I know...os x retail os x retail....just didn't have the time to drive out 35 miles to the nearest apple retail store. :P


That's the main part of it...


I have followed numerous guides to get OS X up and running on this thing, and if it's one thing I've learned, is that its patience. :)


I could not get any version of i boot to even boot. Just stuck on a blinking cursor on a black screen. Even tried different DVD player, and different settings in BIOS, but nothing was working.


I finally got to boot into the installation screen by using Legacy Empire EFI, and booting with boot flags: cpus=1 busratio=28 maxmem=4096 -v


It booted, didn't get the dreaded ACPI kernel panic, and installation started!


After booting into 10.6.2, barely anything worked...the trackpad, usb's, keyboard, and 1024x768 resolution was about it. I followed a guide to update straight to 10.6.8.


Deleted SleepEnabler.kext

Copied 4 kext files to my desktop: AppleACPIPlatform.kext, IOPCIFamily.kext, IOUSBFamily.kext, IOUSBMassStorageClass.kext

Downloaded 10.6.8 combo update through apples site and installed

Downloaded 10.6.8 legacy kernel from somewhere, and installed it,

Then used kexthelper.app (search google) and dropped those 4 kext files from my desktop and put in my password and clicked install.


I then rebooted.


Well, at startup, I got a Kernel Panic for CPU Halted something or rather. Did some more research, and found out by booting with boot flags: arch=i386 -force64 cleared that right up!


Booting into 10.6.8 was a success, and I have full resolution, WIFI works after finding a kext for my atheros card, and I don't seem to have any problems whatsoever with the 802.11n, remembering location, etc. everything works flawlessly.


Webcam works with photobooth, card reader, hdmi out, the whole thing. Only thing I do miss is my backlit keyboard :( Although I see some people have gotten it to work with some kexts, but I haven't tried it yet.


OS X seems to recognize my 5870 card, and my 16GB of ram also...


Does anyone have any experience with this laptop? I am able to use it fully like a native machine. Installing software from the App Store, using my iPhone with iTunes, etc is all good!


Anyone have any luck with the trackpad (touchpad) and multi touch gestures, or even scroll wheel on right side of touchpad? I use a mouse regularly... but every once in awhile the pad is good.


Has anyone updated to Lion? Is there an advantage?? It's not like I am doing development or anything, just an end-user and a fan of Apple products. I know buy a macbook pro right? No one can beat my pieced together, bough off craigslist and repaired Asus G73JH for 500 bucks plus my 2nd HDD and extra ram!


I have purchased an OS X retail DVD for those that hate...I will put it to good use somewhere somehow. Maybe on another machine :)

Link to comment
Share on other sites


  • Create New...