Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Remove stuttering from ALC889A with VoodooHDA?

11 posts in this topic

Recommended Posts

Hi, I have my Hackintosh up and running, but the only problem is that the audio stutters quite alot.

I think it might have to do with VoodooHDA not recognizing my jack ports (look in attachment).


If VoodooHDA could recognize them, i could tick the "Use SSE2" and it would solve the problem, right?


If I uninstall VoodooHDA the audio stops playing so it must work somehow?

Share this post

Link to post
Share on other sites

Why don't you use a patched AppleHDA rather than voodoo?

Personally I'd only use voodoo as a last resort.

Share this post

Link to post
Share on other sites

Can you link me a guide that you know works? I'm not sure if i have tried it...


The original AppleHDA for 10.6.8 is that version 1.7.9?

Share this post

Link to post
Share on other sites

I'm not sure which version is for 10.6.8.

There are many ways to get AppleHDA working, either through an enabler kext, dsdt edit or efi string. Personally I would use a dsdt edit.


Do you have a dsdt compiled for your system?

Share this post

Link to post
Share on other sites

I have tried using ####### and the enabler kexts, but then i lost audio completely.


I don't use DSDT. I don't have a reason not to, it was just simpler somehow to do it without.

Share this post

Link to post
Share on other sites

Ok, no problem.

I use 889a as well and do so via dsdt edit, if you extract your dsdt and post it I can help you patch it for audio.

Share this post

Link to post
Share on other sites

Thanks! That would be awesome!


I used DSDTSE to extract it, if that is important?


I can't post it here directly, but i have attached it in a txt file.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ronniegold
      Hi guys,
      This is my first Hackintosh, designed to be used for music production, so having my audio stutter is a fairly serious issue!
      i7 8700k
      Asrock z370 Pro4
      Focusrite 18i20v2 (have also tested with Focusrite 2i2, and Zoom H6) audio interface,
      Samsung 960 M.2 (I also have a normal HDD in here as well)
      I tested with High Sierra, but had the same problems in Sierra (which I installed on my spinning HDD).
      It seems that sound engine is encountering some kind of error, and is having to restart itself periodically. These are the important lines from Console (I believe)-
      USB Sound assertion (Resetting engine due to error returned in Read Handler) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-311.9/AppleUSBAudioDevice.cpp at line 6182
      ^^ I assume that .cpp file is inaccessible? Would be interesting to see what is on line 6182! Looks like the audio streaming is messing itself up every now and then?
      Core audiod - HALS_IOA1Engine.cpp:365:EndWriting:  HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002D7
      Core Audiod - HALB_AsyncLog.cpp:120:perform:  11:39:38.080572 thread 10d4: HALS_IOContext::IOWorkLoop_HandleOverload: Overload arg1: 64 arg2: 4527392 arg3: 4527426
      Spotify - HALC_ProxyIOContext.cpp:1068:IOWorkLoop:  HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload
      Sometimes I also get a USB Sound Assertion claiming that "output fell behind". although i've just observed that this particular error msg also happens on my imac, so this is probably not hackintosh related.
      USB Sound assertion (Output Fell Behind) in /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleUSBAudio/AppleUSBAudio-311.9/AppleUSBAudioDevice.cpp at line 6177
      https://imgur.com/a/MZXVi(various screenshots of console)
      I haven't noticed problems with onboard sound, which I briefly got working to test. I'm not interested in using onboard sound though. My intuition says that my mobos USB isn't playing nicely with OSX. Unfortunately theres nothing in the bios I can change (I can't force it to run as USB 2.0 for example, and there are no USB 2 ports on this mobo). Changing ports makes no difference.
      I initially used a guide and EFI folder from a website, but today tried the "vanilla" method on Reddit, which seemed to install nicely, but hasn't fixed my USB Audio problems! I've tried fiddling with the USB options in clover but to no avail.
      I've been trying to look into using RehabMans FakePCIID_XHCIMux.kext, but I'm a bit confused about if its doing anything (I put it in my clover kext folder, as well as in sys/lib/ext, as well as the FakePCIID.kext). Not sure what its really meant to do, or if I need to do more to make it work?
      Interestingly, my iMac (which works well with USB audio, running Sierra), uses AppleUSBXHCILPTH as the Host Controller for USB 3.0 bus in System Information, whereas my hack is using AppleUSBXHCISPT. Is this a pertinent detail perhaps?
      I'm not sure what else to try now! I've ordered a cheap USB 2.0 PCI card from Amazon which arrives on Tuesday, but this is a bit of a desperation attempt, I'm quite out of my depth with this issue! Any help would be massively appreciated.
      ​Interestingly, the error doesn't seem to occur as much if I don't touch the computer. I wonder if my mouse/keyboard is interfering with the USB Audio? I've tried unplugging everything other than the mouse/keyboard and USB interface but still get the problem.
      Thanks so much! Apologies if there's more info I need to add, I will supply any information necessary!
      ​EDIT : Thought I'd also add that I updated the Bios to ver 1.60 (latest) from Asrock website, was hoping this would fix the problem but it hasn't.
    • By Mr.Darkwraith
      I'm having audio issues with my Dell Vostro 2520's microphone with VoodooHDA
      The internal microphone isn't detected, yet the microphone audio port is detected, and works.
      According to Windows and Dell, my laptop has the Cirrus Logic CS4213 codec in it, so if that's important, there it is.
      I am on Mavericks 10.9.5, since that works the best on this laptop, but would be open to try newer versions if things work well enough.
      I can provide my DSDT if needed.
    • By DigiV
      Hello, All.
      I have installed Sierra build 16G29 (10.12.6)
      Problem is that my integrated sound card Realtek ALC887 not works properly.
      Now I have installed VoodooHDA 2.8.8 but microphone not working. Anyone can help with it?
      motherboard is Asus H110M-D (https://www.asus.com/us/Motherboards/H110M-D/specifications/)
      CPU i3 6100 Skylake
      Nvidia GTX 750 Ti
    • By MrAnty
      My alc892 audio has an issue. My Motherboard model is ASROCK b350 K4 Gaming. I installed voodooHDA 2.9 and it works. Alc892 has been successfully recognized.
      But there is nothing like 5.1 or 7.1(green rear) in the audio output. There is only Headphone(green front) output.
      So I can only use headphones via the front audio output jacks of my chassis, but cannot use my speakers via the rear audio output jacks(the green one).  Please help me. Any reply will be appreciated.
      Forgive me for my poor ENGLISH....
    • By illfatedIM
      VodooHDA makes sound output (2.1) work but Microphone and Line-Out wont work.
      I've been trying to get the PinConfigOverrideVerbs from Windows regedit and the codec dumps from linux but this card (Emu20k2, SB0880) doesnt have any codecs on linux even though microphone works perfectly fine there and windows doesnt have a PinConfig entry in the registry for this card.
      I'm at a loss... what else can I do to make at least the mic work?