Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Lion on Sony Vaio VPCEB4J1E - ATI HD 5470 internal Display SNY05FA not working

1 post in this topic

Recommended Posts

Hello Folks,


after trying "hundreds" of hours to install OS-X Lion on Sony VAIO VPCEB4J1E, I'd like to let you know my experiences about this piece of sh.. notebook.


The following Hardware is working without any problems:

  • Keyboard & Trackpad (1448-PS2-Synaptics-Keyboard-32+64)
  • Sound and internal Speakers (VoodooHDA
  • Motion Eye Camera (Out of the box)
  • Bluetooth (Out of the Box)

I did the following steps installing Lion 10.7.2 and got it "working":

  • Make bootable USB-Stick with iAtkos L2
  • Replace "AppleACPIPlattform.kext" and "IOPCIFamily.kext" on Boot-Stick with this Versions of "PCI Configuration Begin Fix"
  • Boot from Stick with this Flags to install: USBBusFix=Yes "Graphic Mode"="1024x768x32" -v
  • Use USB-Mouse & -Keyboard to install Lion
  • After completed installation boot your Lion with connected VGA-Display (connected to VGA-Port) to get output on the internal Display
  • Use the 1448-PS2-Synaptics-Keyboard-32+64 Kext to get Keyboard and Trackpad working
  • Install VoodooHDA with ###### to enable Sound

Now the System is booting, but the internal Display is only working well with a connected Display at the VGA-Port (QE/CI doing fine).

Disconnecting the external Display and rebooting the System will get a black internal Screen. The system is stable in background but you can reach it via "vnc-access" on a second Mac.


I tried to change EDID, different KEXTs, some DSDT-Files from other VAIOs, nearly every Tipps & Tricks I found in Google. - But nothing helped.


Now I decided to give up, about 40 hours of trying and searching are enough. If anyone outthere has a solution to get the internal Display working with QE/CI I'd be glad to read about it here.


I got the following informations about the hardware while trying:

  • Graphic-Card: ATI Mobility Radeon HD 5470 (80 SM5.0 750MHz, 512 MB DDR3 1.58GHz 64-bit, PCI 2.00 x16)
  • Display: SNY05FA - ProductID = 5FA - ManufacturerID = 55629 (0xD94D) - 1366x768 Pixel with 32Bit Colors

I tried the following EDID while trying (I think the first is the right one):

  • 00FFFFFFFFFFFF004DD9FA05000000000413010380221378F2CE50A3574C99260F505400000001010101010101010101010101010101B81A566150000C301020240054BE1000000090165664500014301021360054BE1000000000000000000000000000000000000000000000000000000000000000000000000000000000B9
  • 00FFFFFFFFFFFF004DD9FA05000000002D0C0104901F1100EAA8E099574B92251C505400000001010101010101010101010101010101201C56AE50000C303A3A440035AE10000018000000FC004E76696469612044656661756C000000FC007420466C61742050616E656C00000000FD00003D1D2F0800002020202020000003

I got the first EDID from searching on the installed Windows 7 Version, the second one was found in Google.


Perhaps this information will help one or the other of you guys. If you can get this fu....g netbook work with internal display, please let me know!


Thanx to all and many Greetings from Germany!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Nancy10
      I am having problems with the display pane in system preferences, It doesn't open and splays an unknown error has occurred.
      I am not the best at fixing DSDTs .
      Any help ?
    • By dieupxse
      Hi all,
      I'm install Hackintosh 10.12.6, everything work fine but sometimes my screen appear some square (see the attachment).
      Anyone here can help me fix this ?
      My hack is:
      Core I5 - Sandybrigde 
      Intel HD3000

    • By owiowi
      Hi everyone, 
      I got a very odd problem after updating to 10.12.5 and I'll try explaining it to the best I can along all troubleshooting I did...
      I have a Macbook Pro retina 13" (early 2015) that I've always used with two Samsung external monitors (both are the same model). One of them is connected directly through the HDMI port located on the right side of the Macbook Pro, the other one connected through a thunderbolt-to-HDMI cable. It has always worked until last week when I updated to 10.12.5.
      After the update, I quickly noticed that my Macbook Pro wouldn’t detect any external display via thunderbolt-to-HDMI. Thus, I started a long process of troubleshooting, and here’s all I’ve tried:
      Assuming it could have been a defective cable, I’ve tried 3 different ones, still no luck I’ve tried both thunderbolt entry, still no luck I’ve tried thunderbolt-to-VGA, it WORKS, yes, I know this is insane. I’ve tried to connect thunderbolt-to-HDMI (still with all 3 cables) on older Samsung monitors (again two older monitors were the same model, it was my old setup)… it worked Then, I assumed it was the Samsung monitors that were broken (the two of them at the same time…? Odd, isn’t it?). Thus, I tried to connect them on my mac mini, the same way I always did on my Macbook pro… And it works… Then I tried to reproduce the problem on my mom’s Macbook Pro retina 13” (exact same model I have the problem with and same update)... It works Then I assumed the problem must be coming from my Macbook Pro. Thus, I booted on Windows 8 (bootcamp), it works. Starting to lose my mind… I booted from an external hard drive I have (running an early sierra version), it didn’t work either (I had used this external hard drive in the past and it was WORKING) I've done a factory reset, still not working EDIT (forgot to mention):
      SMC, no luck NVRAM, no luck  
      So in a nutshell, the problem seems to appear only via thunderbolt-to-HDMI, only on this specific Macbook Pro, and specifically on macOS.
      I’m no expert and I don’t know what else I can do. Of course I've tried contacting Apple many times but they keep blaming me for updating my mac and/or Samsung for making the environment not compatible, which I believe is a total nonsense. 
      Has anyone encounter any similar problem? Does anyone know what it could be?
      I’m desperate so I’d like to thank y’all in advance for your help.
    • By xJPN
      Hello all,
      I am getting prepared to build another hackintosh, and I have run into something that is puzzling me. I have 2 Western Digital My Book Thunderbolt Duo external hard drives that I've used for years with my MacBook Pro. It is my intent to begin moving away from using my MacBook Pro whenever I finish my hackintosh. As the title of this thread suggests, I am building a dual boot system with Win7 and OS X. I want to be able to use my external hard drives seamlessly between the two operating systems, but I'm having trouble finding a way that I can plug my drives into when the system is finally built(or perhaps I'm having trouble understanding the concept in its entirety). If you were not already aware, the My Book Thunderbolt Duo's I/O consists only of 2 thunderbolt ports on the rear for connection, no USB. And even if it did have USB ports, I wouldn't be able to daisy chain the two drives, as I do now, which is at the moment also daisy chained in with the monitor I'm using.
      So, is there anything I can buy(like a pci card or hub) that will allow me to plug my thunderbolt hard drives into my computer, that will give me full thunderbolt functionality between both operation systems? Once I get my hackintosh built, I'll be plugging the monitor into the gfx card(obviously), so thunderbolt storage is the main functionality desired. But if there is something out there that supports thunderbolt video and storage in a hackintosh like mine, don't neglect to let me know.
      Here is my pcpartpicker list:
      I am building a custom water loop for this hackintosh, so certain otherwise essential components may be left blank in this list.
      Thanks is advance!
    • By Jurikay
      Hello everyone!
      Long time lurker, first time poster here.
      First of all, big thanks to each and everyone here for providing and advancing solutions, sharing knowledge and making it possible to have a f**king solid, reliable and all around working hackintosh!
      Just by reading through threads i was able to get a completely satisfying setup: Working sleep, audio, pm, usb3, handoff/continuity, imessage, you name it.
      Unfortunately recently I came across a new and rather unique problem:
      A couple of weeks ago I bought a new monitor, equipped with Nvidias G-Sync. To my knowledge this was only available on windows and perfectly acceptable because i use windows for games anyways and macOS primarily for work related stuff.
      Installing the release version of Sierra and the newest web drivers however shows a G-Sync tab in the Nvidia preference pane. But here begin the problems.
      If i tick the G-Sync box and (re)start the computer, the screen goes to black after the first boot stage (which for a brief period of time is expected behaviour in many configurations with nvidia cards i guess) but after that the monitor shows a no connected inputs message.
      These are a couple of ways i found out to still successfully boot Sierra: 
      disable nvidia drivers completely (nv_disable=1, which leads to completely choppy graphics and an unusable system, with my 780ti at least) set to default os x driver in the nvidia preference pane (which leads to slightly reduced performance and no g-sync) Shutting off the monitor before (re)starting and only turning it on again after the os is booted up. (this is also the only way for me to enable G-Sync on mac os, indicated by red monitor led) Note: Only deactivating G-Sync but keeping Nvidias alternate drivers still results in the monitor going black.
      For os x 10.11, I used this guide to fix the second stage bootlogo showing up correctly. This in combination with the new monitor caused similar behaviour in 10.11. Not every but every other restart the screen stayed black. Removing these changes from clover config fixed this problem for 10.11.
      Note: G-Sync seems to be only available in 10.12 even with latest drivers in 10.11.
      in Sierra with default os drivers, the bootlogo and progress bar show up correctly anyways but the black screen, which forces a reset if i forgot to turn off the monitor beforehand is becoming a real annoyance.
      Not using nvidias alternate drivers and losing performance is also not an option in the long run.
      Things I have already tried:
      having an additional display connected changing the initial display output in bios. booting verbose, without cache (booting in safe mode works obviously because nvidia drivers do not load) (re)applying the guide from this topic. completely reinstalling nvidia drivers on windows and macOS side. (nvidia drivers and G-Sync setting on windows seem to have a slight impact on all this but i might be wrong..) modifying AppleGraphicsDevicePolicy.kext's info.plist for iMac 14,2 similar to AGDPfix.app the automatic login settings in os x might also have an impact on this (at least on 10.11)
      I probably missed one or two things but either way i am pretty much out of ideas now. I could try another SMBIOS but with imessage working so well and iMac 14,2 being the best fit for my hardware this seems like unnecessary effort.
      Moreover, maybe because Sierra is still pretty new and G-Sync support for macOS is pretty new, i should give nvidia and apple more time. An update in a couple of weeks might fix this. But I think this is quite optimistic.
      I also don't want to completely rule out that this is my monitors fault. I really hope it is not because i bought it well over a month ago so if anyone has a similar but completely working setup, please let me know!
      Any suggestions on what i could try next are very welcome!
      If console or ioreg output, my dsdt, clover cfg or anything else might be of use for someone, please also let me know.
      Sorry for the long post and thanks for reading it!!
      Some more info:
      Bootloader: Clover (updated very recently)
      SMBIOS: iMac 14,2
      OsxAptioFix2 driver
      DSDT patched with Pjalm's fixes for this board.
      Relevant hardware:
      i7-4770k, GA-Z87-UD7-TH, Asus GTX 780ti, Asus PG279Q connected via DP