Jump to content

Search the Community: Showing results for tags 'Display'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • InsanelyMac Lounge
    • Front Page News and Rumors
    • Reader News and Reviews
    • Forum Information and Feedback
  • OSx86 Project
    • New Releases and Updates
    • New Users Lounge
    • Developers Corner
    • Tutorials (The Genius Bar)
    • Technical FAQ
    • Installation
    • Post-Installation
    • DSDT and SSDT
    • Hardware Components and Drivers
    • Desktops
    • Notebooks
    • Netbooks
    • Tablets
    • MacMod of the Month
    • Multi-booting and Virtualisation
  • International
    • Your Language
    • Deutsch
    • Español
    • Français
    • Italiano
    • Português
    • Русский
  • Apple World
    • Mac OS X
    • Apple Computers and Hardware
    • iOS Devices
    • Mac Applications
    • Mac Programming and Development
    • iOS Programming and Development
    • Mac Gaming
    • Mac Accessories
  • Discuss and Learn
    • Windows Discussion
    • *nix
    • Apple Opinions and Discussion
    • The Great Debates
    • Internet(s), Servers, and Networks
    • Buying Thoughts, Reviews, and Recommendations
    • Mods and Overclocking
    • The Big Issues [Real Life]
  • Everything Else
    • Creativity
    • Thunderdome (Random Stuff)
    • Laughs
    • The Marketplace

Categories

  • Kexts
    • Graphics Cards
    • Audio
    • LAN and Wireless
    • Other
  • Kernels
  • Bootloaders
  • DSDTs
    • Patches
  • Pandora
  • Apps
  • Miscellaneous
  • Customization

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 12 results

  1. The app is finished. After running it automatically get the display data from the first display. If you want to make a patch for the second, change the number above on 2 instead of 1 and press the set display data button. If you have a second screen it will now get the required data. Use DarwinDumper (2.7.6 or better) to get your EDID. In DarwinDumper (2.9.1 or better) open EDID.bin, for older open the EDID.hex file with the open button. Select the Apple Display type to emulate. Press the Make button. Now on your desktop you will get the following new files: - A displayoverride for your display which is patched (probably don't want to use this). - A EDID binary which is patched (handy for 2nd check with edie-decode). - DisplayMergeNub.kext auto tailored for your config (probably want to install this). EDIT: New version V1.1 - Modified driver creation to use the new DisplayMergeNub - Fixed a bug to get 2nd / 3rd / etc display with button (caused crash) - Added basic params override for display to be set as LCD - Fixed Info.plist creation code EDIT: 1.1b - Fixed OSBundleLibraries in Info.plist generation EDIT: 1.2 - Fixed driver file copy bug in case of spaces in path - Added Apple LED Cinema display data and option - Added option for only EDID injection (unpatched) EDIT: 1.3 - Added support for the display classes AppleDisplay and AppleBacklightDisplay (for some notebooks) EDIT: 1.4 - Added IODisplayPrefs check in DisplayMergeNub.kext - Added build target for DisplayMergeNub.kext - Added IODisplayPrefs key in FixEDID for matching on that key - Added optimization for multiple monitors (identical), now you can override each display, even on multiple GPU's individually - Fixed a mistake in just edid override EDIT: 1.5 - Added override for IODisplayPrefs (check/don't check) - Added used display class for the selected monitor auto detection (AppleDisplay/AppleBacklightDisplay) - Updated DisplayMergeNub.kext for handling boolean for IODisplayPrefs use or not EDIT: 1.5b - Recompiled 32-bit kext binary for 10.5 and above - Recompiled 64-bit kext binary for 10.6 and above - Merged both binaries in one universal binary so the kext now works on 10.5 and better EDIT: 1.6 - Added hex2int conversion in ObjC manner (thanks to Marchrius for the hex2int routine) - Changed code to only parse vendor and device once and then convert to int and set the decimal value - So thanks to Marchrius setting the vendor and device values is a lot faster now EDIT: 1.7 - Added version override to EDID V1.4 (fixes some issues) - Added option for adding / fixing monitor ranges descriptor (missing in some EDID's but required by EDID V1.3 or V1.4) - Option for adding / fixing monitor ranges is by default enabled but can be disabled by unchecking the checkbox EDIT: 1.8 - Disabled checkbox for monitor range patch by default (patch can be enabled by clicking on the checkbox) - Rewrote the routine for getting the IODisplayPrefs key and setting the vendor and device id in both decimal and hexadecimal (thanks to Marchrius for supplying the faster routine, I modified it slightly for multiple displays) it now gets the vendor and device id from the IODisplayPrefs key instead of running 2 tasks for getting them. It also is now NSTask and NSPipe based (thanks again to Marchrius). It really is about 4 times faster. - Made override for monitor ranges more generic, it should now work on any display EDIT: 1.9 - List with all the displays implemented from which you can choose (credits: Marchrius) - Reads only once the displays unless refresh is clicked (credits: Marchrius) - Faster setting of display data (credits: Marchrius) - New UI (credits: Marchrius) EDIT: 2.0 - Added display class override to kext - Added display class override to app => This means you can make an AppleBacklightDisplay from an AppleDisplay and vice versa EDIT: 2.1 - Added signed kext - Added signed app (all now GateKeeper compliant) - Added scaled resolutions adding for HiDPI support - More bugfixes EDIT: 2.2 - Added help function - Added remove button for resolutions - Added credits file - Added color profile only patch - Added adding / fixing monitor ranges on no patch and color profile only - Added quick buttons for displays (click menu of display models, type 1 to 7) - Added quick buttons for Display Class (click menu of class, type A or - Added quick buttons for Display Override Class (click menu, type C or D) * For using HiDPI resolutions, use RetinaDisplayMenu, attached below... EDIT: 2.2.1 - Changed synthesized method to direct binding (enables building of 32+64 bit app and adds support for building for versions less than 10.7.X) - Rebuilt FixEDID with a 32+64 bit universal app EDIT: 2.3 - Added iMac Retina panel (iMac14,2) - Added aspect ratio description after panel names (16:10 or 16:9) - Bugfix related to fixing monitor ranges on "Only Inject EDID Unpatched" and "Only Patch Color Profile" EDIT: 2.3.1 - Added MacBook Air panel (MacBookAir5,1) - Added scaleable UI - Added fullscreen app support EDIT: 2.3.2 - Added aspect ratio detection based on first detailed descriptor of the EDID on open of the EDID binary (based on detailed resolution) EDIT: 2.3.2 (2nd build) - Fixed aspect ratio detection, there was a resolution issue and I reimplemented detection based on GCD value (greatest common divisor) NOTE: For 32 bit and 64 bit kext it will need to be rebuilt using an older version of Xcode... Xcode 5.X's clang compiler won't build 32 bit kexts If you have Monitor_Apple.kext or DisplayMergeNub.kext installed and which to patch, remove the kext in /S/L/E and caches, reboot, run DarwinDumper and then run the app, otherwise the display values will be wrong... Enjoy and please give me feedback Source is included Github repo: https://github.com/andyvand/FixEDID Github development repo: https://github.com/andyvand/FixEDID_Devel RetinaDisplayMenu.zip FixEDID-2.3.2.zip
  2. Because I have some problem with my screen .. I'm re-doing the kext for Mavericks Need GraphicEnabler=yes and AtiConfig=Hoolock Because I have re-mapped the Hoolock only.. Need to sleep Have fun PS : this is for people want two screens with a good resolution. the problem at the start is I have just one monitor detected .. Now I have my two screens detected with the good resolution 1920*1080. Connected to HDMI and the first DVI on top.. AMD5000Controller.kext.zip
  3. Hi Geeks, I Had a very annoying Message while booting the iAtkos v7,i just capture a snap-sort of the display message which i had attached with this post, and also a video that will define when the message is been displayed, please help me guyz if anyone had this issue before or know how to get rid of this issue please share. Thank You in Advance & Sorry for Low resolution attachments. Link to the Video : https://www.dropbox....01112_12.32.3gp
  4. macrovers

    GTS 450 not detected

    Hi everybody, i have installed iAtKOS L2 ( lion 10.7.2 11c74 ) on my HP Pavilion a6230in. Issue > GPU not detected and display resolution only 1024x720 ( mine is a HPw1907 1440x900 ) My Specs: Intel Pentium ® Dual CPU E2140 @ 1.60 GHZ. ASUS P5LP-LE 2.5 GB RAM Network Card - Intel Pro 100 VE GPU - ASUS GTS450 1 GB DDR5 The issue is that my mackintosh doesn't recognize my GPU. When i go to > About this mac > System Report > Graphics and Display I get this >> Display: Type: GPU Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 3 MB Vendor: NVIDIA (0x10de) Device ID: 0x1245 Revision ID: 0x00a1 Displays: Display: Resolution: 1024 x 768 Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes The options i ticked during install are : Boot loader > Chameleon 2.1 Boot loader Options > Graphics Enabler Built in Ethernet Patches > FakeSMC Disabler RTC>RTC Ev0Reboot IOPCIFamily Drivers > Main hardware > SATA/IDE > ACHI SATA Sound > VoodooHDA > 2.7.2 USB > USB Hardware Sensors > CPU Motherboard nVIDIA VGA Cards PS/2 VGA > nVidia > GF100 Network > I didn't select anything, after installation i added AppleIntel8255x.kext to S/L/E ( with modified value in info.Plist ) using kext wizard. So anybody who have installed GTS450 or any fermi cards, kindly have a look and suggest me to figure this out.
  5. Hello Folks, after trying "hundreds" of hours to install OS-X Lion on Sony VAIO VPCEB4J1E, I'd like to let you know my experiences about this piece of sh.. notebook. The following Hardware is working without any problems: Keyboard & Trackpad (1448-PS2-Synaptics-Keyboard-32+64) Sound and internal Speakers (VoodooHDA 0.2.7.3) Motion Eye Camera (Out of the box) Bluetooth (Out of the Box) I did the following steps installing Lion 10.7.2 and got it "working": Make bootable USB-Stick with iAtkos L2 Replace "AppleACPIPlattform.kext" and "IOPCIFamily.kext" on Boot-Stick with this Versions of "PCI Configuration Begin Fix" Boot from Stick with this Flags to install: USBBusFix=Yes "Graphic Mode"="1024x768x32" -v Use USB-Mouse & -Keyboard to install Lion After completed installation boot your Lion with connected VGA-Display (connected to VGA-Port) to get output on the internal Display Use the 1448-PS2-Synaptics-Keyboard-32+64 Kext to get Keyboard and Trackpad working Install VoodooHDA with ###### to enable Sound Now the System is booting, but the internal Display is only working well with a connected Display at the VGA-Port (QE/CI doing fine). Disconnecting the external Display and rebooting the System will get a black internal Screen. The system is stable in background but you can reach it via "vnc-access" on a second Mac. I tried to change EDID, different KEXTs, some DSDT-Files from other VAIOs, nearly every Tipps & Tricks I found in Google. - But nothing helped. Now I decided to give up, about 40 hours of trying and searching are enough. If anyone outthere has a solution to get the internal Display working with QE/CI I'd be glad to read about it here. I got the following informations about the hardware while trying: Graphic-Card: ATI Mobility Radeon HD 5470 (80 SM5.0 750MHz, 512 MB DDR3 1.58GHz 64-bit, PCI 2.00 x16) Display: SNY05FA - ProductID = 5FA - ManufacturerID = 55629 (0xD94D) - 1366x768 Pixel with 32Bit Colors I tried the following EDID while trying (I think the first is the right one): 00FFFFFFFFFFFF004DD9FA05000000000413010380221378F2CE50A3574C99260F505400000001010101010101010101010101010101B81A566150000C301020240054BE1000000090165664500014301021360054BE1000000000000000000000000000000000000000000000000000000000000000000000000000000000B9 00FFFFFFFFFFFF004DD9FA05000000002D0C0104901F1100EAA8E099574B92251C505400000001010101010101010101010101010101201C56AE50000C303A3A440035AE10000018000000FC004E76696469612044656661756C000000FC007420466C61742050616E656C00000000FD00003D1D2F0800002020202020000003 I got the first EDID from searching on the installed Windows 7 Version, the second one was found in Google. Perhaps this information will help one or the other of you guys. If you can get this fu....g netbook work with internal display, please let me know! Thanx to all and many Greetings from Germany!
  6. Hi All; I've been trying to find a resolution to a couple of issues i'm having with a new installation of Mavericks (10.9.4) using the Clover (current Version) bootloader on a GA-Z87N-WIFI board. The system in general is performing well; however when asking the system to shutdown or restart, the OS goes through the process (it seems) then the computer turns off (both at shutdown or restart) and then turns back on again - When the OS loads, it advises it didn't shutdown correctly. Wake on LAN is disabled in the BIOS and disabled via the Energy Saving Preferences. Second issue is with the OS turning the displays off. I had this setting on at 5 mins - at this time the displays turn off, but when wanting to wake the displays up (via normal methods), I get nil response - however, the computer doesn't seem to be frozen. Any idea's would be most helpful. Thanks in advance!
  7. Good Morning/Evening to everyone. I currently have 10.8.5 mountain lion installed on my ASUS X73E. My specs are: 2nd Gen Intel i5-2430M Intel hd 3000 integrated graphics 8gb of RAM DDR3 some other stuff but i don't think does are important for the problem i am having ... at-least lol But the problem i am having is when starting , i get the bootloader but then my screen goes blank, but the OS is running in the background (since i can hear the static noise since VooDoo HD doesn't load until i log in.) A temporary fix for now is me switching my computer to HDMI mode by pressing FN + F8 which gives me a artifact looking screen on my computer. Then i would have to plug my computer to my TV via HDMI which turns on my internal screen. After that , I could unplug the HDMI cable and my screen will work fine. But if my computer goes to sleep or something, i would have to do that whole process again , so from keeping my computer from sleeping, i use caffeine. Any fix for that? Everything is working fine (except for WiFI but i use my iPhone as a tether from my router.) Thanks in advance!! Here is a video preview of the problem i am having and how i have to work around it: http://youtu.be/Zb06dcUwm1E
  8. Hi, I am having problems with the display pane in system preferences, It doesn't open and splays an unknown error has occurred. I am not the best at fixing DSDTs . Any help ?
  9. My situation is really strange. I installed Windows 8.1 and Mavericks in one hard disk drive with three partitions, one for each operating system and one just for storage purpose. Since my wireless network card (BCM943142HM) is not usable in OS X, I bought a USB Wifi Adapter (TP-LINK TL-WN725N) so that I could access internet. But when I use a lot of internet bandwidth (downloading torrents) the computer freezes completely. So I decided to work heavy internet use in Windows and just specific tasks on OS X. I’ve been using my computer in this way for almost 8 months without any additional issues. But recently I found somewhere that in order to stop the random freezes caused by the high internet’s bandwidth use, I had to disable Spotlight. So I did it, but the freezes continued. However I noticed that I could use the computer for a longer period of time before it froze again. So here is the problem. Yesterday, after some of this freezes I restarted the computer and now it beeps 8 times while booting indicating a display problem according to Dell, and the display shows up like this while booting and in Windows: But inside OS X the screen turns off. When I perform the display test according to Dell (holding down the D key and then pressing the Power button to turn on the computer) it shows solid colours indicating that the display panel is working correctly. Right now I’m using an external monitor connected to the HDMI port which is working correctly in both operating systems. Inside OS X it’s like there is no display panel connected to the graphics adapter, and in Windows it detects the display panel as a generic monitor. I’m really concerned about this. I know this is not a common problem, so I would appreciate any help!
  10. Hi all, So I have done some pretty extensive searching and can't seem to find a straight answer on if/how this is possible. I am currently trying to use my 46" (I believe) Panasonic Viera TV to display my mac running OSx El Capitan. I can get it running just fine using the VGA port, but I have a DVI to HDMI converter, and have been running my Windows partition using that without any problems. When I try to hook it up to mac, the OS freezes. Everything else is running fine! Would love the help if anyone has any suggestions. Current Machine Motherboard - ASUS P5QC with custom DSDT Processor - Intel Core 2 Duo 4 core @ 2.4Ghz Video Card - EVGA e-GeForce 9800 (uses 980 chipset)
  11. Hi, I have an issue with my new 40" UHD LG TV (40UF695V) that I want to use with my Yosemite. My hardware is a Gigabyte Z97x-ud3h-bk motherboard with a i7-4790K cpu. And I want to use my integrated graphics HD4600. I don't want to buy a dedicated one while I don't use any 3D application or game. The problem is the OS X does not allow to select the max resolution (3840 x 2160). I tested this resolution with Ubuntu live USB stick and the TV work perfectly with my HDMI cable at 4K@24Hz. The TV max Hz is 60 but my HD4600 has a 24Hz limitation. This 24Hz would be perfect for me (I try it out in Ubuntu), but I think OS X block this setting somewhere. How can I unlock this setting and select the max resolution? (Edit some files, patch some kexts, clover setting, etc.) Thanks in advance.
  12. Use DarwinDumper to dump your EDID. Open EDID.bin with a hex editor. Open EDID.txt to check your EDID. First of replace the serial number with this one in the EDID.bin (find and replace). 06 10 12 a0 00 00 00 00 1c 16 This will give you the Apple required serial number. Next replace the chroma info with this to get Apple style colors on your display. 6f b1 a7 55 4c 9e 25 0c 50 54 Last but not least you need to edit one of the descriptors with this one (probably not the first as this is most likely the detailed resolution, use one you don't need). 00 00 00 fc 00 69 4d 61 63 0a 20 20 20 20 20 20 20 20 This will give the iMac display data. Save up the binary and leave it open. Use edid-decode to check the modifications and look for the checksum. Correct the checksum and save it up again. Download iMac_Display_Override.zip below. Edit DisplayProductID-717 with a plist editor (plistedit pro for example). Replace IODisplayEDID Data field with the hex value of your new EDID.bin Open IORegistryExplorer. Look for AppleDisplay (under display0 part under your GFX card). Look up DisplayVendorID. Rename the folder DisplayVendorID-756e6b6e to DisplayVendorID-<your_vendor> Open the folder. Switch back to IORegistryExplorer. Look up DisplayProductID. Rename the file DisplayProductID-717 to DisplayProductID-<your_product> Install the folder in /System/Library/Displays/Overrides Reboot. If you did it right it will look like the picture below Enjoy... Screenshot is made under VMWare Workstation running Mavericks (I didn't have my Mac around right now). EDIT: DisplayOverride is not fully good, use the kext set available below (override download removed)
×