Jump to content

Hackintosh doesn't boot properly everytime :(


wambo0402
 Share

10 posts in this topic

Recommended Posts

Hello!


I finally managed to install Mac OS X 10.6.8 on my AMD based desktop pc (thanks to this forum).

everything works now...the only problem is that my hackintosh doesn't boot everytime i switch it on.

sometimes it gives me a "system uptime in nanoseconds error" and sometimes it just restarts.

i don't know why this happens. i have to restart it 2-5 times before the system starts.

when fully started everthing works fine and stable, except the audio is still not perfect.

 

can anyone help me?

 

system stats:


AMD Phenom X4 9650

AMD 780G chipset

nVidia GeForce GT 220

4 Gb RAM

Link to comment
Share on other sites

Can't help you with out knowing whats causing your error. Boot with -v and give us a screenshot of the output when it panics.

 

If you've installed voodoohda i would suggest removing it and seeing if you still have this error - but thats just speculation.

 

Screenshot of boot is required for us to give you an idea what might be going wrong.

Link to comment
Share on other sites

sorry forgot to upload the pics.

here they are:

 

these two occured while "normal" boot (without "-v")

 

http://www.imagebanana.com/view/mehcn3db/IMG_0512.JPG

http://www.imagebanana.com/view/zybtmatx/IMG_0513.JPG

after the error on the second pic it restarted automatically.

 

these were made while booting with "-v"

 

http://www.imagebanana.com/view/223luzep/IMG_0515.JPG

http://www.imagebanana.com/view/iumo2ghk/IMG_0516.JPG

 

i had to restart a few times because the errors only occur sometimes.

 

and to the soundproblem:

i have voodoohda installed because with other drivers/kexts i don't get any sound...with voodoo the only problem is that it makes a weird noise in the background...like a growl.

Link to comment
Share on other sites

The last picture indicates a problem with ApplePS2Controller which is one of the kexts associated with PS/2.

 

I've also had booting problems with VoodooHDA. During booting, I could hear a "click" when VoodooHDA was engaged. If it was early in the boot, then all was OK. If it was later in the boot, then I would get a kernel panic. I eventually removed VoodooHDA and went back to a combination of a special AppleHDA and a couple of enablers and the kernel panic went away.

 

Anyway, you might have multiple issues and the clearest one right now is the ApplePS2Controller.kext.

Link to comment
Share on other sites

The only thing that produces inconsistent results on multiple consecutive boots is VoodooHDA,really a problematic kext,but can be made to work.The dependencies in backtrace are ACPIFamily and the PCIFamily which got changed quite a bit in 10.6.8 and are OSX Lion-like so that is more likely to be the culprit.Never seen much problems with the PS2Controller kext directly.If you used the legacy kernel installer from nawcom,it installs EvilACPIFamily and EvilPCIFamily plugins in /Extra/Extensions to override the loading of 10.6.8 plugins of the same type (the evil ones are 10.6.7) and they are used when you have graphics problems on AMD systems or an unsolvable PCI Configuration Begin problem which is easily passed with a npci=0x2000 boot flag.If that is the case,remove them and try using original ones with the bootflag i provided.In any case,fix permissions and clear/rebuild the kext caches.IF the PS2 kext is the problem,you might try using other solutions as VoodooPS2Controller.And lastly,try to test the system by not using VoodooHDA for a few reboots and see what happens.Hope that roots out all the possible combinations of problems.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...