Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Pages and Photoshop won't open files on the first try.

9 posts in this topic

Recommended Posts

When I double click on a file to open in Pages or Photoshop (I'm not sure if other programs in those suites are having the same problem), if the application isn't already open, then it will start, and give me an error "The document “X” couldn’t be opened" (Pages) and "Could not load default menus because the file is not compatible with this version of Photoshop" (Photoshop). However, if the program is already running then it has no problem opening the exact same files. Any suggestions?

Share this post

Link to post
Share on other sites

I fixed Photoshop by reinstalling. I have reinstalled Pages multiple times, but with no luck. Photos below








Thanks for the help, sorry for taking so long to reply. The forum didn't tell me you replied.

Share this post

Link to post
Share on other sites

Don't worry I know what it's like to post in a topic and completely forget about it >.>


You have QE enabled right and if so I'm hoping it isn't that pages file that you have that is corrupted. If you can create a new pages file and save it then it might be that sspecific file.

Share this post

Link to post
Share on other sites

I looked up how to check if QE is enabled, got this page



I did the:

sudo -s

defaults read /Library/Preferences/com.apple.windowserver GLCompositor



got 256x256

so from what it says, QE is enabled. And I'm pretty sure ALL of my files aren't corrupted. I mean, I don't see how. And it's not that they can't be opened at all, just if Pages isn't already open they won't open and it gives me that error. So, first double click on the file (pages is completely shut down) and I get error message. Second double click on the file (pages is open in background) and it opens right up no problems. This is on any file that I try to open with Pages. .pages, .rtf, .txt, .doc. Pretty much everything.

Share this post

Link to post
Share on other sites

Okay sounds like an odd issue haven't heard something like this before. List your system specs so I can help out some more on the issue that you're having.


pages version as well also.

Share this post

Link to post
Share on other sites

Hardware Overview:


Model Name: MacBook

Model Identifier: MacBook4,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.4 GHz

Number Of Processors: 1

Total Number Of Cores: 2

L2 Cache: 3 MB

Memory: 6 GB

Bus Speed: 800 MHz

Boot ROM Version: MB41.00C1.B00

SMC Version (system): 1.31f1

Sudden Motion Sensor:

State: Enabled



Version 4.1 (923)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies