Jump to content
Mustafa Can

Need Help About HP Pavilion g6-1095st

38 posts in this topic

Recommended Posts

Hello,

 

I need help installing "Mac OS X Lion" on my "HP Pavilion g6-1095st".

 

I used iATKOS L2 + rBoot LE (chameleon is not working?) for installing os x on my pc. Succesfully installed with "cpus=1 busratio=23".

 

Here is my setup configuration:

  • Bootloader
    • Chimera 1.6

    [*]Bootloader Options

    • Graphics Enabler (default)
    • Built-in Ethernet (default)
    • CPU Throttler
    • Original Apple Boot Logo

    [*]Patches

    • FakeSMC (default)
    • Disabler (default)
    • RTC
      • RTC (default)

      [*]EvOreboot (default)

    [*]Drivers

    • Main Hardware
      • Sound
        • VoodooHDA
          • v2.7.3

        [*]Hardware Sensors

        • CPU

        [*]PS/2

        [*]Laptop Battery

      [*]Network

      • Wired
        • Realtek RTL8111/8168

But, It freezes on apple logo. A woman voice saying "Mac OS X have a screen reader named VoiceOver." I can use my keyboard to manage VoiceOver, so sound and keyboard works! :)

 

Tried many Boot options but none of them work. Here is some of them,

 

"Normal Boot" = Kernel Panic

"cpus=1 busratio=23" = Screen doesn't work.

"-v cpus=1 busratio=9 GraphicsEnabler=No" = "DSMOS has arrived."

"-v -s cpus=1 busratio=23" = Opens Command Line. I can use my keyboard to write something.

 

Seems like I have a problem with my Graphics Card. With some searching I found my pc has 2 Graphics card. One named "ATI Radeon HD 6470M" and other named "Intel HD Graphics 3000"

 

Intel HD Graphics 3000 natively supported by Mac.

ATI Radeon HD 6470M have some problems with OS X

 

I'm totally stuck now and need help!

Share this post


Link to post
Share on other sites
Advertisement

It definitely is a graphics problem. Try booting with -v -x. The -x is safe mode and it will disable the graphics drivers. You will still see a graphical interface, but it won't have resolution control or acceleration. But it will give you a chance to finish booting and then go attack the graphics problem. You might still have to add the cpus=1 and busratio but try the combinations with -x.

Share this post


Link to post
Share on other sites

Most laptops with dual graphics have some way to turn off the HD3000 so that the HD 6740M can be used.

 

What we don't know is which graphics system is blocking you from booting. We'll move the HD3000 drivers out of the way.

 

Boot -s

 

Type:  mount -uw /
Type:  cd /System/Library/Extensions
Type:  mkdir IntelBack
Type:  mv AppleIntelHD* IntelBack/
Type:  mv AppleIntelSNB* IntelBack/

 

Reboot -v -f cpus=1 busratio=23

Share this post


Link to post
Share on other sites

Booted with -v -s cpus=1 busratio=23 and moved intel drivers.

 

Booting with "-v -f cpus=1 busratio=23" causes kernel panic while startup.

 

Booting with "-v cpus=1 busratio=23" causes kernel panic just before VoiceOver starts.

Share this post


Link to post
Share on other sites

While opening lion for take a photo, Screen comes up. Thank you.

 

System Information window shows 2 Graphic cards. One of them is "Intel HD Graphics 3000 mobile (Bulit-in)" and other is "Screen (PCIe)" No QE/CI, always %100 brightness, Screen failed to sleep.

 

 

Things work,

Harddisk and DVD drive,

Battery,

Sound,

Bluetooth,

Webcam,

 

Also things doesn't work,

Wireless and wired networking (no way to internet)

Card reader,

Screen

 

Still testing...

Share this post


Link to post
Share on other sites

Thanks, but that didn't tell me anything about the wireless or ethernet. Would you be able to try the Mac version? Download it in Windows then use a flash drive or something to move it to OSX?

Share this post


Link to post
Share on other sites

No wireless support is very bad for me. Also the program that you gived didn't work. I can set it in control panel but when I connect it to my other pc (it's a windows pc. I bridged wireless and wired connections for connecting internet with mac.) My Mac's ehernet light isn't on and My other pc says "Network cable is not connected". Also in System info it shows Mac uses AppleRTL8169Ethernet.kext for my RTL8101E/RTL8102E ethernet controller.

 

Also I found 3 other problems:

I can't change my sound level. It's aways full level and can't be lowered.

While starting mac most of the time it shows me a Kernel Panic. When I restart it 4-5 times it opens properly.

Mac drains battery very quick. It ends in 1 hour 30 minutes. (4 hours on pc)

Share this post


Link to post
Share on other sites

1. Wireless - You have a Broadcom BCM4313 wireless controller. I looked for a solution and all I found were other people looking for a solution. Therefore, the solution is to insert a new card. This is not uncommon.

2. Ethernet - You have a Realtek RTL8101E/RTL8102E ethernet controller. The solution I gave you came from Realtek. The AppleRTL8169Ethernet.kext is what they provided. I presume that Realtek modified it to meet their specifications. Did you go to System Preferences -> Network and configure the ethernet port in the Mac…give it an IP address or set it to DHCP?

3. Sound - In System Preferences, you might find a control panel (at the bottom) for VoodooHDA which you installed. It has sliders you can adjust. Also, read this: http://www.insanelymac.com/forum/index.php?showtopic=267905

4. Kernel Panic - cannot even hope to do anything about that until we know what it says. Are you able to take a picture of the kernel panic and post it?

5. Battery drain - I don't have a laptop so I don't know the solution for this. Search the forums for a solution. Google: battery drain insanelymac

Share this post


Link to post
Share on other sites

1. OK, I can buy a new wireless card later. Thanks!

2. Yes I tried DHCP and Manual. Still don't work.

3. tried

<key>VoodooHDAEnableHalfVolumeFix</key>
<true/>

but i think i broke something really hard system kernel panics every boot.

4. I added 2 picture 1st one is before vodooHDA fix, 2nd one is after VodooHDA fix.

5.I think it's about my graphics. In windows it switches to intel gpu for save battery. but in mac it still uses Ati gpu without power saving (because osx dont know howto save battery, kext is not installed )

 

Edit: Forget to add pictures

post-580798-0-43663700-1334691842_thumb.jpg

post-580798-0-88750000-1334691889_thumb.jpg

Edited by Mustafa Can

Share this post


Link to post
Share on other sites

1. About wireless. Do you have bluetooth? If so, the bluetooth is built into the wireless card and I don't know a replacement that combines bluetooth with wireless.

2. In the 2nd picture, the driver for ethernet is registering the MAC address for ethernet. So the driver recognizes the ethernet and is trying to bring it up. There may be something else wrong somewhere.

3. You have Windows on this computer, right? If so, I will ask for some info from Windows to see if we can fix sound.

4. Try this to see if it will help you boot:

 

Boot -s cpus=1 busratio=23

 

You should come to a command prompt that says "root:"

 

Type:  mount -uw /
Type:  cd /System/Library/Extensions
Type:  chown -R root:wheel VoodooHDA.kext
Type:  chmod -R 755 VoodooHDA.kext

 

Reboot -v cpus=1 busratio=23

Share this post


Link to post
Share on other sites

1. Yes the card is an Bluetooth+Wifi combo. Bluetooth works but wifi does not.

2. Yes I have Windows + OS X dual boot.

3. It works! I can open os x and adjust sound. :)

Share this post


Link to post
Share on other sites

OK, two things.

 

1. Can you paste the contents of a file here for me? The file has one of two names. /Extra/com.apple.Boot.plist -or- /Extra/org.chameleon.Boot.plist

There may be a flag to set in there to help your ethernet.

 

2. I want to try an experiment to see if we can help your battery situation. But it might cause the computer to panic.

 

 

Boot -s cpus=1 busratio=23

 

At the root prompt

 

Type:  mount -uw /
Type:  cd /System/Library/Extensions
Type:  mv NullCPUPowerManagement.kext NullCPUPowerManagement.kext.bak

 

Boot -v -f cpus=1 busratio=23

 

 

 

NOW, if the computer panics, do the exact same thing, except change one line to:

 

Type:  mv NullCPUPowerManagement.kext.bak NullCPUPowerManagement.kext

Share this post


Link to post
Share on other sites

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Graphics</key>
<string>Yes</string>
<key>Default Partition</key>
<string>hd(0,2)</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Quiet Boot</key>
<string>No</string>
<key>UseKernelCache</key>
<string>No</string>
<key>npci</key>
<string>0x2000</string>
</dict>
</plist>

 

2. Trying it now...

 

Tried it... It repeats this: "Still waiting for root device"

Edited by Mustafa Can

Share this post


Link to post
Share on other sites

OK, undo it as I explained by using the other command.

 

After you reboot, let's try a different ethernet driver and see if that works.

- Go to /System/Library/Extensions and drag AppleRTL8169Ethernet.kext to the Trash

- Give your password

- Download and run this installer: http://www.mediafire.com/?n2ciymqmdgw

- Boot -v -f cpus=1 busratio=23

Share this post


Link to post
Share on other sites

"Still waiting for root device" means that when BIOS hands over booting to OSX, it can't find the hard drive it is supposed to boot. This could be because the driver for the hard drive is damaged or corrupt or cables to the hard drive were affected or something in BIOS was changed. Messing with NullCPUPowerManagement.kext should have no effect on the hard drive booting. Did you do anything else to the computer like open the compartment where the hard drive and wireless live? Or change something in BIOS. The only other thing you did was open org.chameleon.Boot.plist (or possibly com.apple.Boot.plist). Is it possible you changed something in there by accident and then saved it?

 

If we can't find something simple to fix, it might mean having to reinstall.

Share this post


Link to post
Share on other sites

I ca't open the computer or change something in bios, I open org.chameleon.Boot.plist but I dont save it (I'm not sure :) )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By iammask
      My laptop is Hp ab522tx(https://support.hp.com/in-en/document/c04863397)
      Product number T0Z73PA Product name HP Pavilion Notebook - 15-ab522tx Microprocessor Intel® Core™ i5-6200U with Intel® HD Graphics 520 (2.3 GHz, 3 MB cache, 2 cores) Memory, standard 8 GB DDR3L-1600 SDRAM (1 x 8 GB) Video Graphics NVIDIA GeForce 940M (4 GB DDR3L dedicated) I made bootable USB of high sierra. While installing it in verbose mode, I get a blank black screen. Mostly its graphics problem with the kext.
      please help guys.
       
    • By Twml
      I have an HP Elitebook 8460P running OSx 10.13.4 High Sierra
       
      I have an odd issue i believe is related to DSDT patch for ACPI Power battery.
      My battery icon works the battery level goes up/down and battery goes black when charging/white when not.
       
      BUT... Always has a lightning bolt in it and says "Power Source: Power Adapter" no matter if its connected or not.
       
       
      How can i get it to recognize my adapter is unplugged?
    • By crisx95
      Hi, can someone of you palese help me fix the dsdt from my HP 15 p030nl? I need battery mette, back light control and the audio work in. Pls, I'm just bad at this, and before making a mess, i'd like your help. 
      P. S. I'm on High Sierra
      DSDT.aml.zip
    • By End3rPwr50
      Hi, I wanted to install macOs 10.13 on my notebook.
      Here are the technical specifications:
      -Intel i7 6500U 2.50GHz Skylake (CPU)
      -12GB ram dd4 (RAM)
      -hp 81EC (MOTHERBOARD) with BIOS insyde F09
      -Intel HD Graphics 520 - AMD Radeon R7 M440 (Graphics cards)
      -Realtek PCIe FE Family Controller (Ethernet)
      -Broadcom BCM43142 802.11 bgn Wi-Fi M.2 Adapter (Wifi and Bluetooth)
      -Realtek High Definition Audio - Audio Intel® per schermi(HDMI)
       
      Thanks in advance
       


       
       
    • By hopoc
      Hi Guys,
      I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!
       
       
      MY COMPUTER SPEC:
       
      System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB​
       

×