Jump to content

A multitude of problems :(


17 posts in this topic

Recommended Posts

Ok, Im pretty new to hackintosh. I used to have OSX in a virtual machine inside of windows a while back when i was on AMD - and that didn't work well. Anyway, I just converted to intel, so I can have a native hackintosh and all is going semi-well. I do, however, have a few problems.


Before I start, system specs:

Mobo: Asus P8Z68v-lx

CPU: Intel i5 2500k

Graphics Card: nVidia 9800GT

RAM: 2x 4g GSkill Raw 1333MHz Ram


1) I spent about 3 hours yesterday trying to get audio to work. I finally got it to work using voodooHDA v.2.1.62(?) from #######. All is fine except for the constant feedback and crackling on startup. Any ideas on how to fix that? I tried using older versions of Voodoo like a few other threads suggested but none of them seem to remotely work :P.


2) My mother board and CPU Support IntelHD 3000 graphics, and I assigned 480mb shared memory to it, but OSX only picks up 64mb. I have set my SMBios profile as the mac mini as another thread suggested and it didn't seem to help :( Any ideas?


3) My Separate graphics card doesn't seem to even work. I have tried NVEnabler (which I have ten told is old and hasn't worked since 10.6.8). I have Graphics Enabler set to "Yes" but it isn't picked up. I am thinking of just buying a GTX550ti, as according to the OSX86 wiki that card allows dual monitor output correct?


4) I am from the UK, using a non-apple keyboard and my keys are all messed up. I went through the keyboard identification wizard and it identified my keyboard as an ISO keyboard (Europe) which I presumed was correct. But my keys don't quite work properly. On the 2 key, there is an @ instead of an ". The key next to left shift makes § and ± instead of \ and |. and the @ key (apostrophe) makes " instead :( How do I fix this?


5) Scrolling up on my mouse (Gigabyte M6900 gaming mouse) has extra buttons, that I can't rebind, any ideas? Also, scrolling the wheel up makes the page move down (which is really confusing :P)




Link to comment
Share on other sites

1. I tried AppleHDA and got no sound at all. I also tried the rollback AppleHDA in ##### and that didn't help either :S

2. Which next? Where do I put it? :)

3. I did have "PCIUIDRoot=1" in for some reason, that was added by########. Is that the one you mean?

4. Thank you! :D

5. THe problem I think I'll have is OSX recognises all of the other buttons as right click :S There seems to be no manufacturer Kext for this mouse :(

Link to comment
Share on other sites

OK, some more info is needed. What version of Lion are you running? Roughly, how did you install it? Some detailed info about the devices in your computer would be helpful. Please download System Info and show the output from the Devices tab: http://www.insanelymac.com/forum/index.php?showtopic=219584


There is a program called Ukelele that can help you with your keyboard layout: http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=ukelele


For mouse scrolling, go to Apple Menu -> System Preferences -> Mouse and click on the button for "scroll direction"

Link to comment
Share on other sites

I am running lion 10.7.3, installed form iAtkos L2 + Apple 10.7.3 combo update.



Here are my devices:



In System Prefs -> Mouse I dont have a button for scroll direction, I checked there first :D


Also, new problem. I tried to setup a time machine disk on my secondary 1tb drive, and now OSX won't boot :( I get a "cannot find mach_kernel" message upon boot. Chameleon, however, shows the drive as "Lion (1,2)" I hit enter and it can't find mach_kernel. However, If I boot through the DVD it works fine. When I get into OSx, i can see mach_kernel in the root folder of /Lion. Its odd. Any ideas?


Also, when I go into system Prefs -> Startup Disks, Lion isn't listed there, which I find odd.

Link to comment
Share on other sites

For the 9800 GT, need to add your device id to the kext for the card. Add 0x061410de to the Info.plist inside the kext /System/Library/Extensions/NVDANV50Hal.kext.


For the disk booting, you need to install Chameleon. Go to this posting and download and install the 1902 pkg: http://www.insanelym...howtopic=231075


My info.plist looks like this:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<string>NVDANV50Hal 7.18.11 270.05.20f02</string>
<string>NVIDIA NV50 Resman Kernel Extension</string>
<string>Safe Boot</string>


Still no better, the other monitor stays blank :(


I'll try and reinstall chameleon.

Link to comment
Share on other sites

For HD3000, add 0x01128086 to the info.plist of /System/Library/Extensions/AppleIntelHD3000Graphics.kext and /System/Library/Extensions/AppleIntelSNBGraphicsFB.kext


Boot with flags -v -f

Link to comment
Share on other sites

ok, reinstalled OSX to fix the boot :), and the voodooHDA 2.7.2 L) So audio is working. Reinstalled those keyboard layouts so that's fixed.


Now, I just have the intel HD 3000 graphics problem. Youtube videos don't play, so I assume ti is a QE/FI issue (or whatever it's called). So, that's top priority atm.

Link to comment
Share on other sites


  • Create New...