Jump to content

ATI Radeon HD 4550 and latest Chameleon


3 posts in this topic

Recommended Posts

Hello guys,


this is going to be a long post I'm sorry for that =/ I'm also sorry for my english.


Since yesterday I'm trying to get OS X 10.6.3. up and running on my PC with the following specs:


Processor: AMD Athlon X3 425

Graphic card: ATi Radeon HD 4550

Mainboard: MS-7501


Sound: Realtek HD Audio (ALC888S)


The basic installation is no problem: I'm using a ModCD and a retail DVD.


After the installation finished I only got a resolution of 1024x768. I read that the latest Chameleon bootloader will support my ATI Radeon HD 4550 so I downloaded Chameleon Wizard, downloaded and installed the latetest version of Chameleon.


I encounterd no problems during the installation and after rebooting the system I see the Bootloader. After pressing enter the screen turnes gray with a white Apple logo on it.

It seems to be the right resolution for my monitor (1680x1050) but after some time the monitor simply turnes gray and stops loading the system.


After restarting the system I used -v to see what is wrong with the booting process. I noticed that the system stucks a while at:

ACPI_SMC_PlatformPlugin::start -waitForService(resourceMatching(AppleIntelCPUPower-Management) timed out

and turnes in a distorted gray, black and white screen and nothing happens.


I used the ModCD again to boot up the system, what worked for me. Now the monitor had it's previous resolution.


I googled and found this topic: http://www.insanelymac.com/forum/index.php?showtopic=190586 which provides a kext for my card.

After downling the RadeonHD.kext I installed it using KextWizard and rebootet.


Now the system won't start. I tried booting with -s and removing the kext manually (what seemed to work) but the system won't start neither.


I'm a little confused and stressed because I managed to get the full resolution by using only the provided Kext in the thread above. The only problem was that the cursor was distorted and I didn't know how to edit the kext file and reloading the kernel cache (if you haven't noticed yet: I'm a noob :D ).


Now I know that I can use KextWizard to reload the cache but I don't know how the edit the kext file when it's placed in /System/Library/Extensions.


Is it possible to edit the kext before installing?


I hope there is hope for me and my problem.

Link to comment
Share on other sites

ATI/AMD video cards usually requires you to specify a framebuffer, you can also load a patched BIOS and set the number of output ports, all of this via /Extra/org.chameleon.Boot.plist. Look into these settings and how to use them. Also make sure that the ATI drivers that ship with 10.6.3 actually support the Radeon HD 4550, otherwise it's a lot of work for nothing. I can't be more specific, I don't use ATI cards. Go back and check older posts on Netkas' blog for more information, he's the ATI guru. If there's anything specific you have to do to use a HD 4550 you'll probably find it there.


Because of your AMD CPU, AppleIntelCPUPowerManagement.kext is not (can't be) loaded on your system, that's why you see a timeout message for it from other kernel extensions that depend on it (in this case ACPI_SMC_PlatformPlugin.kext is complaining). Those messages are perfectly normal in your case and most likely unrelated to whatever is causing the boot process to halt.


To edit a kernel extension right-click -> show contents. Kexts are kind of like folders, just with a different icon. Usually you'll be opening the info.plist inside with xcode (or Apple's Plist editor if you're on Snow Leopard). You'll want to work on a copy, save it to your desktop, then just reinstall it either manually or with whatever tool you like to use once you're done. Don't forget to make backups of the kext you're working on, I can't stress this enough, it's very important when experimenting. Always keep an unmodified copy at least.


Try to avoid using textedit or god forbid Windows notepad when editing plists, plists are xml formatted and "normal" text editors can screw up this formatting and corrupt the plist. If you for some reason have to edit a kernel extension on Windows, use a proper xml editor like notepad++ or whatever is out there.

Link to comment
Share on other sites

Thank you for your answer, it helped me a lot.


Today I updated to 10.6.8. and enabled Graphics Enabler with Graphics Mode and it works neraly perfect :)

The bootscreen is displayed in the right resolution (1680x1050) but my desktop is only displayed with 1400x1050.

Link to comment
Share on other sites


  • Create New...