Jump to content

DSDT Newbie Help


1 post in this topic

Recommended Posts

I have a P5K Pro that has had Snow Leopard installed for a very long time and everything works except sleep. 2 weeks ago, I installed Lion using the USB Drive approach and everything works except for sound. I've tried all the kext that I can find on Realtek ALC883 and nothing has worked. I have never modified the DSDT before, because I've never had success with it. So, I'm trying to venture into DSDT patching again and didn't get very far. Hopefully, someone can point me to the right direction.


This is what I did.

1) Boot to Lion

2) Start DSDT Editor.

3) Extract DSDT and save in /Extra/dsdt.aml

4) Reboot


This is using Chimera 1.8.0 boot loader.



I wanted to start in a control way, so I figure I the DSDT extract without any modification should work. But no luck. I get a kernel panic:

panic(cpu 0 xxx): "Unable to find drive for this platform: \"ACPI\" ... /Kernel/IOPlatformExpert.cpp:1504



Any help would be greatly appreciated.

Link to comment
Share on other sites


  • Create New...