Jump to content
InsanelyMac Forum
Sign in to follow this  
mtek

Qosmio X500 - 2 DSDT's - 2 problems!

Recommended Posts

Hi,

 

I've got a Qosmio X500 that is running almost perfect as an hackintosh (on 10.7.3) using someone else's DSDT.aml. Since I can't compile my own - lots of errors (201 more specifically!).

 

So I've been using that other DSDL.aml. It runs like a charm (recognizes bluetooth, firewire, memory card) BUT has a big issue in the CPU area: it only recognizes 2 cores (instead of 4 cores this CPU has). So the performance suffers...and I loose some 2000 points in Geekbench for instance... icon_e_sad.gif

If I run without any DSDT the CPU and cores are correctly recognized and the performance is at full level.

 

Meanwhile I've come across someone else's qosmio X500 DSDT.aml that I've tried and this were my conclusions:

- CPU & cores correctly recognized - full performance as without any DSDT

- Sadly no bluetooth working - can't use my beloved magic trackpad. icon_e_sad.gif

 

So I sen here attached both these DSDTS, and was hoping for someone opinion on how to fix the CPU (Cores) issue on the DSDT that has that 'small' issue if possible.

 

Many thanks for any help on this. icon_e_smile.gif

Alex

Share this post


Link to post
Share on other sites
Advertisement

attach in zip files. easy fix . ill fix the buetooth,firewire one that has cpu issues with example of cpu working dsdt

 

Many thanks for your help, but I've managed to do exactly that, comparing the CPU sections of both DSDT's I've noticed that on the "2 core only" DSDT there were missing several processors description so I just added the extra lines and voila everything perfect!

 

Here's what I added to make it work:

 

 

Scope (_PR)

{

Processor (CPU0, 0x00, 0x00001010, 0x06) {}

Processor (CPU1, 0x01, 0x00001010, 0x06) {}

Processor (CPU2, 0x02, 0x00000410, 0x06) {}

Processor (CPU3, 0x03, 0x00000410, 0x06) {}

Processor (CPU4, 0x04, 0x00000410, 0x06) {}

Processor (CPU5, 0x05, 0x00000410, 0x06) {}

Processor (CPU6, 0x06, 0x00000410, 0x06) {}

Processor (CPU7, 0x07, 0x00000410, 0x06) {}

 

 

So now everything's working perfectly - except for sleep (using sleep enabler.kext) - it goes to sleep correctly but when it wakes up the screen keeps black. :(

Share this post


Link to post
Share on other sites

410?? they should be 1010

try booting with

-v DarkWake=1

 

Thaks for the tip - I've added remaining processor info from the other DSDT (with all the CPU's working) and I didn't notice that 'detail'. Now they're all 1010, although to be honest I haven't really noticed any difference - performance wise or in stability with either 410 or 1010.

Could you please explain me as a newbie what do those numbers influence? Would appreciate it. :)

 

I've tried to boot with -v DarkWake=1 - unfortunately it stayed the same - just dark screen after waking-up. :( I guess I'd probably have to have some kind of fix for that issue on my DSDT.

 

I send attached my current & updated working DSDL.aml for fellow Qosmio X500 (& X505 I reckon) users. Hope it can be helpful. :)

DSDT+AppleHDA.zip

Share this post


Link to post
Share on other sites

the voodoohda can be fixed in the plist disable polling or enable SSE2. also if using voodoohda u can remove the hdef in dsdt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Cool! Do you have a link? Googled and didn't see anything yet.   Never mind... you're quick! I just noticed you updated it on the 1st page THANKS!!!!!!
    • I resolved the problem. Just set this coding in your config.plist:   "
      <key>KextsToPatch</key>
              <array>
                  <dict>
                      <key>Comment</key>
                      <string>USB 10.13.4+ by PMHeart</string>
                      <key>Disabled</key>
                      <false/>
                      <key>Find</key>
                      <data>
                      g32UDw+DlwQAAA==
                      </data>
                      <key>InfoPlistPatch</key>
                      <false/>
                      <key>MatchOS</key>
                      <string>10.13.x</string>
                      <key>Name</key>
                      <string>com.apple.driver.usb.AppleUSBXHCI</string>
                      <key>Replace</key>
                      <data>
                      g32UD5CQkJCQkA==
                      </data>
                  </dict>
              </array>     "
    • New Web Driver - 387.10.10.10.30.107 for 10.13.4 build 17E202
    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.
    • all the possible frequencyes i have added seems to work fine at the moment, i have added a lot of different frequencyes to support better all kinds of professional applications, inclunding strange sampling rates and goes from 8khz up to 176.4 khz, unfortunately 192 khz does not seems to work even on cards which should support it like the audigy rx, but other frequencyes just works fine and at the moment i have tested only the sound blaster audigy rx and the audigy sb0090 (1st gen audigy) and i can confirm that all the frequencyes from 8khz up to 176.4 khz does work on that card, so i think that such frequencyes should work on all the audigy 2, 2sz, 4 cards as well, tomorrow i will test with my sound blaster live! cards and i will let you know, but here are also some photos (pro tip: use cmd + alt/opton + 4 and then press space to make a screenshot of a single window):


×