Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


How to verify SpeedStep?

8 posts in this topic

Recommended Posts

Hi guys,

I've tryed to use MSRTools but after install the pkg I can not see anything on MSRTools screen... after the "Initialize...' message it becomes all gray with no info. :(


Is there another way to understand if the Speedstep is woking? cmd line will be fine too... :)

Share this post

Link to post
Share on other sites

Still can't find a way in order to show the instant cpu freq. :(

I've tryed MSR Tools booting my netbook with arch=i386 but still no info on MSR Tools Windows.

I saw that both with arch=i386 and booting without option in the SW info the 64bit option is "NO".

Share this post

Link to post
Share on other sites

You can see your power states in IORegistryExplorer (P- and C-states), how to do that is shown with screenshots in several posts in the topic I linked to. Use a temperature monitoring utility to verify that they are working.


I am not familiar with any utility that actually shows your CPU clock in real time as it changes. AFAIK MSR Tools required you to install a low level driver for it to work at all, otherwise it would show a blank window like you say. I can no longer remember if MSR Tools only worked with the Voodoo Kernel or if it will actually work with the Vanilla kernel as well.

Share this post

Link to post
Share on other sites

FYI.  There is a new multi-os application and api from Intel that shows processor speed and current consumption.




They also have a mac cpuid program -- that just displays info about your cpu.   On i5 it doesn't display current speed.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.