Jump to content

GTX 9800+ strangeness in 10.7.3


2 posts in this topic

Recommended Posts

I did a new install of Lion on a Gigabyte GA-EP45-UD3P with an EVGA 9800 GTX+ 512mb. I have a user DSDT and used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to perform the install.


At first glance everything seemed to be working fine. With the GraphicsEnabler key set to yes, the DVD player worked fine, and the card showed up OK in the system prefences pane.


I then tried to run cinebench and it would not start, it said it could not find the IDD_DISCLAIMER.res file. I can run the same version of cinebench on my other 10.7.3 rig without a problem. I re-downloaded cinebench and it comes up with the same error. I played with the permissons, to no end.


I then thought maybe there is a problem and QL/QE acceleration may not be working right. So I tried using an EFI string for my card from http://aquamac.probo...ack1&thread=509. When I did this things booted OK, but then the monitor went blank after the gray boot screen. So I went back to what I had before with the GraphicsEnabler set to yes and no EFI string.


Now is where things get strange. I hooked up the same rig to my LCD TV, which is where I want to use it. I am using a DVI-HDMI passive cable. I get no video on the LCD TV, I try just the monitor and its fine but as soon as I plug in the LCD, the system hangs and won't respond. I tried swapping connections, same results.


I then try my old leopard install, which I had an EFI string for the card. It works fine, both monitor and LCD-TV. So I know the card can output properly to the LCD TV and the monitor.


I had a lot of problems getting connectors to work on my ATI 6870 which is in my other rig. I had to edit the ATIController framebuffer to get both DVI connectors working with acceleration.


So my questions are:


1. Is there a problem with acceleration with GraphicsEnabler=yes which is causing cinebench to not start?

2. Is the EFI string method I'm using not right? I'm doing it under 10.7.3.

3. Is the LCD TV not working a framebuffer issue?


My goal for this rig is to use the LCD-TV as a monitor by itself and to have QL/QE acceleration.




Link to comment
Share on other sites

To update I have also tried to do an DSDT edit to get the video card working without using graphicsenabler. That was unsuccessful, the system booted but the information was wrong under the system profiler, and the DVD player did not work. Also the fan on the graphics card was at 100%.


So, with the graphicsenabler=yes the system appears to be working OK with the exception of cinebench. I tried connecting the computer to the LCD TV again. Whenever its connected the system locks up. I tried remote access and it works OK but only with ssh and not with screen sharing.


Again to recap:


With 10.7.3, the LCD TV will crash the system, and no cinebench.

With 10.5.8, the LCD TV works fine as a monitor.


UPDATE: With graphicsenabler=no the LCDTV works. I suspect there is something not right with the accleration.

Link to comment
Share on other sites


  • Create New...