Jump to content
InsanelyMac Forum
one0nine

Upgrading from 10.6.2 to 10.6.8 Help

Recommended Posts

Hello all. I'm recently new to the OSX86. I have managed to get OSX 10.6.3 running almost flawlessly, I'm very happy with the install.

 

 

I would like to update it to 10.6.8. as stated above I'm new to the OSX86 and don't know the proper way to update the system, without breaking it.

 

I'm using an Acer AspireOne D150-1920

 

8086:2448--------82801 Mobile PCI Bridge

8086:27b9--------82801GBM (ICH7-M) LPC Interface Bridge

8086:27c8--------82801G (ICH7 Family) USB UHCI Controller

8086:27c9--------82801G (ICH7 Family) USB UHCI Controller

8086:27ca--------82801G (ICH7 Family) USB UHCI Controller

8086:27cb--------82801G (ICH7 Family) USB UHCI Controller

8086:27cc--------82801G (ICH7 Family) USB2 EHCI Controller

8086:27d0--------82801G (ICH7 Family) PCI Express Port 1

14e4:4315--------BCM4312 802.11b/g

8086:27d2--------82801G (ICH7 Family) PCI Express Port 2

8086:27d4--------82801G (ICH7 Family) PCI Express Port 3

1969:1026--------Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller

8086:27d8--------82801G (ICH7 Family) High Definition Audio Controller

8086:27ae--------Mobile 945GME Express Integrated Graphics Controller

8086:27c5--------82801GBM/GHM(ICH7 Family) SATA AHCI Controller

8086:27da--------82801G (ICH7 Family) SMBus Controller

8086:27a6--------Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller

8086:27ac--------Mobile 945GME Express Memory Controller Hub

 

Thanks in Advance

Share this post


Link to post
Share on other sites
Advertisement

1. Clone your partition to another disk

2. Download combo update

3. Install combo update to the backup partition.

4. Once the backup partition is stable, repeat the process on your main installation.

Share this post


Link to post
Share on other sites

Would it be possible to use time machine and back-up my data, apply the update and if it completely fails revert back? If so how would I go about the restore if the update fails and the system doesn't boot? I'm okay with the cloning, however I don't have enough Free space laying around to do the procedures you suggested. My end goal was to use OSX as my main system, so my HDD only has one partition on it. Didn't want to mess with dual booting until I learned more about OSX.

 

Literally I'm brand new to OSX and MAC systems.

Edited by Gringo Vermelho
Redundant quote deleted. Don't quote entire posts when replying directly below them.

Share this post


Link to post
Share on other sites

If you are on Snow Leopard you can use disk utility to clone your partition.

You could always partition your HDD into 2. Once updated you can delete this second partition.

 

You cannot boot from a time machine backup and that is what we want to do. You need to create a bootable second installation which we can use to correct errors on the primary installation, should they arrise.

 

A time machine backup is great if your system goes down and you need to restore it to an earlier point in time, but using that method for updating will be very painful.

Share this post


Link to post
Share on other sites

10-4 I'll Start the cloning process meow, I'm going to assume that my boot loader will automatically detect the other partition and allow me to boot to it.... A feature that has been real handy since I've re-installed OSX 9 times in 2 days lol. Finally got most of the bugs worked out and would hate to re-install it again... Thanks I'll let you know how it works.

Edited by Gringo Vermelho
Redundant quote deleted. Don't quote entire posts when replying directly below them.

Share this post


Link to post
Share on other sites

Okay for documentation purposes, I booted my osx install cd and partitioned my HDD in half. Used the disk-utility and created a DMG of my OSX partition. Then restored it to the second partition, I've booted into the test partition and am currently downloading the combo update and will apply it. "Fingers Crossed"

Share this post


Link to post
Share on other sites

Tip:

If the combo update install should for some reason fail to install (it has for me more than once), boot into the other partition and use it to install the combo update to the other partition (the one you initially tried to install it on).

 

Sometimes the combo update just doesn't like being installed to the active/currently running partition.

Share this post


Link to post
Share on other sites

Tired both npci=0x2000 & npci=0x3000

 

Still hangs in the same place.

 

Sorry for the delay had a baby born this past week and haven't got to tinker much.

Share this post


Link to post
Share on other sites

Congrats mate.

Try updating your boot loader to Chameleon 2.1 r1819 (available in the new releases sub-forum) then give it a go.

I can't remember exactly but I know that the 10.6.8 kernel had a lot of changes in prep for Lion, so a newer boot loader might help. It definitely won't hurt anyway.

Share this post


Link to post
Share on other sites

If you have a look in the new releases sub-forum there is the announcement thread for chameleon 2.1 r1819, in the first post there is a link to the installer.

Just run that and it will do everything for you (make sure you target your OS X partition in the installer).

 

If your interested in learning to install manually, download the tar.gz, within this there will be instructions.

It is good to know how to do this just incase you are ever locked out but non-essential.

Share this post


Link to post
Share on other sites

Found This, tried downloading the files, however the site seems to be down from my end so I can't try this method, and its very vague.

 

http://www.insanelym...howtopic=253546

 

Alright as it turns out I was using the latest boot loader. I got the kexts from the above thread. The OS locked up when I tried to replace the kexts. So What I ended up doing was booting to my first partition and running the installer, changing the destination to my second partition, replacing the kexts and using disk utility to repair the permissions... It worked!!! However now my wireless is now not working and the GFX card is not working... What should I do now?

Share this post


Link to post
Share on other sites

Graphics:

You need to patch AppleIntelGMA950.kext and AppleIntelIntegratedFramebuffer.kext

 

Find 86 80 A2 27 and replace it with 86 80 A6 27, this should get your primary monitor working.

 

You will need to do exactly the same for your external monitor but I can't find what you should replace. You need to insert 86 80 A6 27 in place of the default apple secondary output (trying to find the value for you atm).

 

Wi-Fi:

Google 'Atheros AR8121/AR8113/AR8114 os x', see the first result.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • HWMonitor2 v2.1.0rc3:  
    • There are new Bios updates that came out. I think these were to address the security defects in the kernel?   I updated both my 790 and 990 without issue.
    • Crack download software petromod v2016.2 GeoTeric v2017 paleoscan v2016.1 Leica CloudWorx v6.2 techlog v2016.1
      ttmeps#gmail.com ----- change "#" to "@"
      Anything you need,You can also check here: ctrl + f
        midas civil 2018 v1.2
      symmetre r410
      CP-Studio
      kepware 5.20
      saia PG5 2.1
      Motocom32 dx200 plus
      procon-win 3.5
      midas soilworks 3.5
      geostudio 2012
      technet GMbH PreDesigner 2017
      framecad structure v8
      csi preform 3d v6
      geogiga seismic pro 8.3
      citect 7.2
      3dbody 7.0
      3shape convince
      plastycad
      hypermill 2018
      deswik suite 2017.1
      Scania XCom 2.30
      tebis 4.0
      3shape implant studio 2017
      Cape pack V2.15
      Prinect Signa Station 2017
      exoplan 2017.03
      MagiCAD 2018 
      ExoCad 2017.12
      MillBox 2016
      GOM ARAMIS 6.15
      Blue Sky Plan v3 x64
      Maestro 3D Dental Studio 4
      Sirona InLab 4.2.5
      Maestro Ortho Studio Build 2.8
      Zirkonzahn 2017
      Dolphin Imaging 11.9
      Digital Smile System 1.9.8
      PlastyCAD 1.7
      3Diagnosys 4.1
      ArKaos MediaMaster 5.0.3
      smile designer pro v2.6.1 
      GEO5 2017
      TRUSS4 v10
      exocad Partial Framework 2017
      OnDemand3D Application 1.0.10.5385
      Dental Master 2016 
      Dental Wings (DWOS) 2016
      Ekahau Site Survey 8.6.1
      HYPACK 2016
      Dental Shaper
      Orcaflex 10.0e
      AQWA
      MOSES
      NAPA 2017
      offpipe
      maxsurf
      DNV GL AS PHAST
      DNV safty offshore 7.2
      aveva bocad suite 2.2.0.3
      AVEVA Engineering v14.1 SP1
      Aveva everything3D (E3D) v2.1
      napa ship designer
      numeca fine
      marine 3.1
      Veristar Hull, Stability, Homer, Optimise
      Hydrostar, ariane7
      AVEVA Marine 12.1 SP4.29
      sacs 11.0
      DNV Sesam all moduels
      Leica GEOMOS v5.0
      Rocscience RS3
      3shape orthodontic 2017
      Onyx ProductionHouse v12.1
      pc-dmis 2018
      exocad DentalCAD 2.2 Valletta
      exocad 2018
      frontline genflex 3.2c1
      frontline genesis 10.02
      ez-fixture 9.6.4
      ezgrid 9.5
      ucam 10.2
      em-test expert v8
      3shape design system 2017 2.17.3.0
      PC-DMIS 2018R1 x64
      Motor-CAD/Motorcad 11.1.5
      Synopsys Synplify FPGA 2017.09 Win&Linux FPGA
      Golden Software Strater 5.4.948
      Golden Software MapViewer 8.6.651
      Waterloo Visual MODFLOW Flex 2018.v5.1
      Cype 2017m
      Intergraph SmartPlant Spoolgen Isometrics 2014.v08
      Intergraph SmartSketch 2014.v08.00.00 R1
      Intergraph CAESAR II 2018 v10.00.00 x64
      Intergraph SmartPlant P&ID 2014 R1
      IHS QUE$TOR 2017 Q1
      Intergraph SmartPlant Review 2017 v12.00.00.0501
      ANSYS Apache Totem 14.1 Linux64
      Crosslight Csuprem 2018 x64
      Ensoft LPile 2018.10.02
      AnyBody Modeling System 7.1
      Antenna Magus 2018.0.v8.0 x64
      CGERisk BowTieXP 9.0.1
      PDI GRLWEAP Offshore Wave 2010-7
      NI AWR Design Environment with Analyst 13.03 x64
      Rock Flow Dynamics RFD tNavigator 2017.v17.3 x64
      CMG (Computer Modelling Group) Suite 2017.10
      PHDwin2.10.3
      meyer 12 2017.12
      Schlumberger petrel 2017
      HampsonRussell Suite 10.3 
      geoview 10.3 HRS 10.3
      Midland Valley move 2018.1
      jason 9.7
      Schlumberger CoilCADE 6.0
      Schlumberger StimCADE 4.0
      crystal 2018.1
      gohfer 9.0.1.6
      omni 2017.1
      tesseral pro 5.0.3b
      ERDAS IMAGINE 2018
      Waypoint Inertial Explorer 8.7
      Deswik suite 2017
      FAROBox PointSense plant 18.5
      EyeRadar 2.0
      Leica Xpro 6.4
      Trimble EdgeWise_v5.0.2SP1
      Trimble Business Center 4.0
      3DReshaper 2017 x64
      Amberg Tunnel 2
      virtual surveyor 3.6
      cloudworx for revit
      socet set 5.6
      socet GXP 4.1
      OrbitGT
      Riscan PRO 2.0 x64
      JAR reconstrucer 3.3.0 x64
      Materialise E-stage v6.6
      Virtual Surveyor 3.5
      CARIS HIPS and SIPS 10.2
      DP-moderler
      APS 7.6
      Imagestation SSK 2015
      Deswik 2017.2.1234
      EnterVol 2017.4 for ArcGis
      Geochemist Workbench 11.0.8
      Maptek Vulcan 10.1.4
      Tesseral Pro 5.0.3
      Tesseral 2D 7.2.8
      Global Mapper 19.0.2
      GEOVIA Surpac 6.8
      Ventsim 4.8
      MineSched 9.1.0 x64
      Paradigm 17
      VUMA3D-NETWORK 2018
      MineSight 12.0
      Maptek Eureka 4.1
      whittle 4.7.0.1
      Leapfrog Geo 4.0
      Leapfrog Geothermal 3.2
      Leapfrog Hydro 2.6
      OptiSPICE 5.2
      VPI transmission maker 9.8 x64
      VPI photonics Analyzer 9.8 x64
      VPI componentMaker 9.8 x64
      socet gxp 4.3
      GEOVIA GEMS 6.8.1
      GamaPrintPro
      PosterShop
      RipCente
      ProductionHouse 12
      neoStampa 8.1.5
      Fiery XF v6.5
      ORIS COLOR TUNER WEB 3.1
      ORIS PRESS MATCHER WEB 1.4
      FlexiSIGN & PRINT 12
      PhotoPrint 12 Cloud
      ColorGate V10
      neo Textil
      ACRORIP 9.03
      ErgoSoft RIP 15
      3shape trios 1.4.7.4
      OptiSystem 15
      plaxis 2D 2017
      plaxis 3D 2017
      Rocscience SLIDE3 V2017.010
      Rocscience SLIDE V7.029
      Rocscience RocData v5.008
      Rocscience RS3 v2.005
      Rocscience RS2 phase2 v9.023
      ITASCA 3DEC v5.20.250
      ITASCA Griddle v1.0.1
      ITASCA UDEC v6.0.323
      ITASCA PFC v5.0.32
      ITASCA Flac3D V6.0.48
      ITASCA Flac v8.0.443


×