Jump to content

acer aspire 5750 + iAtkos L2 / Lion


2 posts in this topic

Recommended Posts



I am facing a problem with iAtkos L2 DVD, it freezes whenever i press any key or F8, or just if i leave it to finish counting, the screen freezes to the iAtkos logo and nothing happens, i tried this same DVD with a different laptop and it worked without any problem.


My laptop is acer aspire 5750, it has a i5 CPU with Intel HD Graphics 3000, i tried changing the very few BIOS options (AHCI to IDE, booth order ...etc) but no luck.


I tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], it booted the iAtkos, read the DVD files then the laptop auto restarted it self.


thank you for reading and posting your thoughts, i'll be refreshing like a crazy trying to get this to work.

Link to comment
Share on other sites

  • 1 month later...

sorry to bump an old thread, but i am in the same situation! acer 5750, iv tried iatkos l1 and l2 and get the same result, when the dvd boots if i press any key it just freezes, if i wait for the timer to finish, it freezes. Had no luck in booting via usb. sometimes if i boot using ###### cd with iatkos on usb, i get an error saying something like "unable to find driver for this platform /acpi"


i have set the bios to ahci. I removed 4gb of ram so i now have 4, from 8. tried booting it using -v and -x with no luck.


acer 5750 core i5 2430m 2.4ghz

8gb ram (removed 4gb to make it 4)

500gb hhd

optiarc bluray drive

intel hd 3000 graphics


i am going to try iatkos s3 v2 then uprage soon, as i had succesfully installed it on an old laptop, but wanted to try lion really.


is there any other way i can install lion? oh yeah i dont have access to a mac computer, which makes things awkard because most of the guides/tutorials need a mac to start off with (which would be pointless doing a hackintosh if you have a mac?!?)


hope someone can help! if you need any more info off me, ill be refreshing like mad! pulling my hair out here!


forgot to mention i was following this guys guide, he seems to have got it working on the same laptop (sort of) but his instructions arnt very clear!



Link to comment
Share on other sites


  • Create New...