Jump to content

PRO help Required in Post Installation


23 posts in this topic

Recommended Posts

I am having a HP DV6 laptop with following configuration.


Core i7 2630QM


HD3000 graphics

AMD Readon 6770m 2GB

MAC Lion 10.7.0 and 10.7.2 Dualboot


facing following problems in both 10.7.0 and 10.7.2.


Problem-1: :fiery:

System have two USB controllers 1c26 and the other one is 1c2d.

to 1c26 controller 1.Ralink RT539f WiFI and

2.Ralink Bluetooth

3.2 USB3 Ports


and to 1c2d controller 1.True Vision HD webcam and

2.Validity Fingerprint Scanner

3.2 USB2 Ports

are connected.


Out of both, 1c26 controller with WiFI, Bluetooth and USB ports working correctly and

USB2 devices plugged are also being detected in this port,

but device 1c2d controller with True Vision HD webcam,Validity Fingerprint Scanner and usb2 ports

not at all working.

I know that there are no drivers for Validity Fingerprint Scanner for MAC OS but the webcam is not also working.

Whenever i plug any USB device to any of the 2 USB ports on this controller(1c2d) the system freezes and

i have to restart the system by pressing and holding the power button.


Problem-2: :fiery:

Secondly i have 3000 HD graphics and AMD readon 6770m built in and both are being detected

in system information(through DSDT edits), but i am unable to switch to AMD graphics.

I am only able to run with HD3000.

gfxCardStatus software says "please use a system with dual GPUS".

can anybody advise me how to enable graphics switching?


Problem-3: :fiery:

Follwing hardwares are also not working.

Ralink RT539f WiFi (0x1814,0x539f) on PCI-J6C2 : no drivers found yet

Realtek card Reader 5209 (0x10ec,0x5209) on PCI-J6D2 : no drivers found yet

Realtek 8168 Gigabit ethernet (0x10ec,0x8168) on PCI-J5C1 : driver is not loading for it


Any help will be highly appreciated.....


thank in advance....

Link to comment
Share on other sites

  • 1 month later...

mine also freezes and i also have to hard shutdown; but only for USB2 ports.

Strange thing is that USB3 ports work fine with USB2 devices like external HDD, Mouse etc. So 2 USB3 ports working & 2 USB2 ports not working. :huh:

Link to comment
Share on other sites

I don't think you need two Lion systems...unless one's a backup. From what I know, there aren't too many fundamental changes to cause problems between the two versions.


Have you tried adding your USB controller to the USB kext?

Link to comment
Share on other sites

  • 2 weeks later...

Sorry for replying late PookyMacMan.....busy in getting Mountain Lion DP running in my laptop.


I am continuously getting the following error when starting to use WebCam.

i have tried photobooth,macam and many other webcam softwares but none of them make the WebCam work.


I am currently having quadra-boot laptop with SL 10.6.7, SL 10.6.8, Lion 10.7.3 and ML 10.8.0 DP. i am getting same following errorlog in all 4 OSs when trying to run the webCam.


MacBook-Pro kernel[0]: 0 0 AppleUSBCDC: start - initDevice failed


MacBook-Pro kernel[0]: USBF: 475.408 AppleUSBEHCI[0xffffff800c809000]::Found a transaction which hasn't moved in 5 seconds on bus 0x1a, timing out! (Addr: 3, EP: 0)


and it is repetitively occurring in console.


My USB hub details are :


USB High-Speed Bus:


Host Controller Location: Built-in USB

Host Controller Driver: AppleUSBEHCI

PCI Device ID: 0x1c2d

PCI Revision ID: 0x0005

PCI Vendor ID: 0x8086

Bus Number: 0x1a




Product ID: 0x0024

Vendor ID: 0x8087 (Intel Corporation)

Version: 0.00

Speed: Up to 480 Mb/sec

Location ID: 0x1a100000 / 2

Current Available (mA): 500

Current Required (mA): 0


HP TrueVision HD



Product ID: 0xe258

Vendor ID: 0x064e (Suyin Corporation)

Version: 4.00

Serial Number: HF1016-A821-OV01-VH-R04.00.00

Speed: Up to 480 Mb/sec

Manufacturer: SuYin


Location ID: 0x1a120000 / 3

Current Available (mA): 500

Current Required (mA): 500


Vendor-Specific Device:


Product ID: 0x0018

Vendor ID: 0x138a

Version: 0.78

Serial Number: d8ff936f5267

Speed: Up to 12 Mb/sec

Location ID: 0x1a110000 / 4

Current Available (mA): 500

Current Required (mA): Unknown (Device has not been configured)


The two USB 2.0 ports are also not working on this hub...system hangs when a device is plugged even a mouse (tested in in all 4 OSs)


i think may be issue related to current distribution in devices...? Can proper DSDT edit solve this error?


any idea ?

Link to comment
Share on other sites

Most likely DSDT can help. Post over in the DSDT forum. Unfortunately I can't help since I don't know much about DSDT.


Another thing you may want to look up is the EvilIOUSB driver...that might help.

Link to comment
Share on other sites

I almost succeeded in snow leopard 10.6.8. i just don't remember what i have installed in it but webcam and usb started working (snapped some shots from photobooth and plugged usb drive; all worked) but for some time but after that :ihw_pop: KernelPanics. :shock: and the 10.6.8 doesnt boot now. Reinstalling 10.6.8 again. :wallbash:


Anyways if it has worked once than it will surely work again also. I must keep trying. :moil:


One more point, can you throw more light at "EvilIOUSB driver". i googled it but did not find anything.....

Link to comment
Share on other sites

Hm...it might be a private driver...unless I'm getting it mixed up with EvilIOPCIFamily...I'll check it out.


Seems it is. Here's the driver. Put the 2 kexts in /S/L/E and delete the existing USB kexts.

Link to comment
Share on other sites

  • 4 weeks later...





The devices are being mounted on USB 3 super speed Bus and till the time i am looking in USB EHCI 1c2d controller...!!!!


One more problem, the USB2 port is working randomly.

Some time it acts normally and USB2 devices are mounted and some doen't work and the system freezes upon plugging a USB2 device.


Do you have any idea what is causing the problem..?


May be an IRQ conflict....?

Link to comment
Share on other sites

still i am not able to understand why it is behaving randomly...? :|


once in 10 attempts a device is being detected.. :wallbash:


still trying to understand under what conditions it is working...?

it is a USB3 driver problem only......(Renesas USB3).


now i am trying to figure-out what condition are making it work. :moil:

Link to comment
Share on other sites

Personally I would post in the DSDT forum. One of the DSDT gurus over there, LatinMcG, will probably help you out. :)


You could PM him, but not everyone is open to PMs asking for help...so posting in the DSDT forum is probably your best bet. :)

Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...