Jump to content

QE/CI Appears Enabled But Isn't - Inspiron 1520

24 posts in this topic

Recommended Posts

Hi all,


I have recently completed the (mostly) successful installation of iATKOS S3 V2 onto my Dell Inspiron 1520 laptop. I did try Lion however despite 3 full redownloads and burns onto different discs I couldn't get the disc to boot past one of the rdisk files it loads.


The installation went through without a problem and everything appears to be functioning. I have sound, internet, usbs all working etc.


QE/CI is the only thing that appears to be causing a problem, it seems that it is enabled as I can select both of my displays and can adjust their resolutions to maximum.


My system profiler shows the correct graphics card and can identify my displays correctly.


I cannot, however, load up front row as it goes to a black screen or play a DVD (error "A valid video device could not be found for playback. [-70017]").


The following image shows that my 8600M is identified on boot up -




And this one shows my system profiler -





I've tried to edit my DSDT to see if there is anything incorrect in there using DSDTE. My DSDT doesn't appear to mention anything about a graphics card. I've uploaded a copy, please can anyone tell me why my DSDT appears to be so incomplete?




I also don't have a com.apple.boot.plist file in my /extra folder to edit the graphics enabler string. There is a file of this name in the /library/preferences/systemconfiguration/.


Because my card is an 8600M I cannot use the EFI Studio as my device isn't listed and if I try to use OSx86 to manually add EFI Strings I get the following error - Can't make "0" into type boolean. (1700).


From what I can see, my /extra/extensions folder has the NVenabler64.kext in it.



Link to comment
Share on other sites

Don't quote me on this, but QE/CI does not enable you to change resolutions. Usually the two are linked, but not always.


For example, you do not have the translucent menu bar and the Front Row and DVD Player don't work. Most likely Dashboard doesn't have the "ripple effect" when you add a widget.


You probably can make a com.apple.boot.plist for your Extra folder if you want one.


I'd try to find another nVidia enabler and use it instead of NVenabler. I'll look for one. :)

Link to comment
Share on other sites

Ah fair enough. Through many of my searches I read that it was one sign that QE/CI was likely enabled.


Thanks a lot, I really appreciate it!


I tried using a universal injector from this site - http://netkas.org/?p=104


Now I'm getting an LPC device initialization failed error.




I've checked my BIOS, all my settings are as they were before and as limited as it is, what with being a laptop, those settings were fine.

Link to comment
Share on other sites

I found something; it uses NVenabler. Give this a shot:


First what we need to do is check to see if your card's device ID is in the graphics kext (check the ID in System Profiler). I think it already is, but this is just to make sure. Open Terminal and type:


sudo nano /System/Library/Extentions/NVDANV50HAL.kext/Contents/Info.plist


Enter your password and look for "IOPCIPrimaryMatch". Underneath (or beside) it should be a string of hexadecimal digits preceded by 0x. The format is 0x[deviceID][vendorID], so look and see if the first four digits of any of the codes match your device ID. If it's not there, go to the very front and type 0x[yourdeviceID]10de. Once you're done, press Control-O and Control-X. Now type:


sudo nano /System/Library/Extensions/NVenabler64.kext/Contents/Info.plist


Look for IOPCIMatch. Underneath (or beside) it change 0x000010de to 0x[yourdeviceID]10de. Press Control-O and Control-X.


That should be it. Restart and see what happens. :)

Link to comment
Share on other sites

Thanks for the instructions pooky, unfortunately it hasn't resolved the issue.


I made all the changes as you advised, following those instructions.


The NVenabler64 kext wasn't in the /system/library/extensions/ directory though, I could only find it in the /extra/extensions folder but the device ID did show 0x000010de as expected so I changed that.


Before I rebooted I opened the plists via finder to make sure the changes had taken affect. They had, I rebooted and still the same unfortunately. My system profiler shows exactly the same and the plists haven't been changed back. Still no QE/CI though :(.

Link to comment
Share on other sites

Your graphics card seems to be functioning, since you have maximized your display as you said. Why don't you try typing GraphicsEnabler=Yes before booting into your system? That did the trick for me. If that works, then go to /Extra drag com.apple.Boot.plist to your desktop, open it with TextEdit and add <key>GraphicsEnabler</key> *press enter* <string>Yes</string> and then delete the original (after you made a back-up of it) and replace it with the one you just modified.

Link to comment
Share on other sites

Thanks guys, I tried the graphicsenabler prior to boot but issue still remains.


I don't have a com.apple.boot.plist file in my /extra folder though, only in - /Library/Preferences/SystemConfiguration/


This file shows graphicsenabler is set to yes.


Would it be worth me copying the file into the /extra folder?

Link to comment
Share on other sites

That's rather strange. a com.apple.boot.plist file is present in my /Extra directory. Although I doubt it will make a difference if you copy it there, it wouldn't hurt to try.


Is there an Extensions folder in /Extra? If so, are there any kexts inside?

Link to comment
Share on other sites

Is maybe the version of Chameleon a little old?


I have read a lot of things about problems with distros. Maybe you can try a different version of Chameleon, too.

Link to comment
Share on other sites

It looks promising, actually. :)


The DSDT wouldn't have a GFX section; rather it goes by PCI device number. So, your video card is PCI(somenumber).

Link to comment
Share on other sites

I agree with iBifteki. Retail installation is much better and fun. :)


However, the only thing is the issue will probably still be there. I would go ahead with the retail installation.


Not to be dissappointing, but as I am a busy person, it may take a day or two to patch the DSDT.

Link to comment
Share on other sites


  • Create New...