Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Is my XFX Radeon HD 6870 2GB GDDR5 framebuffer ok?

2 posts in this topic

Recommended Posts



I just installed a XFX Radeon HD 6870 2GB GDDR5 ("Dual Fan -DD" edition), but I'm worried my Duckweed framebuffer is not ok. Could someone verify or is everything ok?

I can play chess and DVD player.


Cinebench score is only 36.10. That is too low... what to do?


OS X Lion 10.7.2


Chameleon version:

Chimera 1.7









ioreg | grep ATY

+-o ATY,Duckweed@0 <class AtiFbStub, id 0x100000336, registered, matched, active, busy 0 (697 ms), retain 7>

+-o ATY,Duckweed@1 <class AtiFbStub, id 0x100000337, registered, matched, active, busy 0 (7 ms), retain 7>

+-o ATY,Duckweed@2 <class AtiFbStub, id 0x100000338, registered, matched, active, busy 0 (8 ms), retain 7>

+-o ATY,Duckweed@3 <class AtiFbStub, id 0x100000339, registered, matched, active, busy 0 (6 ms), retain 7>



Using PCI-Root-UID value: 1

Framebuffer @0xE0000000 MMIO @0xFBAC0000 I/O Port @0x0000BE00 ROM Addr @0x00000000

ATI card POSTed, reading VBIOS from legacy space

(AtiConfig) Framebuffer set to: Duckweed

Nr of ports set to framebuffer's default: 4

ATI Barts AMD Radeon HD 6870 Series 2048MB (Duckweed) [1002:6738] (subsys [1682:310a]):: PciRoot(0x1)/Pci(0x3,0x0)/Pci(0x0,0x0)


I noticed that my 1682:310a is a different from others xfx cards. Probably the 2GB?


Btw: The fan is working all the time, not a full speed, but not like it does in bios/boot area. Then its pretty darn silent. In Linux Mint as well. When OS X Lion login screen appears the fan kicks in again, if you catch my drift. So there is a problem in OS X and fan control.


Thank you in advance :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By yungyulli
      hello I am using a laptop and using the ig-platform-id 0x0a260006. I have a intel hd4600 graphics on my intel 17-4710hq cpu and currently I only have 1536mb of ram but the max my graphics can support is 2GB so I need a point in the right direction of how to go about changing this so that I can utilize all 2GB of possible intel integrated graphics. I'm trying to learn some stuff!!!
      is there a patch I need to create?
      is there some code I need to edit?
      anything helps as I am new to hackintosh. I just installed mines like a week ago.
      thanks anyone for the help.
    • By Devonavar
      Putting this here for posterity in hopes it helps someone else (maybe just my future self).
      I just spent 2.5 days getting my previously working HD5750 up and running after a motherboard swap.  At the same time, I upgraded to Sierra.
      Here's what I wish people had told me about patching your framebuffer in Clover:
      Patches only take effect with "WithKexts" in boot args.  At least, that was the case for me. Patches don't get recognized if they cross line breaks (yes, even in a binary file there are line breaks).  Thus, attempting to patch a multi-line framebuffer fails in a single patch.  I believe this is why the official "ATIConnector" patch sometimes fails. If someone had spelled out those things for me, I would have been done in a few hours, not a few days.
      That said, here's my working configuration:
      Card details:

      Asus HD5750, 1GB vRAM, Mfr ID:  0x1002 (ATI), Device ID:  0x68BE  Subsystem ID (useful for matching BIOS):  0x03381043
      Card on TechPowerUp:  https://www.techpowerup.com/vgabios/79262/asus-hd5750-1024-100331
      Working Framebuffer (note the extra 2 bytes at the end of each line compared to most examples ... I believe this is a Sierra quirk):
      10 00 00 00 10 00 00 00 00 01 00 00 00 00 00 00 02 12 04 03 00 00 00 00
      00 08 00 00 04 02 00 00 00 71 00 00 00 00 00 00 22 05 01 01 00 00 00 00
      00 04 00 00 04 06 00 00 00 71 00 00 00 00 00 00 21 03 02 02 00 00 00 00
      02 00 00 00 00 01 00 00 00 71 00 00 00 00 00 00 11 02 02 04 00 00 00 00
      To get it working in Clover v2.3 r3766 (Use Clover Configurator to make your life easier):
      Spoof Device ID as 0x100268B8 ("Fake ID" in "Devices") Check Inject ATI (in "Graphics") FB Name "Alouatta" (in "Graphics") Video Port "4" (in "Graphics")  (Setting ports to 4 with the Alouatta personality will initially recognize both the HDMI and DVI outputs, but they will detect with the monitors swapped) Custom Boot Flag:  "WithKexts" (in "Boot")  
      Three separate patches in "Kernel and Kext Patches", one for each output:
      Name:  AMD5000Controller, Find:  00040000 04060000 00710000 00000000 11020101 00000000, Replace:  00080000 04020000 00710000 00000000 22050101 00000000, Comment:  HDMI Name:  AMD5000Controller, Find:  00040000 04060000 00710000 00000000 22050404 00000000, Replace:  04000000 14000000 00710000 00000000 11020204 00000000, Comment:  DVI Name:  AMD5000Controller, Find:  02000000 00010000 19010000 00000000 12040303 00000000, Replace:  10000000 10000000 00010000 00000000 02120403 00000000, Comment:  VGA (not tested)  
      Useful resources:
      Premade kexts for El Capitan (was working in my previous config):  http://www.osx86.net/files/file/4609-hd5750-0x68be-el-capitan/ Official Clover documentation for ATIConnector patching (and the only place where WithKexts boot flag is mentioned.  Doesn't mention the issue with multi-line patches:  http://www.insanelymac.com/forum/topic/282787-clover-v2-instructions/?do=findComment&comment=1853099 Official Clover documentation for patching any kext (needs to mention WithKexts boot flag):  http://www.insanelymac.com/forum/topic/282787-clover-v2-instructions/?do=findComment&comment=1853204 Excellent how-to guide for creating a framebuffer start to finish.  Clover section doesn't mention WithKexts or multi-line issues:  http://www.insanelymac.com/forum/topic/303186-how-to-modification-of-amd-fb-clover-injection/ Another good guide for framebuffer.  Best technical explanation for what each section of the framebuffer means, but lack of consistent endianness gets confusing:  http://www.insanelymac.com/forum/topic/273937-guide-getting-xfx-hd6850-connectors-to-work/
    • By AndrewK2685
      Hello everyone!
      OK I know this is a relatively ancient system, but here it is:
      I was having some free time in the summer and thought of giving my old Toshiba Satellite A300 (PSAGCE) a second try
      in installing Mac OS X El Capitan with Clover. Generally, I think that this is a good hackintosh-candidate laptop, apart from
      its Mobility Radeon HD 3650 GPU (DevID 0x9591).
      So, I tried to follow-up guides from bcc9, mucha, slice and vlada on ATI kext patching to enable the internal LVDS display
      and see what will happen. I started with the two scripts decoding the VGA Bios. My results were the following:
      ATOM BIOS Rom:
                  SubsystemVendorID: 0x1179 SubsystemID: 0xff1c
                  IOBaseAddress: 0x5000
                  Filename: 28109C.bin 
                  BIOS Bootup Message:
      Tosh_IEC_Potomac_M86_DDR2 M86 GDDR2_16Mx16 128bit 256MB 600e/500m          
      PCI ID: 1002:9591
      Connector at index 0
                  Type [@offset 45056]: VGA (1)
                  Encoder [@offset 45060]: INTERNAL_KLDSCP_DAC1 (0x15)
                  i2cid [@offset 45146]: 0x90, OSX senseid: 0x1
      Connector at index 1
                  Type [@offset 45066]: LVDS (7)
                  Encoder [@offset 45070]: INTERNAL_KLDSCP_LVTMA (0x1f)
                  i2cid [@offset 45169]: 0x14, OSX senseid: 0x5
      Connector at index 2
                  Type [@offset 45076]: HDMI-A (11)
                  Encoder [@offset 45080]: INTERNAL_UNIPHY (0x1e)
                  i2cid [@offset 45192]: 0x91, OSX senseid: 0x2
      Connector at index 3
                  Type [@offset 45086]: 9 pin DIN (9)
                  Encoder [@offset 45090]: INTERNAL_KLDSCP_DAC2 (0x16)
      28109C.bin  :
      Tosh_IEC_Potomac_M86_DDR2 M86 GDDR2_16Mx16 128bit 256MB 600e/500m          
      Subsystem Vendor ID: 1179
             Subsystem ID: ff1c
      Object Header Structure Size: 266
      Connector Object Table Offset: 46
      Router Object Table Offset: 0
      Encoder Object Table Offset: ce
      Display Path Table Offset: 10
      Connector Object Id [5] which is [VGA]
                  encoder obj id [0x15] which is [iNTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false
      Connector Object Id [14] which is [LVDS]
                  encoder obj id [0x1f] which is [iNTERNAL_KLDSCP_LVTMA] linkb: false
      Connector Object Id [12] which is [HDMI_TYPE_A]
                  encoder obj id [0x1e] which is [iNTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
      Connector Object Id [15] which is [DIN]
                  encoder obj id [0x16] which is [iNTERNAL_KLDSCP_DAC2] linkb: false
      As you can see, the Bios decode scripts point out this structure:
      CRTC2>DAC>DAC A>VGA (SenseID 01)
      CRTC2>DIG1>UNIPHY_A>HDMI (SenseID 02)
      CRTC2>DAC>DAC B>S-Video
      So, I tried to create a custom framebuffer string for each output:
      I injected the LVDS and VGA strings for AMD3800Controller.kext in Clover. This resulted in black screen in LVDS
      (nothing was showing up in system info as well), but the VGA was successfully detected and enabled. [FIRST WIN! ]
      I tested it with the single monitor setting in BIOS (in previous tests with Chameleon, the change in this setting gave me
      different results, I don’t know why, but they were weird - e.g. LVDS was showing up as a second VGA monitor with the
      same characteristics as the VGA monitor connected when both outputs were enabled in BIOS! Apparently, Clover uses
      only single monitor setting - even when LVDS+VGA setting is selected in BIOS, when Clover shows up, one monitor is off).
      What was strange, was the i2cid value of LVDS (0x14). Doing some search for it, I found a thread from 0xdeadbeef
      pointing that Radeon_Bios_Decode script may return wrong values about SenseID.
      Also, an old thread from YannickD about this laptop on Leopard suggests that this laptop has a LVDS which behaves like
      a DVI in a way (I didn’t actually understand that to be honest). So, I decided to do some trial and error tests on SenseID
      and ATY-ControlFlag values of the framebuffer (I was considering Transmitter and Encoder values as well, but on HD3000
      these are hardwired, so it wouldn’t make much difference). Also tried to change some settings in Clover
      (Rename my GPU from OVGA to IGPU in DSDT and play with Load VBIOS and Inject EDID options in Clover).
      After some (not too many to be honest! ) tests (mainly brute-force attack on framebuffer values and change of options)
      I found out a setting which successfully worked on LVDS!!! My internal monitor is successfully detected and I can have
      the basic 2D functions for it (resolution & colour change)! [sECOND WIN! ]
      What did work was the default SenseID of the framebuffer (11 instead of 05) AND the ATY-ControlFlag for DVI
      (1402 instead of 4000 - others for DVI might work as well!) PLUS the options in Clover (Rename in IGPU for DSDT,
      Load VBIOS and Inject EDID, which are usual Clover settings for laptops). When tried both LVDS and VGA, both
      monitors were correctly detected and working! The only strange thing was that the GPU was detected as an
      ATI Radeon HD4330M instead of Mobility HD3650.
      Now the bad things…
      I can’t enable QE/CI acceleration, even though the DevID 9591 is included by default in ATIRadeonX2000.kext.
      Apparently, the kext is loaded, but returns zero values. This is the second computer that I cannot enable because
      of the damn ATIRadeonX2000.kext - YannickD says that after Snow Leopard Apple removed some
      detection routines with fixed values. Has anyone here found any clues about ATI Acceleration kexts and their values?
      I tested different controllers as well to see if I can get the acceleration. Results were the same for AMD2400Controller.kext,
      AMD2600Controller.kext and AMD3800Controller.kext, but on AMD4600Controller.kext the system crashed and rebooted
      before showing anything.
      Finally, I tested the HDMI string. The result was that the monitor was successfully detected and its properties were correctly
      showed up in Mac OS X, but the monitor was showing nothing (black screen). Since HD3650 can drive up to two different
      outputs, maybe a special switch must be enabled for the output, or might be a transmitter-encoder issue (don’t know - didn’t
      have the time to search more for it, as I was focused on the internal monitor, but it seems something minor).
      This was for the Video only - I have not tested the HDMI Audio
      To sum up
      The framebuffer working was:
      VGA (successfully detected and enabled - no QE/CI)
      LVDS (successfully detected and enabled - DIFFERENT VALUES FROM SCRIPTS IN BOLD - no QE/CI)
      HDMI (successfully detected but showed nothing in monitor - no QE/CI)
      S-Video - not tested
      Load VBIOS, Inject EDID and Rename from OVGA to IGPU in DSDT were essential for the monitors to work.
      I tested these settings across different versions of Mac OS X as well, and got the same results.
      I can try them on Sierra as well, but I think results will be the same.
      I think there is a need to do further search about framebuffer string values and their meaning.
       - IF they do not function for you DO NOT BLINDLY TRUST THEM - ESPECIALLY IF YOU GET BLACK SCREEN!!!!!!!!!
      Also, it would be very good if someone could tear down the acceleration kexts (especially the ATIRadeonX2000.kext)
      Anyone??? Please???
      Thant’s all folks and sorry for my long thread!
    • By Si Vis Pacem
      Heya guys,
      anybody managed to get a R9 390 non-X 8GB working - Sapphire Nitro in my case?
      my fully working patch for El Cap doesn't work even after modifying it to fit the new pattern with the insert of the zeroes.
      Thanks in advance!
      This is my El Cap patch. Heaven 2560x1080 minimum of 25 fps with very high settings.
      Patched Baladi framebuffer AMD8000Controller.kext working NOTICE THIS LITTEL GUY | v 00080000 04020000 00010101 22050403 changing from 00010100 to 00010101 here 00040000 04030000 00010200 12040101 00040000 04030000 00010300 10000205 00040000 04030000 00010400 20010306 04000000 14020000 00010500 11020504 00040000 04030000 00010600 20010606 Sierra patch not working
      Sierra Baladi patch NOT working 00080000 04020000 00010101 00000000 22050403 00000000 00040000 04030000 00010200 00000000 12040101 00000000 00040000 04030000 00010300 00000000 10000205 00000000 00040000 04030000 00010400 00000000 20010306 00000000 04000000 14020000 00010500 00000000 11020504 00000000 00040000 04030000 00010600 00000000 20010606 00000000
    • By xxGOMESxx
      Uma "ajudinha" aki clã,
      Eu tenho a R9 270 e gostaria de mais informações de como instalar os drivers. Eu tentei arrumar os drivers aki no Yosemite, ja vi várias pessoas que conseguiram instalar a R9 270x e algumas q instalaram com a R9 270. Na primeira vez que eu inicio o hackinsoth (pra instalar) funciona tudo normal com os boot args: /amd1 npci=0x3000 (note que eu uso um processador AMD, mas atualmente não interfere mais na performance do hackintosh, visto que ele não necessita mais de um processador Intel). Depois de usar esses boot args, a instalação ocorre perfeitamente e o primeiro boot também, porém sem os drivers da placa de vídeo, ou seja, animações travando muito. Outro problema que encontro é que, sempre quando reinicio o PC depois de acabar de reparar as permissões, etc. na hora de fazer login ele trava na tela com o mouse rodando (aquela bolinha colorida) e um loop infinito nessa tela sempre acontece. Espero conseguir ajuda. Eu sei que isso também deve ter algo a ver com o FrameBuffer, mas das poucas vezes que eu consegui mudar alguma coisa nas configurações do clover, na hora de reiniciar e fazer login, o loop depois da tela de bloqueio ocorre novamente. Eu sempre usei hackintosh no meu Notebook da Dell, mas agora que tenho uma máquina que eu sei que tem suporte eu fico nervoso por não conseguir instalar tudo certinho, porque sei que o erro, com certeza sou eu quem está cometendo. Mas gostaria de ajuda ^^
      Minha placa de vídeo: Gigabyte Radeon R9 270 (OC Version).
      Meu processador: AMD FX4300 (funcionando com o boot arg: /amd1)
      Minha placa mãe: GA-78LMT-USB3 rev5 (tudo funcionando também, boot args: npci=0x3000)
      Memória RAM: 8GB HyperX
      OBS: A versão do FrameBuffer que eu preciso não aparece no kext  AMD7000Controller nem no AMD4000XController (já cliquei em "show package content" mas n achei meu FrameBuffer que provavelmente é o Futomaki, mas não tenho certeza.
      OBS 2: Já ativei a opção InjectATI no Clover e também ja salvei e substitui as configurações (substitui o arquivo do clover, pelo meu editado com os meus boot args, framebuffer info, etc.
      OBS 3: Não se esquecam de me ajudar também, se possível na correção desse bug da tela de login que eu comentei. Provavelmente após corrigir esse problema da placa de vídeo, não acontecerá mais nenhum loop, mas como também não tenho certeza, peço ajuda novamente.
      P.S.: RXILHA