Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  

iATKOS S3 v2 "Still waiting for root device"

5 posts in this topic

Recommended Posts

Hey guys!


So I've been running into a problem when trying to boot up into iATKOS S3 v2 (See my system specs in my sig) using the ISO Image I burned onto a DVD. But I keep getting "Still waiting for root device" I even tried booting up using "-v rd=disk0", still no luck. Any idea how to fix this? Probably something to do with AppleNForceATA kext?


Thanks! :D





Share this post

Link to post
Share on other sites

I think, you must enable ACHI mode on bios


My bios doesn't have that option :/ I pretty much tried every flag and bios setting, even turning off firewire.

Share this post

Link to post
Share on other sites

i was have same problem with ASUS M2N and iatkos leopard , board dosent have AHCI option




u can fix it by intalling leohazard 10.6.0 , only this distro was working on ASUS M2N motherboard

also aways boot with -v busratio=20 cpus=1

Share this post

Link to post
Share on other sites

This works (also nForce):




I've had a hard time getting past that ''Still waiting for root device''. It seems to be a problem with some AMD chipsets, specifically the 7xx. Almost all the OSX distros I used resulted in the same message.


After a lot of time spent getting past that message, I finally bumped into something on the internet. A boot CD called Hack OS X boot, made by a brazilian OSX86 team for use with AMD (and Atom). All you have to do is burn it on a disk and boot into it. You will end up at a bootloader. This is where you swap your Hack OS X boot cd with a Snow Leopard retail (or something like iAtkos, but I don't recommend that as it might produce another problem, namely: getting stuck at PCI configuration begin). Now press F5 to refresh the bootloader and boot the Snow Leopard retail disk.


Here the (direct) link to the Bootcd: hackosx.com.br.


Good luck!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.