Jump to content

Kext swamping question


vallo
 Share

6 posts in this topic

Recommended Posts

Hi, I've a question about how to make my graphic card work again. Let me better explain my problem:

I've installed iAtkos Leopard 10.6.3 updated to 10.6.7 and made my configuration working really well:

ASUS P5K-C

Intel 6400

6Gb Ram

Nvidia 8400 GS

I have no problems, even with quartz extreme. I've made it work my graphic card only with the graphic enabler option at the iAtkos setup page.

Now I swamped my old card with another old one but much better an ATI 4870x2.

I know that since I installed the nvidia graphic enabler I could have problems for sure while installing a different card.

I tried to install iAtkos lion 10.7.2 and it works just fine with only ati48xx.pkg choosed as driver package at the setup page and I know it will works even on the leopard 10.6.7.

So, my question is: How can I remove the old graphic enabler and isntall the new ati48xx.pkg safely without reinstalling the whole system? Is there a tutorial that chould help me?

I know.. I'm a newbie so forgive me.

Thanks!

Link to comment
Share on other sites

Hahaha! Really funny! :D

anyway, I cannot find the plist file, currently I'm using win 7 installed on another hard disk and I've selected to show all the files. Inside the hidden Extra folder there are only 2 folders, extensions, themes and 3 files com.apple.boot.plist, extension.mkext and smbios.plist I still can edit plist files using plist edit for windows. What do you suggest? I've noticed 2 kext files in the extensions folder, NVEnabler64.kext and NVEnabler 64.kext I think they are pretty much the same, only a space between letters and numbers makes the difference. What do you suggest at this point?

I've installed the driver ati48xx.pkg on the lion 10.7.2 dvd using pacifist, but nothing happened. Looks like they won't work for some reason...

 

I've tried to edit the com.apple.boot.plist founded in the /extra directory, it was "Graphic enabler yes", I changed it in No, but nothing happened. It still boots up, but the display isn't the right resolution and I don't have any hardware acceleration

Link to comment
Share on other sites

NVEnabler only works with Nvidia cards, you can delete it.

 

If you're runnning 10.6.7, using a driver package for 10.7.2 spells big trouble down the line. I'm sure there is a proper fix to get your card to work.

 

org.chameleon.Boot.plist used to be com.apple.Boot.plist, the name was changed for the final version of Chameleon 2.0. It's the same file, it just means that your iatkos distro uses an older version of Chameleon. If you have used Lizard to update to a more recent version then it will be using org.chameleon.Boot.plist.

 

I don't know anything about ATI cards, try going to Netkas' blog and use the search over there to find the information you need.

 

Glad you liked the swamp.

Link to comment
Share on other sites

Thanks a lot, I'll try to find more info on Netkas.

It seems strange to me too, but I remember that I've made work the ati 4870x2 on a leopard 10.6.7 on another system using the lion driver package. I hope I there is no need to edit the plist file or compile something, I really don't know how to do it

Link to comment
Share on other sites

 Share

×
×
  • Create New...