Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Not detecting Firewire Card on 2nd PCI port

4 posts in this topic

Recommended Posts

My computer is an ASUS P5KPL-AM EPU motherbaord, intel Core2 Duo with 2GB of DDR2. It's pretty much a fool proof hackintosh. I was able to install 10.6.3 retail using the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] method and then update to 10.6.8 combo update without any issues.

My issue is that originally I had purchased an ATI Radeon HD 3450 because I had read that it is supported on OSX, but I was misinformed and it is the HD 4350 that works. Just yesterday I happened to come across an nVidia Geforce 8800 GTS for free which I promptly swapped out and was ecstatic when it booted up on the first try when passing "GraphicsEnabler=Yes" at boot. I can switch resolutions, it supports DVI on both outputs and QE/CI works flawlessly.


Unfortunately, the 8800GTS is big. It's f'in HUGE, and it covers up the first PCI port that I used to keep my VIA Firewire PCI card plugged into which worked flawlessly. I figured no big deal, I have another PCI port. Unfortunately, when I plug the Firewire card into the second PCI port, my computer takes a VERY long time to boot into OSX, and once I am booted the system fails to detect any Firewire ports, but I can confirm that without the Geforce 8800 GTS installed and the VIA Firewire card installed in the first PCI port, firewire did in fact work just fine.


When I run lspci -nn in the terminal, it registers that the firewire card is installed, but the card is not detected in the system profiler.


So... is there are workaround here to get my card detected on the second PCI port or do I need to get another firewire card? I've read that changing the smbios.plist can affect hardware detection (I suppose that makes sense if my computer believes itself to be a model that had only one PCI port). I also have one PCIE X1 (the small approx. 1" wide port) available. And of course, USB is always an option. are there any PCIe X1 or USB firewire devices that are known to work on OSx86 or is there any chance of getting my second PCI slot detected properly?


Here's the output of lspci -nn. I've checked and it's IDENTICAL to the same output when running Ubuntu on this PC.

00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 10)
00:01.0 PCI bridge [0604]: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port [8086:29c1] (rev 10)
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)
00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 01)
00:1c.1 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 2 [8086:27d2] (rev 01)
00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 01)
00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge [8086:27b8] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 01)
00:1f.2 IDE interface [0101]: Intel Corporation N10/ICH7 Family SATA IDE Controller [8086:27c0] (rev 01)
00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 01)
01:00.0 VGA compatible controller [0300]: nVidia Corporation G80 [GeForce 8800 GTS] [10de:0193] (rev a2)
02:00.0 Ethernet controller [0200]: Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet [1969:1026] (rev b0)
04:01.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller [1106:3044] (rev 46)

Share this post

Link to post
Share on other sites

Okay a little bit of light has been shed here. Using OSX86 tools to create an EFI string for my ethernet so that I could access the app store, I discovered that the Firewire card is in fact detected properly, however the IO Ports are disabled. Just a hunch, but I'm wondering if the address assigned to the IO ports (ec00 in my case) are in use by other hardware. Perhaps VoodooHDA has something to do with this. I doubt it could be that simple, but I think I'm on the right track.

Share this post

Link to post
Share on other sites

You may be correct. Is it possible to reinstall? Often that's how I fix my PCI issues.


Also, I've noticed that swapping graphics cards without reinstallation can cause problems. Just something to think about. :)


This is definitely perplexing....

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By guitarsimo93
      Buon giorno a tutti ragazzi!
      Ho il mio sistema principale da dover aggiornare da Yosemite 10.10.5 a El capitan oppure a Sierra.
      Ecco l'hardware: MOBO: GA Z97-HD3 CPU: i5 4690 GPU: GT630
      Attualmente utilizzo clover per avviare anche un secondo ssd con installato windows.
      Sto verificando attualmente che tutti i programmi che utilizzo siano funzionanti su Sierra, ma vorrei valutare al meglio con voi se conviene aggiornare a Sierra oppure a El Capitan la mia work station.
      Se la memoria non mi inganna al momento dell'installazione di yosemite (e anche primo montaggio hardware), con il vostro aiuto, non ho avuto grossi problemi se non con la scheda video che o non riconosceva i 2GB di memoria che ha oppure causava il riavvio del computer anche quando schiacciavo su spegni o digitavo il comando da terminale per spegnere il computer.
      Ricordo che per risolvere il problema della scheda video avevamo lavorato parecchio sul dsdt.
      Kext particolari non ne ho installati (spero sempre di non dimenticarmi qualcosa) ho solamente quelli nella cartella di clover per la rete e per l'audio, mentre in Sistema/Libreria/Extension non mi ricordo di aver installato nulla.
      Una cosa che potrebbe creare qualche problema potrebbe essere la presenza (non più necessaria ma se riuscissimo a mantenerla sarebbe meglio) di una scheda pci per avere delle porte firewire. La scheda ha il chip principale della VIA. Ricordo che un annetto fa sulla build numero 2 e sulla numero 3 che potete leggere in firma, durante il tentativo di installarci El Capitan, non voleva funzionare e causava un kernel panic.
      Ecco la mia EFI completa ed attualmente in uso con yosemite:
      EFI Yosemite.zip
    • By guitarsimo93
      Buon giorno ragazzi!
      Qualcuno di vuoi saprebbe indirizzarmi sull'acquisto di una scheda pci con porte FireWire compatibile con El Capitan (10.11.3, bootloader Clover)?
      Grazie mille in anticipo a tutti quanti!
    • By guitarsimo93
      Buon giorno ragazzi,
      Ho necessità di utilizzare delle porte FireWire sulla seguente configurazione:
      Mobo: asrock b75m-gl R2.0
      Cpu: i7 2600k
      GPU: integrata HD3000
      Bootloader: clover v2.3 r3333
      In casa ho due schede FireWire che fino a Yosemite funzionavano anticamente senza bisogno di nessun kext o nessuna patch.
      Entrambe montano un chip FireWire della VIA siglato VT6306.
      La prima che ha solo la FireWire e quindi solo questo chip mi lascia avviare il computer ma non mi viene riconosciuta nessuna interfaccia FireWire.
      La seconda che ha quel chip per le FireWire e un secondo chip in aggiunta sempre della VIA e siglato VT6214L per delle usb aggiuntive mi fa riavviare il computer al boot. Ecco uno screen del riavvio
      È possibile utilizzare in qualche modo una di queste due schede sotto El Capitan?
      Grazie ragazzi!
    • By kobe80
      Hi friends,

      So the other day i installed the newest updates for Yosemite. A bunch of things broke, but i got them all fixed, except firewire's not working. In System Report, it says 'No Firewire ports Available', and it won't detect my Apogee Ensemble FW audio interface.

      I know the card isn't dead bc in Windows, windows recognizes not only the card but the device i have plugged in (Apogee Ensemble FW Audio Interface - mac only)

      So the card seems fine. i tried different cables and ports on the card and ports on the ensemble.

      I also installed a fresh copy of Yosemite on another SSD and it's not working in that one either. I feel like maybe the software update from Apple killed the FireWire?

      Any ideas?

      My rig:

      X99 Deluxe
    • By TheBosZ
      Ciao a tutti,
      è un pò di tempo che non mi faccio vivo su questo forum anche se capito spesso per leggere.
      Chiedo il vostro aiuto perchè sto preparando un Hackintosh ad utilizzo musica, quindi che presenti buone caratteristiche di gestione di grossi volumi di dati (sicuramente sotto i 16Gb non si andrà nella scelta).
      La mia domanda era quale scheda madre consigliate nella quale ci si debba mettere poco mano sopra in termini di kext e compagnia bella, in più il massimo sarebbe se fosse dotata di porte FireWire (il mio amico utilizza un mixer con questa connessione) e che anche in questo caso presenti pochi problemi nel riconoscere le periferiche attaccate.
      Se avete anche qualche topic da consigliare in lettura sono ben accetti suggerimenti,
      grazie mille per qualsiasi risposta