Jump to content

Iatkos L2 on asus maximus x38+msi gtx580 lightning problem


8 posts in this topic

Recommended Posts

Hi there

I have the configuration as in the topic, I install the system and can't boot.

I tried in many different ways, using the nvenabler from the vga drivers list, and another time with the nvenabler from the bootlist options, neither work.

I think the graphic card is the problem but I'm not sure, any ideas how to solve the problem?

I also tried both bootloaders still with no sucess, though I think that chameleon is working better it takes more time during start to crash.

Can someone help me? :) Thx!


p.s. I attaching the photo from the crash from bothh bootloaders, the give slightly different info


My configuration:

Asus maximus x38

4gb ram 800mhz geill black dragon

msi gtx580 lightning

Intel core 2 quad q9550 2.8@ 3.4Ghz





Link to comment
Share on other sites

NVEnabler is not a driver.


Delete NVEnabler.kext, boot with -v and take another photo when it halts/panics.


Try booting with -v -x (x is safe mode, like on Windows, sound and video drivers don't load)


"NVDAResman not found", "Geforce.kext failed to load" indicate a serious problem. Those are part of the OS X nvidia drivers. Make sure your driver files are unmodified and that all of the nvidia driver kernel extensions have been installed. The main driver for your video card is GF100Hal.kext.


This is another great example of why everyone should be using retail install media + boot CD instead of hacked install DVDs.


Your installation was done with a hacked install DVD right? Which one?


Try not picking anything in the video section when installing.

Link to comment
Share on other sites

HI big thx for your answer :)

I'll try to explain what I have done :)


I'm not very good with these things, although I managed before to install, also on hacked dvd iDeneb v 1.5 but with a different video card 8800gts.


but back to this case :)


I am using iATKOS L2

While installing I check all the neccesary drivers on list: network marvel yukon, ahci intel sata, vodoo sound (i hear a click while booting so i assume sound might work) etc.

Then I install it from the dvd, restart and try to boot from the disk, how can i delete the file Delete NVEnabler.kext? and where from the hard disk? or from the installation dvd? I'm not sure and confused here.

I did not manage to boot even once in to the desktop, it always fails, that's why I don't know what you mean :)


Hope I was clear enough, sry for my english :)


will try to boot with the command -v-x and post at once :)

thx again for trying to help I would love to have a hackintosh on my recent hardware configuration :)))

Link to comment
Share on other sites

Boot your install media and run Terminal.app from the Utilities menu.


From there navigate to /Volumes/nameofyourOSXpartition/system/library/extensions and enter


rm -rf NVEnabler.kext


If you don't remember the name of your OS X partition, enter diskutil list first to see it.


After doing this, boot with -f -v -x (-f ignores cached kernel extensions, this is important because NVEnabler.kext will still be present in the cache).

Link to comment
Share on other sites

You wouldn't be posting here if you did.


"Still waiting for root device" means OS X is not recognizing your SATA controller, which results in OS X not being able to see any of the drives that are connected to it.

You can fix this by changing SATA mode to AHCI in the BIOS, or by installing the right driver for your SATA controller in the "customize" section.


Make sure that the hard drive you've installed OS X on is connected to the Intel ICHx and not the JMicron SATA controller. Look in your motherboard manual to see which SATA ports belong to which controller.


Try disabling the JMicron SATA controller in the BIOS.


Lastly, if you have done the above, or if the above does not apply to your situation and you can't get it to boot on the ICHx, connect the OS X drive to a SATA port on the JMicron and see what happens.

  • Like 1
Link to comment
Share on other sites

Hi there :)

I managed to boot the system :))!!!


but still it is not 100% functional, I have a lack of graphic card drivers, I'll write how I managed it :)


At first I formatted, the disk, made a new guid partition. In bios switched to ahci mode (strange cause I did that before and it didn't work), at first boot I stopped on the nvenabler, so i did what you suggested, deleted the file from the extensions through terminal, and booted again, via -f -v -x, it managed to boot to the desktop, in a sec I wiil try to boot without the safe mode and see wether the sound will work.


I still need a solution for my graphic card, I hope it can be done by modyfing some kext files.

Is there a way to copy somehow the nvenabler.kext back to the system? right now it shows only 1 screen resolution 1024x768, so as I understand my graphic driver is not working.

If you have any other good ideas I'll be more than happy :))

Anyway BIIIG THX for your help with booting the system :)))))) I hope that when I rebbot in normal mode it will work also, will report on that.

hope to hear from you :)



I booted in normal mode :))) the sound is working but i have 5 channel headphones and it's a bit weak, but I think that when I use normal stereo it will be ok

I used the voddo sound driver, and mybe id does not support 5.1 I'm not sure


still need a way to somehow get back into the system the nvenabler.kext

Link to comment
Share on other sites


  • Create New...