Jump to content

Can't change SystemUUID 10.7.2


4 posts in this topic

Recommended Posts

Hey guys!


I've got a problem with getting iCloud to work. I think it's my wrong System UUID.



My MAC address is 00012E2D7401

Hardware UUID I want: 55ADE93X-XXXX-XXXX-XXXX-00012E2D7401


But bdmesg shows me:


Type: 1, Length: 27, Handle: 0x1


manufacturer: Apple Inc.

productName: Macmini3,1

version: 1.0

serialNumber: CK93201319X

uuid: 00020003-0004-0005-0006-000700080009

wakeupReason: 0x6

skuNumber: To Be Filled By O.E.M.

family: Macmini




Customizing SystemID with : 00020003-0004-0005-0006-000700080009



My System Profiler says: 55ADE93X-XXXX-XXXX-XXXX-15640684C489

It's the same UUID, instead of the last part, which should be my MAC address (the X's are hex numbers).


I have a SMBios.plist and org.chameleon.boot.plist setting with the right UUID and I don't have a PlatformUUID.kext - where else could be an entry with the wrong UUID?



Best regards,



P.S. Sry, wrong category.

Link to comment
Share on other sites

First of all, there is no such thing as System UUID, you're mixing things up. It's system-id and PlatformUUID.


It has absolutely nothing to do with your DSDT.


As far as I know it works like this: Unless you override it via smbios.plist, "system-id" is read from your motherboard DMI data by the Chameleon boot loader (since RC4). Your PlatformUUID is then auto-generated, based on this system-id. PlatformUUID is the one you see in System Profiler. It will not match your MAC address and there is no way to change the PlatformUUID, only the system-id.

This functionality was added by rekursor during the RC4 dev cycle.

Read here for more information: http://www.insanelym...dpost&p=1359776


I doubt that your issue is related to your Platform UUID. It is not important that the PlatformUUID matches your ethernet MAC address, what matters is that it doesn't change. The way it works now (Chameleon 2.0 RC4 and above) it will not suddenly change because it's based on fixed data from your motherboard BIOS. The only way it could change is if you override the system-id yourself (as you have) or if you install OS X on a different PC.


The worst that can happen if you lose/change system-id is that you lose the accounts that are based on the PlatformUUID generated from it - it should not break iCloud itself. iCloud would break if you had no PlatformUUID but as you can see that can no longer happen to anyone using Chameleon RC4 or higher.


Either you need to find a solution in this topic:


Or, simply update to Chameleon 2.1 svn-r1691 or higher to get the fix for iCloud and Facetime.

Link to comment
Share on other sites

Hey! Thanks for your reply and your advices.


Ok, i tried almost everything to get iCloud working, the last step was to change my Platform UUID matches my en0 address. I thought, that was the problem. If that's not necessary I actually don't know whats wrong with my system.


My Chameleon Version is: 2.1svn-r1716 - so it's than higher your recommendation.


I reread your links - maybe I find another mistake I made.


Thank you!!

Link to comment
Share on other sites


  • Create New...