Jump to content
Johanne M.A. Lim

how to disable fsck_hfs at boot time

2 posts in this topic

Recommended Posts

Hi guys,

 

Is there a way to disable fsck_hfs checking upon boot?

 

I've recently been getting these really long progress bars upon booting my OSX 10.6.8 (MacBook Pro) and when I checked in verbose mode, I saw that fsck_hfs was trying to fix my drive during boot.

 

Thus takes so much time since it takes 3 passes before it actually gives up and loads the OS.

 

I've looked for the rc.boot and didn't find any, maybe you have a way to disable fsck running at boot time? Is there a log file somewhere that I can delete to prevent the fsck from happening at boot?

 

PS. I've tried renaming fsck_hfs in sbin to see if that will do the trick and simply didn't work as it didn't load OSX. So that option's out.

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement

You're seeing fsck because it always runs when booting in verbose mode.

 

If normal non-verbose mode boot is taking too long, run console.app and check timestamps in kernel.log/system.log to track down the issue.

 

I should be surprised if fsck is also running in non-verbose mode.

 

Boot with your installation DVD, run Disk Utility and do a drive repair.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×