Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  

Need to use Windows or Grub bootloader for Dual/tri-boot system.

Recommended Posts

I have a Dell Latitude E6510 laptop that I'm trying to set up either a Dual booting Windows 7 and Lion system on or a Tri-booting Windows 7, Lion, and Ubuntu 11.04 on.


However I'm getting a bunch of problems because I have an incompatible hard drive and all the tutorials on the interwebz end up having Chameleon being the bootloader in the end. I have a Western Digital Scorpio Black WD5000BPKT 500gb hard drive in it, and I'm pretty sure this is messing with my attempts at installing Chameleon/Chimera as the main bootloader.


Whenever I get it installed, I just boot to a boot0 error. After much research, I've noticed that this is a symptom of incompatible hard drives and people say that you can use the Windows bootloader with EasyBCD to boot Chameleon and it will work. This would be fine and all, but I can't get Windows to boot period after installing Snow Leopard.


Here is what happens more less every time. (I've done this process upwards of 25 times, so everything seems to be running together now. I feel like I've tried all the options.)




First of all, I set BIOS to AHCI mode. I boot up using one of two boot cds and Hazard 10.6.6i (See below section for more information on this) and go to the disk utility. I partition the drive to GUID and have 3 partitions. (4 if I could install Ubuntu. Which I want to) Set up in this manner:


1 - Snow Leopard 150gb HFS+ Journaled

2 - Windows 7 300 FAT32

3 - Time Machine 50 HFS+ Journaled Case Sensitive


I then proceed to install Snow Leopard on the Snow Leopard partition.



Option 1: OSx86 Mod CD E6410-


This boots and installs fine. However, when I finally get everything install and load up Snow Leopard graphics are at the lowest setting and QI/CE or whatever is not working. I can not get them working either; using any of the methods posted on the guides for the e6510 and e6410. Shutdown and reboot do work though!


Option 2: [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.1.1


This kernel panics unless i boot using -x. It installs fine. I can only boot using -x and when i finally get everything booted, graphics work 100%. I have Full resolution and a transparent menu bar. I can't seem to get Audio working using the voodoohda kext on the modcd. After installing the basics with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], I can boot without -x. There is one bug though, no matter what I install or do, I can not get my trackpad to work. I have to use either a USB mouse of the trackstick. On top of that, the track stick is vertically inverted. Pushing up makes my cursor go down and vice versa. Shutdown and reboot also do not work. The os shuts down but not my hardware.



After getting my kexts working, with respect to each method, I cannot update to 10.6.8. Once I do, I can no longer boot. I think it gets stuck on PCI Configuration began or whatever, but I can't quite remember. Also, DSDT's do not work either. They cause my install to crash. I can, however, update to 10.6.7. (Which is okay, because you can update to Lion with that version of Snow Leopard)


When I try to update to lion however, It says I have an incompatible processor. I figured this was because my hackintosh wasn't detecing the right processor. But it does. It recognizes my i7 and reports it as running at 1.6ghz. My laptop has an i7-620. Is there anyway around this? I'd really like to have Lion running.




Okay, now that everything is working. (As far as I can go with either method at least) I begin to install Windows 7. BIOS is still in AHCI mode. I boot off the Windows 7 disk. I go to install and click on the partition i made for Windows earlier. I click format and then install. Note, this method never makes a system reserved partition. This is required to boot, correct?


The install goes fine, with no hiccups at all. At this point I reboot to finish the installation. When my computer reboots, it goes to the NO operating system found page. Nice =/


I boot off the Windows 7 cd and click on repair this computer. It says I'm using an incompatible version of Windows for this recovery console or whatever. So I press Shift+f10 and load of Command Prompt. At this tiime, I attempt to fix the mbr using bootrec. This process works and I reboot.


When my computer reboots, it POSTs fine and then goes to the part where it is supposed to load an operating system. Instead of getting the operating system missing error, I get just a blinking cursor though. I believe this is because my Bootloader is looking for a windows installation?


At this point in time, If windows worked, what i assume I would do is install Easybcd and add my Mac installation to my boot loader. How exactly would I do this? After I got them both booting, I would like to install uBuntu.



TL;DR Questions



  1. How can I set up a dual booting system with the Windows bootloader instead of chameleon? (Tribooting if possible using either Grub or Windows bootloaders)
  2. How can I install the 10.6.8 Update. Is there any reason to even do this really?Why do DSDT's cause my system to crash? Is there anyway to create my own easily?
  3. Why does Lion not recognize my CPU?
  4. Why does [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] install my graphics kext on first boot but ModCD does not?
  5. Why does [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] only enable the track stick and in inverse mode?
  6. Am I partitioning correctly? Do I need the system reserved partition?
  7. Basically, Where do I go from here?

Share this post

Link to post
Share on other sites
Yes, definitely! I wish my laptop had support for more than one hard drive....


get a second hard disk and caddy. swap drives.

its what i do. i dont like to have to tinker with bootsectors every months when it breaks.

Share this post

Link to post
Share on other sites

I now know what the problem is...


I have an advanced format hard drive. (4KB sectors)


They aren't compatible with Chameleon bootloader because the advanced format hardrive deletes the boot1h file during its auto-cleaning process.


I found a semi-workaround though. If you manually install chameleon with the terminal, and immediately cut the power after copying all the files, you can boot using chameleon 1 time. Then your hard drive auto-cleans itself.



Share this post

Link to post
Share on other sites

My solution may not be the right one but I have a dell laptop and i can tell you how i did it.


1. Hazard has its own bootloader no need for the others.

2. Boot up Hazard and partition hard drive GUID and however many partitions you want.

3. Reboot put Windows cd in and install on first partition.

4. reboot put hazard back in and install on 2nd partition.

5. Chameleon should take over at this point

6. Work on getting kexts working

7. Install ubuntu or win 8 or whatever. Sometimes after installing new OS, MBR inside windows partition get corrupted.

8. Google gptsync to fix mbr on guid. thru live gnu/linux cd


hope it helps

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.