Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
myr1

DSDT for HP TC4400

5 posts in this topic

Recommended Posts

Hi all,

I've just extracted and patched DSDT for HP TC4400 (with bios version F.0C). Everything including tablet (via TabletMagic 2.0b18) seems to work (Broadcom Ethernet not tested yet, Intel wireless doesn't have a kext). Maybe it could be useful for someone.

Enjoy :rolleyes:

 

EDIT:

New version in the next post.

dsdt.aml___OK.zip

Share this post


Link to post
Share on other sites

Here is a new version of DSDT.

Changes in RTC, HPET, LPCB, TIMR and PIC. This means USB is working at its full speed (480 Mb/s), lower CPU temperatures, Bluetooth fixed. Still not working: Sleep (not tested), Wi-Fi (Intel) - missing kext.

I forgot to mention that I am using bautzen's kexts and bootloader from bautzen's guide: http://www.kexts.com/downloads.php?do=file&id=1716

Enjoy ;)

dsdt.aml_7IRQFIXES_HPET_RTC_TIMR_PIC_.zip

Share this post


Link to post
Share on other sites

Hi,

 

I appreciate I am a little late with the post, but....

 

Thanks for the dsdt - it is great that someone still loves these little tablets!!

I was using the one from bautzen, but your one seems to detect the serial port correctly so I can use the pen and modem. I don't have any bluetooth though for some reason - I didn't with bautzen's either so I have no idea why since both advise that bluetooth works. I have a TC4400 with a T2500 CPU.

 

Any ideas with the bluetooth problem? It is enabled in BIOS, and works correctly in Win7.

 

Also, did you manage to get the internal SDHC card reader to work - bautzen didnt manage to get it to work and it wont show my card with this either :(

I am fairly sure I had it working at one point in Leopard although I cannot be entirely sure cos it was a while ago.

Anyway, any help with the bluetooth issue would be very much appreciated,

 

Thanks very much again

Share this post


Link to post
Share on other sites

Try pressing the "wireless switch" (hardware button to turn on/off BT+WiFi) and restarting. I think it showed me the normal (not crossed) bluetooth icon.

I didn't have any luck with installing the card reader kext. I've tried many, but none of them worked. (Probably just needs to have edited Info.plist inside the kext or the binary should be patched. It could also be completely incompatible with Mac OS X just like Intel wireless, which is unlikely.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×