Jump to content
Sign in to follow this  
nomeutente94

[Risolto] Audio e DSDT, come fare?

11 posts in this topic

Recommended Posts

Salve a tutti, vengo subito al punto. Ho trovato un kext niente male che dovrebbe far funzionare anche il microfono e il 5.1 della mia ALC883 a differenza di VoodooHDA, ma c'è da editare il dsdt.aml, di cui io non conosco per niente il funzionamento. Con questa installazione di Lion non ne ho avuto bisogno, quindi non ho il file dsdt.aml in extra, dovrei crearlo da zero, credo.

 

Riporto il paragrafo che riguarda la modifica del dsdt dal file di testo del pacchetto:

 

 

DSDT

(ALC883)

-----------------------------------------------------------------------------------------

 

Device (HDEF)

{

Name (_ADR, 0x001B0000)

Name (_SUN, One)

Method (_PRW, 0, NotSerialized)

{

Return (Package (0x02)

{

0x0D,

0x05

})

}

 

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0C)

{

"codec-id",

Buffer (0x04)

{

0x83, 0x08, 0xEC, 0x10

},

 

"built-in",

Buffer (One)

{

0x00

},

 

"model",

Buffer (0x0F)

{

"Realtek ALC883"

},

 

"device_type",

Buffer (0x0B)

{

"sound card"

},

 

"layout-id",

Buffer (0x04)

{

0x0C, 0x00, 0x00, 0x00

},

 

"PinConfigurations",

Buffer (Zero) {}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

 

-------------------------------------------------------------------------------------------

 

Ecco. Il kext AppleHDA è già in /System/Library/Extensions, ma col dsdt non ho la minima idea di come fare.

Grazie mille in anticipo a chi saprà aiutarmi. :(

Share this post


Link to post
Share on other sites
Advertisement

Già fatto, con quel programma ho creato un dsdt.aml. Ora ho provato a modificarlo con DSDTSE, sostituendo tutte le stringhe appertenti a Device (HDEF) con quelle postate sopra. Riavviato, parte, ma l'audio non funziona.

Share this post


Link to post
Share on other sites
Già fatto, con quel programma ho creato un dsdt.aml. Ora ho provato a modificarlo con DSDTSE, sostituendo tutte le stringhe appertenti a Device (HDEF) con quelle postate sopra. Riavviato, parte, ma l'audio non funziona.

 

guarda che con quel programma il dsdt.aml che crea è già apposto

Se la parte Device (HDEF) non te la creata allora devi aggiungere te quella parte posta sopra senza modificare niet'altro

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×