Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


New OS X installation gives kernel panic at first boot

23 posts in this topic

Recommended Posts

I'm a new member of these forums and new to installing OS X on non-Mac machines, so although I've done some research, I'm not entirely 'fluent' in the language of this project. Please excuse any perceived 'ignorance'.


Also, I'm not sure if my problem would be classified as a 'hardware issue', so if I'm wrong in my classification, feel free to move this post ;) .


Here's my problem: I'm trying to create a triple booted system with Windows 7, OS X, and Ubuntu. This computer is a custom build, with its specifications listed at the end of the post. Just to get a sense of how I would go about installing Snow Leopard on this machine, I'm installing Mac OS X first. I know this typically isn't the way that people create dual or triple booted systems, but if necessary, I wouldn't have a problem reformatting and reinstalling the operating systems once Snow Leopard is installed.


I'm using the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and Snow Leopard retail disk method of installation, and the installation process seems to work properly (but only if the boot switch PCIRootUID=1 is entered into [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]; I get a kernel panic otherwise). On restart, I replace the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disk, hit the new install, and wait. After a few moments (and sometimes instantly) I get a kernel panic. The entirety of the panic text is attached after the computer's specifications, minus what is hidden by the 'you need to restart your computer' rectangle.


How would I go about solving these problems? I imagine I would have to install kexts, but all the methods that I've read would need a somewhat workable Mac OS X desktop already running, and I can't even get close to that.



Intel Core i7 (LGA1155)

Corsair VENGEANCE 4x4GB DDR3 (only one stick installed per [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] instructions)

Two EVGA nVidia GeForce GTX 460 2048MB (only one installed per [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] instructions)

3TB Hitachi hard drive (with a 900 GB partition for SL created by Disk Utility)

LG SuperMulti optical drive

ASUS P8P67 PRO motherboard

Thermaltake 1050W PSU


Connected to eMachines E230H using VGA with DVI to VGA adapter


Kernel panic text (some cut off by the rectangle):


panic(cpu 2 caller 0x2abf6a): Kernel trap at 0x5e0e7ad8, type 14=page fault, registers:

Loading VoodooHDA 0.2.1 (based on hdac version 20090401_0132)

Controller: NVidia (Unknown) (vendor ID: 10de, device ID: 0beb)

warning: couldn't set recording device to microphone

warning: couldn't set recording device to microphone

warning: couldn't set recording device to microphone

warning: couldn't set recording device to microphone

Codec #0: NVidia (Unknown) (vendor ID: 10de, device ID: 0012)

Codec #1: NVidia (Unknown) (vendor ID: 10de, device ID: 0012)

Codec #2: NVidia (Unknown) (vendor ID: 10de, device ID: 0012)

Codec #3: NVidia (Unknown) (vendor ID: 10de, device ID: 0012)

warning: found invalid min/max dB (using default -22.5 -> 0.0 range)

warning: found invalid min/max dB (using default -22.5 -> 0.0 range)

warning: found invalid min/max dB (using default -22.5 -> 0.0 range)

warning: found invalid min/max dB (using default -22.5 -> 0.0 range)

com.apple.AppleFSCompressionTypeZlib (cut off)

vendor:device: 0x8086:0x1503.

AppleIntelE1000e(Info): changing MTU (cut off)

FireWire runtime power conservation (cut off)

FireWire (OHCI) VendorID 1106 ID 304 (cut off)

CR0: 0x8001003b, CR2: 0x06c5a087, CR (cut off)

EAX: 0x06c5a084, EBX: 0x464186d4, EC (cut off)

CR2: 0x06c5a087, EBP: 0x5e053cc8, ES (cut off)

EFL: 0x00010206, EIP: 0x5e0e7ad8, CS (cut off)

Error code: 0x00000000


Debugger called: <panic>

Backtrace (CPU 2), Frame : Return A (cut off)

(backtrace omitted)

Kernel Extensions in backtrace (with dependencies):


dependency: com.apple.iokit.IOPCIFamily(2.6.5)@0x5514e000

dependency: com.apple.iokit.IOAudioFamily(1.8.3fc2)@0x5e110000


System uptime in nanoseconds: 2308902026C8):42:42 PDT 2011; root:xnu-1504.15.2~1/RELEASE_I386


This goes to the end of the screen, so I imagine the last line was overwritten several times.

Share this post

Link to post
Share on other sites

It looks like there are issues with Audio causing your KPs.

Unless you have installed any kexts like VoodooHDA.kext, these must be coming from the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] disk.


Maybe try a different boot disc, I've always had success with the Nawcom mod cd when installing 10.6.3 from the retail disc. Then once running I use Chameleon 2 RC5.


I'm not saying this will definitely work as our systems use different mobos but It's worth trying a few different bootloaders.


As for your question regarding the triple boot, I've always done it this way:

1. Boot OS X, partition drive as GUID, Extended Journeled for OS X, then 2 fat 32 partitions, 1 for win, 1 for Ubuntu.

2. Install OS X, Install bootloader (Chameleon) to the EFI partition (created automatically by OS X during partitioning the drive)(not the snow leopard partition, you'll see why when you screw things up and have to restore your partition).

3. Install Windows to the second partition, when you reboot windows will boot automatically.

4. Boot the windows disk again, Use DiscPart from the command line to set the EFI partition as active.

5. Reboot again and install Ubuntu, MAKE SURE YOU SELECT YOUR / AS THE INSTALL LOCATION FOR GRUB!!!!!

6. Resync your partition table from withing Ubuntu

7. Reboot again, chameleon should boot and you should be able to boot into all 3.


If windows complains and wont boot it's just because it's not the primary partition. In which case:

1. Boot windows disc

2. Swap to Command prompt, make windows the active partition using discpart

3. Run a repair on the disk DO NOT REBOOT

4. before clicking reboot/whatever go back to command prompt and again, using discpart, set EFI as the active partition.

5. Reboot and all should work.



From experience, it is better to use a separate drive for OS X.

I started by doing it the way described above but ended up using that OS X partition for Time Machine and setting up a totally separate hard drive for EFI(bootloader) and OS X.


I hope this helps you out.

Share this post

Link to post
Share on other sites

Thank you so much. That post is extremely helpful!


I installed OS X no problem with the Nawcom mod CD, following your instructions to the letter*. When I tried installing Chameleon v2 RC4 (couldn't find RC5 on the web), I did screw it up, and I'm reinstalling OS X right now ;)


Anyway, how exactly do I go about installing it to the EFI partition? Assuming the EFI partition is disk0s1, and the OS is installed on disk0s2 with two FAT partitions at disk0s3 and disk0s4, would it be:


sudo fdisk -f boot0 -u -y /dev/rdisk0

sudo dd if=boot1h of=/dev/rdisk0s1

sudo cp boot /


And why are these commands referencing an 'rdisk' device, instead of the normal 'disk'?


Thanks again!


*EDIT: I should clarify that I followed your instructions to the letter with the exception apparently of installing the bootloader to the EFI partition.

Share this post

Link to post
Share on other sites

have a look here for instructions on how to install to EFI



For chameleon rc5, go here:


You want a tar.gz, not an installer


If you're feeling brave you could always add the SVN repository for chameleon and give compiling your own a go using xcode.


If you get stuck let me know and I'll upload my boot file for you.

Share this post

Link to post
Share on other sites

Installed Chameleon to EFI using the tutorial you provided. The only hitch in the installation process was that, when setting the EFI partition to active, it said it couldn't get exclusive access to drive, and so it would make the changes upon restart.


When restarting the system, Chameleon loads, but doesn't start booting Mac OS X automatically. No problem; I make sure I'm on the Mac OS X partition and hit Enter. Apple screen pops up, but no circular progress bar thing. It hangs here.


In verbose mode, some text scrolls down the Chameleon screen, but when that screen goes away (presumably to show what should be OS X's verbose output), it hangs at that black screen.


I can still boot into OS X with the mod CD though, so I think the problem was in the installation of the bootloader.


Again, thank you for all of your help so far, and in the future. You don't know how much I appreciate it.

Share this post

Link to post
Share on other sites

Did you make the directory /Extra/Extensions on the EFI partition and have you installed any kexts there?


If not, that's why it wont boot.


Boot OS X with the ModCD and when it pops up on your desktop open it up, you'll find a file in there called Preboot.dmg.

Double click it to mount it, it will then appear as a drive on your desktop.

Open it up and you'll find a directory Extra/Extensions, copy the contents to the Extra/Extensions folder on your EFI partition.


You can make Chameleon automatically boot a partition. In Extra on your EFI partition, you'll find a file called 'com.apple.boot.plist', copy it to your desktop and then open it with TextEdit or something and add the following:

<key>Default Partition</key>


Obviously change the 0,2 to suit your needs. If unsure, open terminal and do a diskutil list, it'll show you all your drives and the names and their drive/partition numbers.


Also, (you'll probably know/realise but just to be sure), you can't just add stuff anywhere in the CABP (com.apple.boot.plist) you have to add it where the other definitions are.


Create a new folder on your desktop, call it backup and copy the CABP from EFI to here (this is just incase things go wrong).


Copy the edited CABP on your desktop to Extra on EFI replacing your existing one.


Rebuild caches and repair permissions on the EFI disk, 'kext wizard' is good for this as you can point it do a partition that is not the running. (Note: kextwizard will rename Extra/Extensiont to Extra/Kextstore but that makes no real difference to us).

Or use terminal:

sudo chown -R root:wheel /Volumes/EFI/Extra

sudo chmod -R 755 /Volumes/EFI/Extra

sudo kextcache -v 1 -a i386 -a x86_64 -m /Volumes/EFI/Extra/Extensions.mkext /Volumes/EFI/Extra/Extensions


Reboot and give it a try.

Share this post

Link to post
Share on other sites

Nope, didn't do that before. Just did.


After copying everything over, I fixed the permissions with no issues. But when it came to rebuilding the cache, it said it couldn't write Extensions.mkext because there wasn't enough space. Finder reports that there are 0 KB available in /Volumes/EFI.


I restarted using the mod CD because obviously Chameleon wouldn't boot it, and tried that one line again (after mounting the partition, of course). This time, I'm getting "Couldn't lock : Operation not supported by device".


Do I need to make the EFI partition larger or something? And how would I do that, being that the OS X partition starts immediately after the EFI partition?


Thanks again!


Oh, by the way: I just opened up 'About this Mac' out of curiosity, and it's reporting that I have a 1.37 GHz unknown processor (I have a 3.4 GHz i7) and 2 GB of 800 MHz DDR2 (I have 1x4GB DDR3 installed at the moment). I've also noticed that the mouse movement isn't smooth. Once this gets up and running, would it be possible to fix these problems? I'm not looking to solve them now; just want to know if I can.


Last question: When I was using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to try to install OS X, I was told to remove one of my two graphics cards from the system, as well as three of my four sticks of RAM for installation purposes, but I haven't seen that requirement yet with Nawcom's boot CD. Can I reinstall those parts, or would it be safer to keep them out until the system is entirely set up?

Share this post

Link to post
Share on other sites

The Nawcom modCD no doubt contains alot of stuff you won't be using.

Can you list the contents of the modCD, or at least list the things you are trying to copy.


Your CPU identification normally comes from Chameleon but we may have to add a few strings to your CABP. No worries, I had to do that for both CPU and ram.


As for your additional hardware, leave it all out for the time being, it could cause no end of trouble at this early stage.


What mouse are you using? Is it wired USB, wired PS2, USB Wireless or Bluetooth?

Share this post

Link to post
Share on other sites

My mod cd has an Extra folder within Preboot.dmg, but there's no Extensions folder in there. I originally thought you meant add the kexts from the /System/Library/Extensions folder.


Extra has a bunch of kernels (legacy_kernel, etc.) and a postboot.dmg image. postboot.dmg doesn't contain any kexts either.


Where did you download your mod cd from? I got it from Nawcom's blog at http://blog.nawcom.com/?p=446 .


As for the mouse, I'm using a USB wireless mouse. I'll swap it out with a wired USB or PS2 when I can find one in my house :)

Share this post

Link to post
Share on other sites



Followed those instructions, and this time, when I started the computer for the first time, I got the Welcome video, which hadn't happened before!


Installed Windows on the second partition, now I could boot into Windows, but not Mac OS (obviously). So I booted into Andy's boot CD, got into Mac, and installed a bootloader (not sure whether it was Chimera or the one in the post-install package on Andy's cd, but both are Sandy Bridge compatible, so whatever). To my amazement, Windows AND Mac OS can both be booted without a CD! It surprised me because I didn't think the default installers ever installed to the EFI partition, and from my (limited) knowledge, this setup shouldn't work when installed to the Mac partition! But, whatever, it works brilliantly.


Oh, and I forgot to mention, somewhere along the line I updated to 10.6.8.


The only things left to do are install Ubuntu (which isn't working because the install CD won't seem to boot), ensure that networking works (read: get a longer Ethernet cable), and get the video card recognized and working at higher resolutions.


I won't ask you to help with the Ubuntu issue, because this is a Hackintosh forum, but if you have any quick suggestions I'd be happy to hear ;)


I've just done a bit of research, and it seems like I'm pretty much out of luck with a GeForce GTX 460 until nVidia releases an update, huh? Oh well, I can deal with 1024 x 768 for a while :D


Thank you so much for all your help. Without you, I would be nowhere near where I am now.

Share this post

Link to post
Share on other sites

Not a problem mate.


Ubuntu - Did you make the disc bootable? Make a usb with it on. I think there are windows utilities to download and make one all in one go.


I have a 480GTX and I installed the Fermi drivers and it worked beautifully (There's native support for mine in Lion).

Have a look for Tony Mac Nvidia Update if you cant find the genuine nvidia one, it's exactly the same just with some of the system checks removed.


Glad you got everything sorted. Did you manage to get your CPU recognised under 'About this Mac'?

Share this post

Link to post
Share on other sites

Regarding Ubuntu, I think it was a bad disk. Reburned the CD and it installed fine.


Forgot to adjust where grub2 was to be installed, though, so I majorly screwed up everything else. Reinstalling everything...again... :(


Yeah, the 480 has support in both tonymac's package and nVidia's package, but not the 460 AFAIK. I tried both; the first didn't do anything and the second refused to do anything (guessing the system checks didn't work out).


And with the reinstall of OS X with the new boot CD, About This Mac worked fine. In fact, I've already done a reinstallation of Mac OS X with all my hardware installed no problem, so even that was resolved!

Share this post

Link to post
Share on other sites

Ah, I was probably installing the Fermi drivers. That would explain the fact that it didn't do anything :wacko:


One (hopefully) last question for you, though: The first time I tried to install Ubuntu and it failed, I DID install grub2 to the correct partition, but it still wiped Chameleon as well as the Windows bootloader (as far as I can tell; I couldn't boot into Windows, even with a boot cd). Did a little research, and this seems to be an issue that some other people have had as well. Is there something I have to do with boot flags or active flags or some other flags? Also, would it be an option to install an older version of Ubuntu that gives you the option to NOT install grub and just install it later (or just boot with Chameleon, perhaps)?

Share this post

Link to post
Share on other sites

You need grub installed on the ubuntu root as that's what chameleon will detect.


Chemeleon boots grub, then grub will boot ubuntu.

Share this post

Link to post
Share on other sites

Ok, so I've got good news and bad news.


Good news is that the most current LTS version of Ubuntu does not wipe any other bootloaders on the disk when it installs to its own partition.


The bad news is that even though Chameleon recognizes that there is a bootloader on the third hard drive, trying to boot into it just leaves me at a flashing cursor. Windows also refuses to boot, citing a missing /Boot/BCD file (which is strange, since that seems like a Unix file path).


Adjusting the active partition doesn't help either OS; it always loads Chameleon, and it doesn't let Chameleon boot either Windows or Ubuntu.


Even just attempting to get to the system recovery options on the Windows boot disk gives "This version of System Recovery Options is not compatible with the version of Windows you are trying to repair. Try using a recovery disk that is compatible with this version of Windows." So your suggestion in the first post with diskpart won't help me here.


Any other ideas?


Also, I want to apologize for not responding yesterday; I was out of town all day and couldn't work on the system.

Share this post

Link to post
Share on other sites

Hey no worries, it's your rig, work on it as you like ^_^


Boot/BCD error is because you haven't re-sync'd your partition table.


To fix this, you must install gptsync, a Linux tool that synchronizes MBR partition tables with GPT partition tables, and hence allows Windows to load.


1. Load Ubuntu and make sure you are connected to the internet. You can connect to WiFi by clicking on the icon on the top right of the desktop.


2. Once you are connected, go to Applications -> Accessories -> Terminal.


3. Type sudo vi /etc/apt/sources.list and hit enter. You will be asked for your administrator (login) password to continue. This will load the list of sources for the package updater in the text editor vi so that we can add a new source.


4. Scroll down to the bottom of the file using page down or simply by pressing the down arrow. When you reach the end of the file, press the letter o. This will open the edit mode on a new line.


5. Type deb http://ftp.iinet.net.au/debian/debian sid main


6. Press ESC. This will exit edit mode.


7. Type :wq and hit enter. This will save the file and exit the text editor. If you make a mistake, you can exit without saving by typing :q!.


8. Now we want to actually install gptsync. Type sudo apt-get install gptsync and hit enter. Install commands should pop up and (hopefully) it should install successfully.


9. Type sudo gptsync /dev/sda and hit enter. You will receive a message to update partitions from MBR to GPT. Type y and hit enter.


10. Restart the computer with no disc in the disc drive. Confirm that both Windows 7 and Mac OS X successfully load.

Share this post

Link to post
Share on other sites

I probably would have done this already, but like I said, I can't even boot into Ubuntu!


Being that I need to install software, I'd imagine that this can't be done with a live CD, but would it work with a live USB drive? Or does the software need to be installed on a partition of the drive that needs repairing?


On an entirely seperate note, you're the only other person I know (besides me) that knows how to use vim :D

Share this post

Link to post
Share on other sites

I've spent too long in linux environments to not know vim, lol, even my mobile has a busybox terminal in it.


You should be fine using a live USB to do this, once you've re-sync'd I think ubuntu should boot from chameleon.

I re-sync'd just after I installed so I didnt ever have to boot ubuntu (except the install) so I never ran into this problem..... you shouldn't have restarted :D

Share this post

Link to post
Share on other sites

Well, my phone never notified me of your post until too late. Already did a full reinstall of all the OS's :):(


I think that previous installation also messed up somehow, because this time I can at least get to the grub> prompt and boot up using the linux/initrd/boot commands. After doing so, I resynchronized the partition tables, and now I can boot into Windows and Mac OS X just fine, but I still need to boot Ubuntu from the prompt.


I don't know much about manually configuring grub2, but I do have a bunch of menuentry statements within grub.cfg, as well as the /etc/grub.d/ files. It also noticed both Windows 7 and Mac OS X (not that these really matter, but still interesting). Locating the configuration file with configfile at the grub> prompt just clears the screen and throws me back to the prompt again.


Any ideas on how to fix this one? Or is this a job for the Ubuntu forums?


Again, I want to thank you very very much for sticking with me for the past week or so, as well as the whole of the OSx86 project and everyone here at InsanelyMac whose tools I used to get my system up and running. You have made what could have been a year-long project into a much more pleasant experience, and I am very grateful for that!

Share this post

Link to post
Share on other sites

No worries mate, forums are great like that.

I honestly have no idea why grub is playing up for you, I think I last installed Mighty meerkat and that worked fine.

Maybe grub has been updated, it might be better asking in the ubuntu forums for this one.

Share this post

Link to post
Share on other sites

Alright, no problem. After a few years of running Ubuntu on my laptop, I think it's about time I get a forum account over there, anyway :P


Again, thank you so much. Your help has been priceless!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.