Jump to content

IBM/Lenovo Atheros AR5212 Issues...


3 posts in this topic

Recommended Posts

I recently purchased the IBM/Lenovo Atheros 802.11a/b/g Mini Pci-express wireless card and have been having some issues trying to get it working under 10.4.7 (JaS).

 

I originally had the comparable Intel option, and had installed the Wireless Patch when I originally did this install. I noticed that the card was not found in "About This Mac" under Airport cards or any other networking section. I then checked dmesg and did not find it loading there either. I tried loading the IO80211.kext, which loaded successfully but did not help. I then extracted the IO80211.kext file on the DVD from the Intel Patch folder and that loaded but did not make the card work. The disk permissions were repaired after each file change.

 

I would appreciate some guidance on this issue, any help would be great!

 

fwiw, lspci in linux shows the card being the following:

0000:03:00.0 Ethernet controller: Atheros Communications, Inc AR5212 802.11abg NIC (rev 01)

 

Thanks!

Link to comment
Share on other sites

  • 1 month later...

I purchased this Lenovo TP 11A/B/G LAN MINIPCI EXPADAP model 40Y7026

http://www-131.ibm.com/webapp/wcs/stores/s...686018425101115

 

I installed it into my Acer 4202

 

No go in Windows - IBM does not even supply drivers.

I donwloaded the following drivers and there is no luck

http://www-307.ibm.com/pc/support/site.wss...ocid=MIGR-52527

 

I tried drivers from Atheros and Ekahua but no luck

The card is seen - but the radio does not turn on.

 

In OSX I followed Wei Jian's advice in post #57 and 58

http://forum.insanelymac.com/index.php?sho...13522&st=40

 

I installed the 10.4.5 kext and the Airport became available.

Link to comment
Share on other sites

 Share

×
×
  • Create New...