Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Intel D946GZIS DSDT Help

8 posts in this topic

Recommended Posts

i need to insert this:

Method (_DSM, 4, NotSerialized)
				Store (Package (0x02)
						Buffer (0x04)
							0x18, 0x3A, 0x00, 0x00
					}, Local0)
				DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
				Return (Local0)

into my LPC device for sleep. i dont know if im just reading the LPC device wrong or something, but it seemed really long. i thought LPC was only supposed to be 20 lines or so? I went to what i thought was the end of LPC (many pagedn's later) and inserted it, and compiled w/o issues but i didnt want to give the wrong device the DEVID. so i took it out, and im gunna let you guys try:)



and i need to put this in my IDEC (IDE/ATA) Device. because i have the issue as explained in the code box. not sure if im supposed to overwrite or add the code etc. i get ioatafamily KP, after secondary IDE disabled

IDE KP fix.

Some intel IDE controllers will panic with Snow Leopard, this hack courtesy of TheKing will solve it.


Device PATA on DSDT (0x001F0001)

OperationRegion (IDET, PCI_Config, 0x40, 0x04)
Field (IDET, WordAcc, NoLock, Preserve)
 M1, 16,
 M2, 16

Method (_INI, 0, NotSerialized)
Store (0xE307, M1)
Store (0xC000, M2)

Insert into _wak method:

   Method (_WAK, 1, NotSerialized)




Thanks alot! ive tried my self and i cant seem to get it w/o errors, ive done pretty much all the other DSDT hacks except speedstep(which i haven't tried yet) by my self(yay me!). Both the IDEC device and LPC device are in their native DSDT format, no changes currently, in the attached ZIP.


Share this post

Link to post
Share on other sites

thanks but umm i used winmerge to compare the two dsl files , before and after, but i dont see any of the usb or ide fixes in there?

Share this post

Link to post
Share on other sites
thanks but umm i used winmerge to compare the two dsl files , before and after, but i dont see any of the usb or ide fixes in there?



look at the 0x001F0001 --> _DSM

look at the "tree"

can be anywhere within the device

beginning or end or middle etc



You do not need to fix

Share this post

Link to post
Share on other sites

cool thanks!

i was asking because i get a usb erro at boot a timeout error Like this,


USBF 89.826 AppleUSBUHCI(0x1ce900):: found a transaction which hasnt moved in 5 seconds one bus 16 TIMEOUT

(from forum, not my log)



also, i have a intel pro 100 VE Lan 0x10948068

can i get it working in SL with just a DSDT or will i need to do some kexts? ive already found a kext but dsdt would be better


thanks again


yeah, taht didnt fix it i kinda knew it wouldnt:

ok so i restored the osx 10.6 dvd to falsh drive, put cham on there, put the kexts, dsdt CABP. and the install was glorious! no error( except that USB time out) no ATAFAMILY panic. but when i try to load the install HD from the same cham flash drive it gets stuck on ATA panic. their was no hardware changes or anything, just install then try to boot the HD.


it wasnt always like this, it worked before(installed osx to hd then booted from hd just fine), then started trying out audio and lan kexts (in SLE + EE) and a bios update(gunna try that now,revert back) then it stopped working. even after a complete re-install of osx, still no go(i can load the dvd not the HD). i removed all the lan and audio kexts from EE before i tried the new install. i could boot before with: fakesmc, sleepenabler, voodoops2 (the last 2 not being vital) i was so excited one kext(but no lan or audio.)


YAY i got it ;)


switched ATA/IDE mode to legacy instead of native in bios

Share this post

Link to post
Share on other sites

if you use vanilla kernel, dont use sleepenabler

NativePM + USB fix(if you need) = Sleep without kext


send me ioreg

Share this post

Link to post
Share on other sites

wow cool i didnt know that!


but i had a big mistake, apparently my usb chameleon stick doesn't load the DSDT for some reason so while ive been able to get it to work with just fakesmc, CABP, i havent been using the DSDT, which is why LPC wouldn't load. but now that i have cham on EFI, the dsdt loads and causes root device error, i tried both DSDT's before and after you fixed it. but i can still get in by bypassing the DSDT, and will get that IOREG.



ps also topic notifications werent working either :hysterical:

Share this post

Link to post
Share on other sites

files in zip


1. ok so in the ZIP attached their is the original DSDT unmodified in any way, except to fix a compile Warning (MUTE 0FFF to FFFF). The original DSDT will boot SL fine.


2. But the other DSDT in the zip, the one that i used your patcher(mald0n) with and did all the DSDTSE hacks on, does not work(root device error). i hope i don't offend you but i think your patcher did something. all the DSDTSE hacks are unrelated to IDE and SATA. or maybe it was when i asked you to apply that IOATAFamily kp fix?


3. the IOREG dump from SL with no DSDT loaded at all(weird: when i booted SL with no DSDT chameleon said before OSX started: cant read from bios something).


4. LSPCI, CABP, and some kernel logs


Also a question, if im using cham RC5 and i enable C + P states generating, do i need to do: DSDT - Vanilla Speedstep - Generic Scope (_PR)(http://www.insanelymac.com/forum/index.php?showtopic=181631). i have already done it and it doesn't seem to cause any KP etc, but i can take it out easily if needed.




EDIT: Mald0n i used the original bios, and used your dsdt patcher, i confirmed it, your patcher does something that messes up HDD booting and RD, sorry. i put the freshly cooked dsdt.aml from the patcher to EFI and got a RD. but i just booted a few minutes earlier using the original DSDT.


EDIT2: yeah another question sorry. i have a pentium dual-core and D946GZIS what model i dentifier should i use. i was thinking one of the iMac ones as that is what OSX puts there. but osx does 8,1 which doesnt support sleep, so i used SMBIOS to up it to 9,1. should i put it to iMac12,2?


EDIT3: i went to the auto patcher dir and found my patch file, and i tried reversing some of the patches but no go. :(


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.