Jump to content

boot0 error - Hackintosh 10.6.7 worked perfect for weeks!

3 posts in this topic

Recommended Posts

Here's what happened:


1. Perfect Hackintosh,everything worked for weeks/months. It also worked on that night - shut the PC off.


2. 8 hours later i wanted to boot. My PC has 2 HDDs. 1 for Mac and 1 for Windows. Normal bootloader screen,it boots automatically in Mac OS X. Endless booting. Restart,now it shuts down automatically after 5 seconds.


3. -v mode said something with CPU,dont remember what exactly. Reboot - Black screen says:


boot0: GPT

boot0: test

boot0: test

boot0: done...


=> If i disconnect the Mac HDD i can boot into Windows 7


4. Formatted the Mac OS X HDD,installed Mac OS X Snow Leopard succesfully. Installed Andy's P8P67 Package,10.6.7 update,[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] things and BridgeHelper. Could Reboot.


5. Shut the PC off and some hours later i wanted to reboot and ... again the boot0 screen. no bootloader,nothing. If i disconnect the Mac HDD i can boot in Windows.



Intel Core i7 2600k (No overclock)

ATI Radeon HD 4650


Installed OS X by using Andy's Boot CD,Andy's P8P67 Package,[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] (only for sound and ATI) and BridgeHelper.

Link to comment
Share on other sites

boot0 is 512 bytes written to the beginning of the first sector of the

hard drive, commonly called the MBR. Did you reinstall Chameleon

so that boot0 is installed? And the other two Cham files, boot1h and

boot go the root partition of SL. Without this, SL will just boot from

a boot cd, not the hard drive. Chameleon can be installed manually.



For Windows, there is a free bootloader called Easybcd which will let

you choose booting from the SL hard drive, as a temporary measure.


Hard drives are physical, and it's possible but rare, that the needed

area on your hard drive to store the boot0 file has been corrupted.

Actually, I think this is very unlikely in your case/error messages.


Most likely, a manual reinstall of the three files for Chameleon will

solve your problem. When you run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], installing the Cham

bootloader to the hard drive is an option you have to check mark,

and you may have forgotten to do that.

Link to comment
Share on other sites

I will try that. I dont know. A bootloader was installed with "Andy's Package" or his boot CD. He made a package for my motherboard with all kexts and things to work with my mainboard (bluetooth etc.). It also contained a bootloader.


Will try this soon,thank you.

Link to comment
Share on other sites


  • Create New...