Jump to content

Frozen screen but mouse moving and pc working

11 posts in this topic

Recommended Posts

Hello guys!

First thing first i want to say that this forum is wonderful and it's thanks to a guide found here that i could get my hackintosh running on my amd machine (guide: http://www.insanelymac.com/forum/index.php?showtopic=227592) applying to it the right corrections and adjustments where needed :( so, thanks a lot for your work! But let's arrive to my problem.

Generally when i am watching youtube videos or using skype video call my screen freezes, monitor stays up and the image of what was my desktop is still there with all the windows etc but i cant click anything despite the fact that my mouse moves and the pc keeps working, i mean it keeps playing the video or, in skype case, the call stays up... At the beginning i figured out that it could have been a problem of X11 and i replaced it with xquartz, but nothing happened, same error again, next I tought that it could have been my video card's driver crashing, made the advised fixes, added (while not necessary as it worked already out of the box) the EFI strings but still the same... pc it's perfect (except audio input), only this problem i truly hope that you'll help me out solving this.

I'm sorry for the "not so esplicative" title but I truly don't know how to call this problem, im sorry if i posted in the wrong section, mods ur free to move me in this case and finally im sorry for my bad english too.



I also get an error while booting:

"Decryption hasn't succeeded yet (probably will retry)

patch exec_obj_segment failed

map_segment failed"


My system:


MB: asus m4a785d-m pro

CPU: Amd Phenom 2 x4 945 (3.1 Ghz)

Ram: 3Gb 800 mhz

GFX: nVidia Geforce 9600 GT 1Gb


OS: Snow Leopard retail 10.6.7

Kernel: Legacy kernel 10.0.6/7 (both works but both suffer the same problem of before)

Boot Loader: Chameleon 2 RC5


If you need to know something else from me let me know, at the moment nothing else comes in my mind, hoping in a answere thanks in advance


Link to comment
Share on other sites

in 32 bits looks better... it still didnt crash... let's see how it goes... can't you help me guys?

EDIT: as i had said nothing... here it is.. crashed again youtube plus some other apps crash arrived whn i opened mail...



Link to comment
Share on other sites

Try setting a hot corner for display sleep in system preferences. When the video freeze happens, use your mouse to sleep and wake up your display.


You are my new God!!! thank you a lot! now this works in case... a way to solve it? (i hope im not asking too much!) thanks a lot again!!!

Link to comment
Share on other sites

If the drivers should cause a panic you can boot into single user mode (-s) and delete them from /System/Library/Extensions. When booting in single user mode, you must follow the instructions at the command prompt to run fsck etc etc before doing anything.


Then you should be able to boot in safe mode ( -x) and reinstall the old ones that you have backed up - all files in /S/L/E with Geforce in their name + whose name begins with NV.


However, the drivers also updates the OpenGL framework and probably some other files, not sure if that would cause any problems when reverting to older drivers.


If you need more details about this procedure use the search or google, there are many, many posts about it already.


I doubt that you will have any problems with the latest drivers if you're already on 10.6.7 with working video.


Obviously if you have modified any of the nvidia driver files themselves you will have to perform the same modification to the new files after installing them and before rebooting...

Link to comment
Share on other sites

Thanks for you answere, but those drivers doesnt support my GFX card, only the 9600m that its the one for laptops, so i doesnt allow me to install them... ant ideas on what i can do now?

Link to comment
Share on other sites

You are wrong, pay attention, that's not what the message says. This is even mentioned on the driver download page:

If you can't run the installer it's because your model identifier is not Macpro3,1, 4,1 or 5,1.


In theory the installer should run just fine as long as that requirement is met. Even if you don't have an nvidia card.


You must either use a MacPro3,1 smbios.plist in /Extra, or do the following;


Copy the installer mpkg off of the disk image, right click, show contents, find distribution.dist somewhere in there, open it in textedit and edit the model identifier check so that it matches the model identifier you're using. If you don't know, see System Profiler.


Save the file, run the installer, profit.

Link to comment
Share on other sites

Perfect!!! i reinstalled SL from zero because of the problems mentioned before and it made me again the same error, now i modified my smbios.plist and installed the nvidia drivers it looks all right... it gives a lot of errors when i boot in verbose... as soon as i can i take a photo of it and i show you... now i reinstall some cpu intensive apps and i'll see what i can pump out of this thing... thanks thanks thanks for the help!!!


this is the error i talked about:



it showed up after the installation of the nVidia drivers... but it seems like everything its allright... let me know...

thanks in advance

Link to comment
Share on other sites


  • Create New...