Jump to content

4 days till cranium meltdown


HeezDeadJim
 Share

9 posts in this topic

Recommended Posts

My name is Trent Sommerstein. I hail from the future of 2068. I have been delegated by the Order of Defiant Mosfet Monks to find an unorthodox solution to install a much more "primitive" version of the usurping "Majestic Unified Holy Operating System" (MUHOS), the OS that will soon evolve from the now OSX. I have less than 96 hours to get an old motherboard working to help restore privacy from the prying eyes of the White Tower's embrace. We have encrypted the Time Portal and I've sacrificed my left hand with a tracking ID to gain time. The lack of GPS tracking in this generation is vital to my success.....

 

Wait....what do you mean you have phones that track and log your every move without your consent?!?!?!?!

 

OK, now to be serious. I've been trying for the last few days to get OSX on my Gigabyte mobos. While I'm well versed in computer hardware and electronics, I have now only begun to dabble in the black arts (white maybe?). I have relentlessly tried many variants of SL 10.6 with little positive results.

 

Hardware:

Intel Q8300 (2.5Ghz quad-core)

Gigabyte GA-P43-ES3G (775/DDR2 bios:F14)

8GB DDR2 Wintec AmpX (only 4gigs for OSX installs)

nVidia 285 GTX (tried using a NVid 7950 GT, 1 monitor for install)

OCZ Vertex v.1 SSD (Seagate 80GB HDD partitioned in GUID for installs)

 

Attempts:

[boot from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CD (Chameleon v2.0 rc5?) then burned a OSX 10.6 "retail" to DVD-DL]

[ added -x, -v, -f, mach_kernel, PCURootUID=1, cpus=1 (not all at once) to no avail]

[booted from iDeneb 10.5 DVD, can get to install screen, but "install fail" halfway through to HDD]

[burned a supposed Gigabyte "bootCD" but still with same results]

[tried to boot from different OSX 10.6 ".dmg" files straight from 2 USB 8GB CF/SD cards]

 

I've also searched videos and Insanelymac forums for mobos' similar to mine, so as you can see, I'm not being lazy about attempting this by myself before I come here asking for assistance. I think my video card (both the 285 and 7950) are giving the most problems (I found out that the screen goes black but clicking the mouse "around" the screen incurs "loading" from the DVD). However, I may be missing some pre-installs like DSTD (or is that after the install?)?

 

If someone has the same motherboard or similar mobos, please tell me how you came about to get an install. Or if someone could direct me to maybe installing 10.5 and "upgrading", I'd appreciate that too. I will supply any details of all my attempts if anyone should request it. Thank you in advance.

Link to comment
Share on other sites

Greetings Program, welcome to the past. So it's true what they say, everything was better in the old days.

 

Boot your retail DVD with the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CD (or that Gigabyte CD you found) with -v and post a photo of where it halts. Use the full editor to attach files.

 

BIOS settings:

 

Set the SATA controller to AHCI mode

ACPI 2.0 and ACPI APIC enabled

All "advanced CPU features" enabled, except CPUID Limit

HPET enabled and set to 64-bit (if you have such a setting)

For troubleshooting purposes, disable hardware not necessary during installation such as Floppy drive controller, Firewire- Serial- and Parallel ports (it's not necessary to keep these disabled). Try disabling the on-board sound as well - but leave the LAN enabled. This is to minimize the chance of hardware conflicts, which (if any) you should be able to fix post-install.

Unplug all USB devices except mouse and keyboard.

 

For best results use

-only SATA drives, this includes your optical drive.

-only USB mouse and keyboard, no PS2 devices

-the GTX 285 - there is no support for Geforce 7xxx series cardsin 64-bit kernel and drivers mode.

-the monitor output on your video card that's closest to the motherboard (when facing the back of the case). Use a VGA-DVI adapter if you have to.

 

If all fails, try a CMOS reset. Yes I'm serious.

Link to comment
Share on other sites

Did a CMOS reset to start from scratch. Using my nVid 285 GTX again, set CD-Rom to first boot, HDD to second, and disabled 3rd boot. Booted from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] first...then Snow Leo retail with "-v"....and got a black screen and DVD-rom reads for a bit...then shuts down.

 

Second attempt: added -x -v with same result

 

Third attempt: changed "init video" from "PEG" back to "PCI" with -x -v....same result

 

Fourth attempt: using BootCD then -v -x with Snow Leo retail: "No DSDT found, using 0 as uid value" / Using PCI-Root-UID value: 0........then freezes

 

entering -v -x PCIRootUID=1 still freezes the install with the BootCD/SnowLeo DVD

 

OK...well it seems if I use the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/Snow Leo with -v -x PCIRootUID=1....I can get to the install screen. But I'm still in the same boat as i was before:

 

I can't get through with a full install to the HDD. I've unchecked everything before I click on the HDD that I want to install (made sure it's GUID/HSFJ)....and it still gets about 13% left, and the stupid Yellow warning sign pops up and can't finish the install. Same thing with iDeneb when I tried it. So it's great that i can NOW see the install window....just can't get it to install on an HDD for the life of me.

Link to comment
Share on other sites

Yep I forgot, many Gigabyte boards need PciRoot=1.

 

"PEG" means PCI-E Graphics, so just leave it at that. Setting it to PCI will cause nothing but a short delay on bootup until the BIOS finds out that there is no PCI graphics card to initialize and automatically moves on to your PCI-E card.

 

The DSDT messages et al are from the Chameleon bootloader, those are status messages, not error messages, there's nothing wrong. However, if you're booting with PciRoot=1 it should definitely not say "Using PCI-Root-UID value: 0"!

 

Not completely sure but I don't think you can complete an install when booting with -x (safe mode).

 

Try the BIOS settings I suggested and then try booting again with just PciRoot=1 -v (in that order and without the UID).

Link to comment
Share on other sites

Tried [ PCIRoot=1 -v] like you said....it does the boot to a black screen...then shut itself off after a few seconds. I don't know why it just shuts down/off.

 

What if i coax my roommate to let me borrow his nvid 9800 GS? Do you think the black screen will stop (2 different monitors and both go black)?

 

Does (-x) not allow to actually install but just do disk utility/terminal stuff only?

 

And what exactly does "mach_kernel" do, also?

 

BTW, thank you for responding so quickly....

Link to comment
Share on other sites

-x is safe mode. This means no sound and only VESA framebuffer graphics. Don't know what else, probably some ACPI stuff gets disabled as well.

 

You are thinking about -s which is "single user mode", booting to a command prompt.

 

mach_kernel is the filename of the "vanilla" OS X kernel.

 

Patched kernels normally has a different name, this is to prevent them from getting overwritten by a new kernel installed during an OS version update. The kernel (patched or not) can be named anything you like, for example "custom" or, in the old days, "mach_kernel_voodoo". But you can name it "daisy" if you like, it doesn't matter. You can specify which kernel to load from the boot prompt, or set it permanently in /Extra/com.apple.Boot.plist. No mystery.

 

You don't need to use a patched kernel, your CPU can use the vanilla kernel.

 

Try PCIRootUID=1 -v then since that (almost) worked for you before.

 

I'm not sure using a different video card will help, you already tried with the 7xxx card and the same thing happened.

 

Try again with the 285 but leave only one display connected. Use the output that's closest to the motherboard, when facing the back of the case.

 

Also try the MyHack and Nawcom boot CDs (google).

Link to comment
Share on other sites

When I meant a black screen....i meant it shuts the monitor off and i can't see anything even though there was still data being read from the DVD and sometimes it wouldn't shut down. So I'm guessing there was a pinwheel...i just couldn't see it.

 

The blue screen acts like it's frozen since it doesn't show any form of mouse activity...then it just shuts off after a few minutes of blue (more like a pastel blue) screen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...