Jump to content
Sign in to follow this  
Followers 0
RCOO

USB lento e problemas de wireless

16 posts in this topic

Recommended Posts

Olá!

Estou com um problema que me está a aborrecer.

Instalei o iAtkos S3 V2, Mac OS X 10.6.3.

Eu tenho um Linksys Compact Wireless G USB adapter WUSB54GC, estou a usar a versão 3.9.6 do IOUSBFamily.kext que vem pre-instalado com o iAtkos.

Estou a usar dois drivers para a Wireless USB. Um para funcionar (RT73USBWireless.kext) e outro para evitar ter de tirar e voltar a colocar a pen wireless em todos os reboots (RT2500Replug.kext). Apareceu, no entanto, outro kext, que eu não instalei (RT2500USBWirelessDriver.kext).

Tudo funciona bem, excepto o facto de as pen drives que eu utillizo com esta versão do IOUSBFamily terem velocidades de transferência muito lentas. (USB 1.0)

Depois fiz o upgrade para o 10.6.6. Reinstalei o IOUSBFamily.kext 3.9.6, e estava lento na mesma.

Instalei então o IOUSBFamily.kext v3.8.5, mantendo todos os outro drivers. As velocidades de transferência melhoraram significativamente, para niveis normais. No entanto, a Pen Wireless tem alguns problemas de incompatibilidade. Maior parte das vezes funciona, mas, se eu ligar uma pen drive, perco à ligação à Internet, e a pen wireless deixa de ser detectada. Se eu desligar a pen drive, e desligar e voltar a ligar a pen wireless, volta tudo ao normal.

É um pouco chato, visto que não poderei usar a minha wireless e ter uma Pen drive ligada ao mesmo tempo. Isto não acontece com todas as pens drives que eu ligo.

O meu disco externo não afecta a pen wireless. A minha pen drive Cruzer USB Stick também não.

Mas o meu iPod, o sistema de armazenamento do meu telemóvel e a minha pen drive de 1GB, sempre que são ligadas fazem-me perder a ligação.

 

O meu computador:

- Intel Core 2 Duo - 3.2Ghz;

- Asus P5GZ-MX motherboard;

- Intel GMA 950 (works using Intel GMA 950 desktop fix on DSDT);

- 2 GB Ram;

- 4 USB Ports: uma ocupada pela pen wireless. Outra pelas colunas USB. outra com um Logitech wireless receiver. e uma vazia para ligar pen drives.

 

Não sei se o DSDT vai ser a solução... Vou fazer o upload dos drivers da pen wireless, ambas as versões do IOUSBFamily.kext, a que tem velocidade mas problemas de internet e a q nao tem velocidade mas sem problemas de internet.

Também vou fazer upload do DSDT.

 

Data.zip

 

Se alguém puder ajudar, agradeço.

Share this post


Link to post
Share on other sites
Advertisement

Sim. É ICH7.

Fica aqui esse print:

post-728344-1299450024_thumb.png

 

Já tem alguma ideia sobre qual será o problema?

Share this post


Link to post
Share on other sites
Sim. É ICH7.

Fica aqui esse print:

chipset.png

 

Já tem alguma ideia sobre qual será o problema?

ICH7 não precisa de fix UHCI

 

UHCI é USB 1.0

EHCI é o 2.0

vc só deve ter uma ou duas portas EHCI

Share this post


Link to post
Share on other sites

Hmm. Mas eu estou ligando as pen drives sempre na mesma entrada USB.

O kext original, dava-me velocidades baixas. O kext que eu coloquei depois já me permite maior velocidade a partir da mesma porta, porque eu não troquei.

A questão é mesmo o porquê da net cair quando eu insiro alguns dispositivos USB...

Share this post


Link to post
Share on other sites
Hmm. Mas eu estou ligando as pen drives sempre na mesma entrada USB.

O kext original, dava-me velocidades baixas. O kext que eu coloquei depois já me permite maior velocidade a partir da mesma porta, porque eu não troquei.

A questão é mesmo o porquê da net cair quando eu insiro alguns dispositivos USB...

 

Eu posso até injetar IDs de ICH10, mas ICH7 realmente não precisa, não sei que mágica é essa que essa kext faz :wacko:

Share this post


Link to post
Share on other sites

Hmm. Não tem solução então?

Será que não tem jeito de editar o IOUSBFamily 3.9.6, para que as velocidades de transf. sejam as mesmas do kext 3.8.5?

Share this post


Link to post
Share on other sites
Hmm. Não tem solução então?

Será que não tem jeito de editar o IOUSBFamily 3.9.6, para que as velocidades de transf. sejam as mesmas do kext 3.8.5?

injetando os IDsdeve resolver

 

use o DSDT editor e Patcher

http://www.insanelymac.com/forum/index.php?showtopic=223205

e aplique o ICH9 USB sleep

Share this post


Link to post
Share on other sites

Não pode fazer o patch para mim, no DSDT qe eu mandei, mantendo também o patch da placa gráfica? Quando eu tentei para a placa gráfica ele deu kernel panic e tive de reinstalar. Um user aqui do fórum fez o patch para mim depois...

 

Isto se você puder =S

Share this post


Link to post
Share on other sites
Em qual dos kexts? No da baixa velocidade?

Vc tem de usar as kexts originais que vem no sistema, nada dessas modificadas

Share this post


Link to post
Share on other sites

Então tenho que usar a kext IOUSBFamily original (foi a unica que mudei) + dsdt com o patch?

Pode fazer o patch do DSDT para mim? (Não vai apagar o patch da gráfica, pois nao?)

Share this post


Link to post
Share on other sites
Então tenho que usar a kext IOUSBFamily original (foi a unica que mudei) + dsdt com o patch?

Pode fazer o patch do DSDT para mim? (Não vai apagar o patch da gráfica, pois nao?)

basta vc aplicar o patch com o DSDT EDITOR e PATCHER

Moleza

 

use a kext original + o DSDT parcheado

Share this post


Link to post
Share on other sites

Posso aplicar o patch ICH9 no meu DSDT que já tem o patch da gráfica, sem problema?

Share this post


Link to post
Share on other sites
Posso aplicar o patch ICH9 no meu DSDT que já tem o patch da gráfica, sem problema?

sim

 

ele só vai adicionar as infos no UHCI, não vai alterar nada em outro Device

 

;)

Share this post


Link to post
Share on other sites

Tenho outro problemazinho. Mas esse não é tão grave. É no meu laptop. Eu fiz o upgrade do 10.6.3 para o 10.6.6 e o painel das preferencias ficou todo cinzento e não posso editar as opções!

 

trackpad.tiff

 

Sabe o que fazer?

Share this post


Link to post
Share on other sites

Já apliquei o patch do DSDT. Coloquei na pasta extras.

Pus o .kext original, com as velocidades lentas. As velocidades lentas permanecem. Mas a Internet não falha, como tinha dito.

Como pode ver na imagem, a velocidade está limitada a 12MB/s. Com o outro kext, aumenta para 480Mb/s!

cont.tiff

 

E para confirmar, deixo esta imagem:

cont2.tiff

Com o .kext que estraga a internet eu tenho as portas a USB 2.0. Com o kext original as portas estão limitadas a USB 1.1! Não há um IOUSBFamily com patch que resolva isto? Ou um outro patch do DSDT?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×