Jump to content

How to Install Lion on any CoreDuo Mac upgraded to a Core2Duo

34 posts in this topic

Recommended Posts

  • 5 months later...

I have been running my Lion on my MacMini 1,1 for over a year now, using the "target disk mode" approach to boot an officially Lion-compatible Mac (a white MacBook) and then adding '<string>Mac-F4208EC8</string>' to /System/Library/CoreServices/PlatformSupport.plist. It has worked perfectly. Until this week!


I recently updated to 10.7.4, doing the update while booted on the MacBook just to be on the same side. The upgrade did not overwrite PlatformSupport.plist, and the MacMini booted up just fine after afterwards.


While at the logon screen, my one-year-old daughter was randomly hitting keys (this may be a complete coincidence), and the MacMini rebooted. Since then it will not boot, with verbose mode reporting: "This version of Mac OS X is not supported on this platform! Reason: Mac-F4208EC8". The MacBook continues to boot fine from the MacMini HD (SSD actually) using target disk mode.


I have tripled checked PlatformSupport.plist, renamed it out of the way, searched for additional versions of the file and also renamed the one in com.apple.recovery.boot. But still no luck.


Can anyone suggest what to try next? I am now stuck. I do not know enough about the OS X boot sequence to further diagnose the problem, and can't figure out what has changed since it was working!


Link to comment
Share on other sites

Well, I can confirm that the same problem that jgdh reported as having with 10.7.4 appears to affect 10.7.5 as well. Here's what I know so far:


-My mac mini (originally a core solo machine), upgraded to a 2.33 Core2Duo, installed 10.7.0 successfully with the method detailed in this thread.

-10.7.2's update worked after renaming or deleting PlatformSupport.plist

-10.7.3's delta update caused no problems

-10.7.4's delta update caused no problems

-I was able to install Server.app from the App store to turn the mini into a server on 10.7.4

-The 10.7.5 delta update (which included server components since I had updated to Server while running 10.7.4) broke the boot sequence

-Deleting/renaming the PlatformSupport.plist file has no positive effect.


It appears that the boot sequence has at some point lost some dependency on the PlatformSupport.plist, even though the 10.7.5 update put it back in place. Removing that file from the equation doesn't have the same effect anymore.


My next step will be to put an older version of the PlatformSupport.plist file on the machine and to have the machine ID in there to see if that helps.


Beyond that, I'm not sure what else to do. Any thoughts are appreciated!

Link to comment
Share on other sites

Quick update... I'm stumped.


I put the machine ID into the plist and placed it in the directory, but still no dice.


I found a report elsewhere (http://www.xlr8yourmac.com/systems/mac_mini_core_2_duo_swaps.html) with news of success, so I'm still hopeful. My mini differs from the success story, however, in that he has also apparently installed a firmware update to fool the mini into reporting that it's a newer (yet still Lion-unsupported) model.


In any case, if anyone out there has any more ideas, there are at least 2 of us on here that are all ears.

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
  • 2 years later...

im gonna see if this works on a standard core duo by creating 3 partitions on my hard drive, first: SnowLeopard(In case it doesn't work and to delete .plist file) Second:LionHD Third:LionInstaller(Following Above instructions). If it fails to install or boot, i will try a Hackintosh x86 Kernel and let you know my results.

Link to comment
Share on other sites

wayy wayy complicated, but it works and i havnt updated it yet, so im not sure if this works past 10.7.2

This is for 32-bit Core Duo not core 2 duo. It is running on my mid 2006 imac with no lags or need for extra kexts beside the ones from DP1

Follow the instruction from post 8, except instead creating new partition, were creatiing a new image that is 8gb in size using all post 8s settings. it will end in .cdr i named the file install.cdr, with the partition name still LionInstaller

Follow all instructions on post 8 after creating the image on the lioninstaller partition in the Installer.cdr image


Find the finder app from developer preview 2 online, happy hunting, this is the last 32-bit version of finder for lion and runs on 7.2

The Kernel has to come from Developer preview 1, hunt for this also, this is the last 32-bit kernel for lion and will boot 7.2 installation and it will be needed to boot the os as well

You will also need boot.efi as well as 

AppleIntelCPUPowerManagementClient.kext, AppleIntelIntegratedFramebuffer.kext,and AppleIntelCPUPowerManagement.kext from Lion Developer Preview 

Replace the kernel in the installer root

replace boot.efi then bless it

install, replace kexts and finder using snowleopard. done after fixing kext permission.


Edit: To flash to usb  $ sudo dd if={locaion of Installer.cdr} of=/dev/{Alias of Flash} bs=1 

I wont go too much into detail because the mach_kernal will boot the installer no matter what and if an idiot does this it will not boot screwing up their mac unless the have a second to firewire it, but im a windows user and i dont have a lot of experience with mac, so im not gonna assume much of the mac communit i just assume you guy are advanced mac users and are smart enough to follow my steps.

Link to comment
Share on other sites


  • Create New...