Jump to content

Multiple dead ends on Radeon 4850


roflmao
 Share

4 posts in this topic

Recommended Posts

I've spent about 50 hours trying to get my [vanilla] Snow Leopard to recognize my 4850HD with qe/ci to no avail. After countless google searches I've practically tried everything so I've hit a dead end and don't know what to do now. Everyone I ask on IRC says that the 4850 HD is a 'well-supported' card so I wonder why I'm having so many issues.

 

My OS either hangs at boot (no kernel panic) or shows artifacts on the screen, depending on what I do to try to get the Sapphire 4850HD with 2 DVI ports to work (I'm not using a dongle). The different things I've tried:

 

 

  1. On 10.6.5 tried inserting my device ID directly into ATI4800Controller.kext, reboot, nothing happens, tried setting GraphicsEnabler=Yes. When I do GraphicsEnabler=Yes I get a black screen with white artifacts (or grey screen with black artifacts if I didn't do verbose). I will post a screenshot later on
    ----------------
  2. On 10.6.5 tried installing LegacyATIController.kext and enabling it with either GraphicsEnabler=Yes or EVOenabler. Same problem as above with the screen artifacts
    ----------------
  3. Netkas qe/ci patch on 10.6.5 gets ignored at boot, I get the following error on the logs:
    ATI4800Controller.kext has been ignored. The vtable 'hugelongstring' is malformed. Please make sure your kext is built against correct headers. I think I only get this error message if I install the qe/ci patch after I reboot after the 10.6.5 software update. If I install the qe/ci patch before the reboot, I get a boot hang with no distinguishable error.
    ----------------
  4. ######## video card patch for 48xx series on both 10.6.5 and 10.6.6 either does nothing or has sometimes caused my boot to hang without any distinguishable error message, forcing me to do an entire reinstall (something I've had to do at least 30 times by now)
    ----------------
  5. Netkas qe/ci patch on 10.6.6 hangs boot with this error message:
    virtual bool IOHIDEventSystemUserClient::initWithTask(task*, void*, UInt32): Client task not privileged to open IOHIDSystem for mapping memory
    ----------------
  6. Tried to use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] instead of the 'generic' Chameleon RC4 I have. It gives me a drive is unsupported error.
    ----------------

 

I've tried numerous combinations of all of the above in all sorts of imaginable ways, but nothing seems to work.

 

Any suggestions before I throw in the towel?

Your help is greatly appreciated.

 

- roflmao

Link to comment
Share on other sites

  • 1 year later...

Hello. Use the latest ######### for SL. Select the ati 48xx device injector and ati 48xx patch for your version of SL. Use latest kext utility to install EvoEnabler.kext (you stated you already have this) in system/library/extensions. Boot with GraphicsEnabler=No or add it to your org.chameleon.Boot.plist. Good Luck.

 

 

topic posted 09 February 2011, last users connected date: 11 April 2012

Edited by fantomas1
Discussion of commercial spin-offs of the OSx86 scene is allowed if it’s to understand their existence, but no discussion of how to use them, nor any support for these commercial spin-offs are allowed as they are not in the spirit of the OSx86 scene.
Link to comment
Share on other sites

  • 2 months later...

I understand your edit. May I ask what the "spirit of the OSx86 scene" means exactly, with respect, moderator?

 

 

 

 

 

read this : http://www.insanelym...howtopic=279451

 

I agree completely. I will be more careful with my posts in the future. Thank you very much.

 

 

thank you for your understanding ! ;)

 

Is it okay that I uploaded the evoenabler file? I thought it might help, but now I'm wondering if I should have or not. I found the file when I had this card installed myself, and used it for years. I did not edit it myself. I have had a lot of free time recently, and I thought I would try to return a small bit to this community which has helped me so much. I am sorry if I broke the rules. I will think more carefully before I post next time. I truly am grateful for all the knowledge I have gained from this forum. Again I am sorry to have caused trouble. I will strive to teach more than just pass out quick fixes in the future. Thank you moderator for making me think a little.

 

 

there's no problem with uploaded EvoEnabler and never will have problem with your help to this community while you respect the rules. There's nothing with you, don't care ! :) Be happy here !! ^_^

 

Good luck and good hack !! ;)

Edited by fantomas1
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...