Jump to content

VooDooHDA causing panic! IOKit to blame?


AustinRoepke
 Share

6 posts in this topic

Recommended Posts

Hello,

 

Pertinent information:

 

Motherboard Gigabyte GA-EP35-DS3L w/ DSDT Auto Patcher(http://www.kexts.com/downloads.php?do=file&id=846)

Installed iAtkos 10.6.3 w/ 10.6.6 update and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] UserDSDT with no customization or kexts.

Installed tonymacx86's NVIDIA update for 4xx gpus.

Chameleon RC4 installed from iAtkos bootdisk.

 

the DSDT contained all working drivers, along with an older VooDooHDA kext.

 

Got an error;

 

Debugger called <panic>

error: failed to open PCI device

 

org.voodoodriver.VooDooHDA(2.7.1)@ (x64 location)

 

Kernel extensions in backtrace (with dependencies):

dependency: com.apple.iokit.IOAudiofamily(1.8.0.fc1)

dependency: com.apple.iokit.IOPCIfamily(2.6)

 

I just wrote these down. Because audio/IOkit isn't vital, I can boot into safe mode w/o forcing kexts.

 

I got this same error with an earlier version of VoodooHDA and the new IO Family package from Apple. I backrolled the IOfamilies with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], but no avail.

 

If anyone has any ideas, please send them my way!

 

Thanks,

 

Austin

Link to comment
Share on other sites

Odd thing. I tried to unload the VoodooHDA and I get this:

 

host-81-57:~ RoepkesHackintosh$ sudo kextunload /system/library/extensions/VoodooHDA.kext

Password:

(kernel) Kext org.voodoo.driver.VoodooHDA not found for unload request.

Failed to unload org.voodoo.driver.VoodooHDA - (libkern/kext) not found.

 

I see it in finder, but I can't find it with the terminal...

Link to comment
Share on other sites

  • 6 months later...
delete AppleHda.kext ou use disabler in Extra/Extensions

AppleHDADisabler.kext.zip

 

HDEF + VoodooHda = KP

 

Amigo Mald0n, estou precisamente a ter constantemente no OSX Lion este mesmo problema que aparece aqui, kernel panic com o VodooHDA usando o autopatcher, percebi agora pela sua frase que HDEF+ VoodooHDA= KP, podias-me remover do meu dsdt.aml o HDEF, os meus drivers de som sao via VIA VT1708S, e uma vez que não existe solução para para colocar a AppleHDA modificada a funcionar na minha placa de som, pedia se me podias, editar o meu dsdt.aml removendo o HDEF?, ja removi a AppleHDA e tambem instalei a AppleHDAdisabler, mas o problema continua :blink:

Obrigado

dsdt.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...