Jump to content

"Unable to read partition map"


5 posts in this topic

Recommended Posts

I was following the guide to use Acronis and have created the Primary FAT32 partition. When I boot the OS X (10.4.6) DVD and attempt to use Disk Utility to "Erase" the partition and format with Mac OS (Journaled) I get the error, "Erase failed, Unable to read partition map".


Has anyone else evr gotten this, was there a fix? Didn't see anything using search so thought I'd ask, thanks.

Link to comment
Share on other sites

I got it, maybe this will help someone else...


Turns out, it was my Vista primary partitin screwing things up... I think.


I had my disk laid out like this before OSX Install:


(Using Acronis OS Selector)


XP Primary

Vista Primary

Mac OS FAT32 Primary-> Tried to convert via disk utility (Failed everytime with above error)

Extended -> Logical - Swap (XP Swap)


Solution? Delete Vista primary and resize XP primary to use free space from Vista primary.


After killing Vista primary, my disk looked like this:


XP Primary

Mac OS Primary (Converted fine with disk Util)

Extended -> Logical - Swap (SP Swap)


Now, since my Vistas are legal, I'd like to run it... think it would be an issue creating a logical drive and reinstalling?

Link to comment
Share on other sites

Well I've gotten my OS X running along side Windows XP using Acronis' OS selector.


I had to drop in an old PATA Seagate (10GB) drive and reload in order for it to boot however, also had to use both PS2 mouse and keyboard for both to work. (Was using USB mouse with PS2 board)


I see there are some fixes around the forum so I'll check those out.


This too cool though, I'm using a GB K8NS nForce 3 board and mostly all hardware is supported.


Have sound, networking, and video (Radeon 9600 AGP) as well as full USB and printing support.


Also, the speed is very good.

Link to comment
Share on other sites

I had the same problem. My set up was:


Windows XP (Primary)

Mac (Primary)

Data (Extended)


...and when trying to erase it said: "Could not read partition map"


but when rebooted into Windows and used Acronis to change the Mac partition to logital it worked.


My system:

Acer TravelMate 800LCi

Pentium M 1.3GHz

1.5GB memory

Link to comment
Share on other sites


  • Create New...