Jump to content
InsanelyMac Forum
Sign in to follow this  

DiskWarrior (4.2) - kernel panic during boot

Recommended Posts

Recently I had a weird problem with my MacBook Pro with Snow Leopard 10.6.6.


"Still waiting for root device" - Apple NO sign.


After doing the obvious (Disk utility via install disk -> fix permissions; PRAM reset; SMC reset; reblessing efiboot) I was left with DiskWarrior 4.2 Bootable DVD.


Unfotunately it was giving me a Kernel Panic each time I tried to boot it.


Now for some of you this might be obvious but, since I haven't found any real sollution to this anywhere I decided to contribute a bit. :D


You will need another mac. :)



Check in verbose mode which kext is causing the kernel panic and remove it from the disc image before burning DiskWarrior again.




1. Boot DiskWarrior in verbose mode: Hold alt (option) on boot chime until you see the boot manager. Put in the DiskWarrior DVD and wait for it to appear. Now hold apple (command) and "v" simultaneosly while hitting enter on DiskWarrior.


2. Analyse the KernelPanic: You will see a lot of messages across the screen but you are looking for one in particular (once it stopped moving). The one which indicates which kext caused the Panic (in my case AppleHDA).


3. Make the DiskWarrior disk image writeable: use DiskUtility (obviously on another mac, or use another program to edit dmgs') to convert the dmg to "read/write".


4. Remove the faulty kext: mount the DiskWarriorDVD. Use terminal to navigate to




type: sudo rm -R kextname (eg. sudo rm -R AppleHDA.kext)


type in password and hit enter.


5. Unmount DiskWarrior, burn the dvd and boot (preferably in verbose mode again). :)





Now, this did not solve my "still waiting..." problem, but now I have a working DiskWarriorDVD.


Disk Warrior solved some of the (alleged) problems it found, but besides, everything seems the same. :P


If someone could help me with this, thanks in advance.

Share this post

Link to post
Share on other sites

I finally found a solution.


After trying everything,


Disk utility (on safeboot, on install disk, on another mac)

DiskWarrior (on safeboot, on bootdvd, on anothert mac)

fsck (even advanced options)

pram reset

smc reset

etc. in all possible configuration, by even removing the disk from the unibody case and attaching it via USB to another mac.


I finally found a solution. These failures are always due to faulty BIOS settings or faulty kexts on OSX86. But since I am on a MacbookPRO, there is no BIOS.


Long speech short


Replace IOStorageFamily.kext in /System/Library/Extensions with one from a working mac, or from the installation disc using Pacifist, or whichever way you prefere.


Fix permissions and ownership, repair permissions with discutility. Remove caches.


And you are good to go.


I can imagine that sometimes other kexts may be the faulty ones. In such cases it is always good to analize verbose mode first.


This is how I managed to fix my problem without having to reinstall.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.