Jump to content

Problems with Volumes. iPod incorrectly detected


Takuro
 Share

1 post in this topic

Recommended Posts

- 5th gen iPod Video 30gb

- Mac OS X 10.4.7 w/ latest security update

 

Short story ::.

Here's the basic problem: OS X incorrectly detects my iPod's model. Windows doesn't. This problem didn't exist until today.

 

 

Long story ::.

I've been having some problems with my iPod in OS X. The first problems occurred when I ejected the iPod, disconnected it, and then reconnected it. Even after launching iTunes, it wouldn't mount. It wouldn't mount the iPod until I rebooted my system. Sometimes when I plugged in the iPod, my primary hard drive would display as a generic blue folder and many other icons went awry as well. (This leads me to suspect a problem in volume detection)

 

Plan A: I decided to try to reinstall iTunes, thinking maybe there was an iPod driver problem. I used Pacifist to do this. This didn't fix anything. (I thought I should just mention this. Could Pacifist wind up installing the wrong driver from the iTunes package, or one that would normally not be installed? Like a Jaguar driver maybe..)

 

Plan B: I thought it might be a good idea to hold down the MENU and SELECT buttons on the iPod to reset it. After I reset it and plugged it in, it mounted just fine. But now I had an all-new problem: it was detected as an iPod mini. I noticed this after I went into iTunes and found myself unable to add video content to the iPod.

 

I downloaded the latest iPod updater. Strangely enough, it detected the iPod as a 2nd gen model. It installed the wrong firmware version, which messed the iPod up pretty badly. Another thing to note: the updater was unable to display the iPod's serial # or model #. After running the updater, it was no longer detected as an iPod Mini. It was detected as a 2nd gen iPod!

 

So I booted into windows and downloaded the windows version of the updater. It worked fine! However, when I booted into OS X, it decided to detect my iPod as a Mini... yet again. I ran the iPod updater in OS X yet again, and it showed the model # and serial #, but it still suggested that firmware for a 2nd gen iPod be installed.

 

Any suggestions would be appreciated!

Link to comment
Share on other sites

 Share

×
×
  • Create New...