Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Numberfly

Acer Aspire 5720 Snow Leopard install problems

3 posts in this topic

Recommended Posts

Hey, I have been trying for quite awhile to isntall osx86 on my Acer 5720 laptop. I first tried iPC 10.5.6 and the install worked fine, however neither my LAN or Wireless would work (possibly becuase I didnt know which Kexts to choose), i am slightly more informed now but still no go.

 

I then tried Hazard's Snow Leopard 10.6.1-10.6.2 (because of a sucess listed on the HCL and tried to follow the way he/she installed, still no luck, so here i am, lol and I was wondering if anyone had a similar laptop or hard config and how they did it. Here's teh specs:

 

Acer Aspire 5720z

 

Intel T2330 1.73 Dual Core CPU

 

Intel 965 Chipset

 

Integrated 965 Video card

 

Broadcom 5709 Ethernet LAN

 

Atheros AR5007 Wireless

 

 

 

Thanks in Advance for your Help!

Share this post


Link to post
Share on other sites

..thought I may be able to lend a hand here, to anyone else struggling with this laptop

 

I have a Aspie 5720z. after a 2 day {censored}fight with it, i have come out ALMOST victorious. Everything works except the damn wifi, which i'm still working on, with hope.

 

so here are the specs of this one, from what i can tell:

CPU: Pentium Dual Core 1.8Ghz (Shows up as Core 2 Duo 1.87Ghz)

RAM: 2Gb DDR2/533Mhz

HDD: Seagate (i think) 160Gb SATA

Graphics: NVidia 8400m 256Mb

Audio: Realtek 268 (i think)

Ethernet: Broadcom 57xx...not sure.

Wifi: Atheros AR5BXB63, (showed up as AR5007EG in vista. )

 

here's what i did:

1. used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd to boot and mac osx 10.6.3 retail dvd to install. (removed printer/language packs)

2. plugged in usb mouse as the touchpad "Shatners" the mouse cursor. I invented the term cos the cursor animates much like William Shatner in Family Guy. If you lose the ability to click with the mouse, touch the touchpad and it should come good.

3. boot into newly installed system with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd. the animation with the godawful hipster music will play. setup your location, name, account, etc. trackpad will still be Shatnering.

4. plugged in usb containing [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and all the necessary kexts, copied them to documents

5. install [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]: [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] install, System Utilities, Graphics->NVenabler, Audio->VoodooHDA0.2.2, All of miscellaneous except for the usb3 thing, System definitions->MacBook Pro

6. Reboot without cd. Graphics now running beautifully with full resolution and QE/CI fully supported, sound working, and trackpad no longer Shatnering. No network supported though. Daing.

7. Copy VoodooBattery.kext, AnyiSightCam.kext, and IO80211Family.kext to /System/Library/Extensions. (used terminal. sudo cp -R )

8. Copy AppleBCM5701Ethernet.kext to /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns, replacing the old crappy kext of the same name.

9. Repair permissions, rebuild caches (battery icon will show up at this point), reboot.

10. ->System Preferences->Network. 2 New devices detected. Airport and Ethernet.

11. ETHERNET WRRRKS! w0000t. So does the webcam - I can now frighten myself with my grotesque appearance in PhotoBooth. Airport fan icon will appear in top right corner, but won't allow you to turn Airport on.

12. Plugged in LAN cable, performed Software Update, installed new itunes, ilife client support, airport update, remote desktop client update, and the 10.6.8 combo update. reboot.

13. Ethernet and Wifi no longer detected at all. Repeat steps 7, 8, 9 (minus battery and isight) and they work again. (Airport still won't turn on)

 

So that's where i'm at.

Got a 5720z on Snow Leopard 10.6.8 that is near perfect, except for the Airport which won't turn on.

Tried kismac and it doesn't show anything.

 

I'm gonna keep trying different stuff, and will post again when i have a win.

If anyone has any helpful tips on Atheros ar5007 make goingnow it would be awesome. thankyou.

 

ive attached a zip of all the kexts that i used for this, except [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url].

you should know where to get that.

 

HAPPY NEW YEAR EVERYONE.

Aspie5720z.zip

Share this post


Link to post
Share on other sites

I got WiFi working by replacing the card with a Broadcom model from an old laptop. Not working:

 

1. Sleep.

2. Ethernet. I can get it working using the described methods, but it prevents the machine from doing a reboot (just hangs on shutdown).

3. Touchpad scroll area. Is this supposed to work?

 

Everything else works perfectly. Any pointers on the above three issues greatly appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×