Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
lycrake

Hackintosh suddenly won't boot (Signal 8) - Time Machine the culprit?

3 posts in this topic

Recommended Posts

Hi there guys

 

This has been a very helpful forum, and i'm hoping that people will be able to help me again.

 

My Hackintosh has OS X 10.6.4 on one hard drive and Windows 7 on the other. Until very recently it was working perfectly, and could boot into either OS and there were no problems at all.

 

I recently enabled Time Machine to backup to an external Hard Drive.

 

Yesterday i tried to boot in OS X (as usual) but a progress bar popped up beneath the normal spinning wheel, it got to half way, disappeared, came back, went to halfway again and then my PC shut off.

 

When I booted into single user mode and ran fsck (and Applejack) to repair the disk I ended up with the error

 

"Cannot create links to all correct files

/DEV/RDISK1s2/ (HFS) Exited with signal 8

 

and then it prompted me to try and repair the disk again. Basically i couldn't get past this stage.

 

I then booted up into Windows and ran MacDrive 8 to try and repair the drive that contains OS X. All went well until the last stage which then said "Volume cant be repaired, you might need to reformat.")

 

So again I rebooted, and this time OS X booted up fine (after a progress bar appeared for a bit)

 

Very odd, it all appeared as normal and worked fine, however, when i sent it to sleep, or rebooted I get the same problem again with it not booting up- and the only remedy is to go back into Windows and attempt to repair the disk...

 

Any ideas? I want to hold Time Machine the culprit, as I turned this on a couple of days again and the problem seemed to start then. I have since turned it off- but the problem hasn't gone away....

 

Help!

Share this post


Link to post
Share on other sites

For other people who have the same problem, I managed to fix this- but it was a bit of a mission.

 

In the end I couldn't repair the disk- so I just had to boot into the OSX dvd and restore my computer from my Time Machine backup- I then had to run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to get a couple of things working again, but I am back up and running.

Share this post


Link to post
Share on other sites

Did anyone actually find a fix? I don't think a rebuild can be counted as a fix really...more of a give up and start again! Mines just piped up with the signal 8 this morning, after no sign of anything wrong.

 

It can't be a disk error as I'm typing off my healthy windows partition as we speak, and the disk checked out. Surely its something in the filesystem thats given up and can actually be repaired?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×