Jump to content

SL on Asus P5N-MX

2 posts in this topic

Recommended Posts

Hi guys,


I just installed SL 10.6.3 from iAtkos S3 v2 dvd on an P5N-MX mobo. I couldn't install it normally, with a dvd, as I was stuck at "waiting for root device" every time. So I installed it via vmware, using a physical partition, then restarted my pc and continued the gui part of the setup. Everything was fine, except for some minor issue with the mouse (it froze when I was selecting the country, but I plugged it in again and it worked fine). SL boots without any flags, so everything is ok here.


Now, I have several issues that really bug me. First, as expected, the display is not working as it should, I only have the 1024x768 resolution. My card is Ati 5770. I tried that [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] thing, but it doesn't seem to do anything.


Secondly, I have a problem with the sound. It's working with VoodooHDA (I think), but the microphone is always on and I can't turn it off. I tried selecting different outputs, but nothing changes. Also, in VoodooHDA pref pane I only have HDMI out (from the video card I think).


And another thing, the ethernet connection. When I installed SL, I selected the "nforce networking" kext, and the network worked from the first time. However, after each reboot, SL finds "a new ethernet connection". I am now at Ethernet 10, and it's really annoying. Don't have a clue why this happens.


That's about it. If you guys can help me with some or all of these issues, it would be great. I was thinking about doing a clean reinstall of SL and ask you about what should I choose in the installation options (kexts, fixes, etc.).

Link to comment
Share on other sites

  • 5 years later...

Asus P5N-MX (610i chipset) needs PCIRootUID=1 and probably npci=0x3000 for Nvidia graphics card (I'm using a Geforce 210), pretty typical for nvidia chipsets.


EFI graphics string can be generated in OSX86Tools


Main thing is to choose the right connections for your card ie DVI-I VGA or DVI-I DVI-I etc and the cards memory size.


add the string between <string> and </string> and put it all in the org.chameleon.Boot.plist





Sound needs a ALC662 VoodooHDA 



I used OpenHaltRestart to avoid shutdown/restart/cmos reset problems.


Sleep may work with the USB device wakeup jumper set to S3 on the motherboard and S3 set in the bios and legacy usb disabled in the bios (otherwise it won't go to sleep and just hangs).


Sleep may also work with all USB disabled in the bios and a PCI NEC USB2 card used instead.


I get Sleep to work by enabling everthing in APM Configuration and disabling USB Legacy in the bios, and then waking Yosemite via USB using the USB Keyboard Space Bar (the power button might not work correctly as a wake up).


No DSDT is needed and any DSDT edits for PIC, TMR, HPET etc just result in sleep breaking.



Bios APM Configuration




Power On By PCI/PCIE Devices [Enabled]
Power On By External Modems [Enabled]
Power On By RTC Alarm [Enabled]
HPET Support [Enabled]
Power On By Keyboard [space Bar]
Power On By PS/2 Mouse [Enabled]


Ethernet works with nForceLAN (0.64.5) http://www.osx86.net/file/1942-nforce-lan/


nvenet.kext in the plugins folder of IONetworkingFamily wants to load as well as the nForceLAN kext, so nvenet.kext needs to be removed and the extension cache needs to be rebuilt (just drag the Caches folder in /System/Library to the trash and reboot.


Interesting things happens with the inbuilt nvidia video and a Geforce PCI-E card (Geforce 210).


NVDANV50Hal(Tesla) wants to load for the inbuilt nvidia video and also load for the Geforce PCI-E card, resulting in a black screen even though the EFI graphics string is right for the Geforce PCI-E card.


The nForceLAN kext loading seems to stop the inbuilt nvidia video being loaded by NVDANV50Hal, so then the Geforce PCI-E card can  get loaded by itself and function normally.


The best thing to do would be to add a device id for only your card to NVDAGF100Hal.kext or NVDAGK100Hal.kext or NVDANV50HalTesla.kext and don't add or allow any other device ids, forcing the nvidia kext to just load just for your nvidia PCI-E card.





This AppleNForceATA is the only one that works with PATA (IDE) on Yosemite, that I've found.


Otherwise it's the old "still waiting for root device" routine.


It might work on others as well , Snow, Mountain, El Capitan, although AppleNForceATA-1.06 is apparently for El Capitan.






Set Bios to AHCI.


Tested on an Asus P5N-MX with a 610i chipset.


PATA interface is "10de:056c" and is also called "MCP73 IDE".


SATA interface is "10de:07f4" for AHCI mode, and "10de:07f8" for RAID mode.


Link to comment
Share on other sites


  • Create New...