Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
kevintroy

Compaq Presario SR5129UK

4 posts in this topic

Recommended Posts

I have a Compaq Presario SR5129UK which I've added a NVIDIA 9500GT 1GB graphics card into in aims of installing either Leopard or Snow Leopard onto, but I have a bit of a problem...

 

When i go into my BIOS I have no option to change to AHCI mode, which I believe is needed to run Leopard or SL?

 

I've tried to install iDeneb and iAtkos onto my system but neither will load, I get a "stop sign" on the grey screen after a few minutes, I've also tried to install both via Virtualbox but neither work (iDeneb installs but after i unmount the CD to restart after installation, it goes to a blank grey screen and hangs)

 

What are my options? here are my computers specs (screenshots taken from CPU-Z):

 

Compaq Presario SR5129UK

CPU

Caches

Mainboard

Memory

Graphics

 

massive thanks to anyone who can help me!

Share this post


Link to post
Share on other sites

That's strange, I have exactly the same computer but with a 9600gt gfx card instead and although I couldn't get OSX working with one hard drive, I definitely had the option to change to AHCI within the BIOS. Just to confirm, is there an option called "SATA Mode" on the first screen that appears when you enter the BIOS setup? If there is then that's where you need to be choosing AHCI. (If the option isn't there it might be worth checking if you have the most up-to-date drivers for your hard-drive.)

 

Before you change the SATA mode however, remember to enable AHCI mode in windows 7 otherwise you'll have to go through the painful boot recovery process to make it work again. Do that by following the guide here.

 

If you can get it working on a second partition then congratulations. I personally couldn't, but I did get it working perfectly when I installed on a second hard drive.

 

Hope this helps

Mike

Share this post


Link to post
Share on other sites
That's strange, I have exactly the same computer but with a 9600gt gfx card instead and although I couldn't get OSX working with one hard drive, I definitely had the option to change to AHCI within the BIOS. Just to confirm, is there an option called "SATA Mode" on the first screen that appears when you enter the BIOS setup? If there is then that's where you need to be choosing AHCI. (If the option isn't there it might be worth checking if you have the most up-to-date drivers for your hard-drive.)

 

Before you change the SATA mode however, remember to enable AHCI mode in windows 7 otherwise you'll have to go through the painful boot recovery process to make it work again. Do that by following the guide here.

 

If you can get it working on a second partition then congratulations. I personally couldn't, but I did get it working perfectly when I installed on a second hard drive.

 

Hope this helps

Mike

 

Hi there, I've checked my BIOS again and the only similar thing I have is Onboard PATA/SATA Drivers which include the following:

 

PATA Controller - Enable or Disable

SATA1 Controller - Enable or Disable

SATA2 Controller - Enable or Disable

 

I've checked the Compaq website for driver updates but I see none for the BIOS when I choose windows 7, however, if I say that my OS is Windows Vista (which originally came with the computer) then I get the following BIOS update:

 

 

P5LP-LE Motherboard BIOS Update

Description:s.gifP5LP-LE Motherboard BIOS update corrects SATA port information displayed in BIOS setup.

Im guessing this wont work because it says that I must have Vista and be logged in as administrator to install the update.

 

Also, what version of OSX were you using? iAtkos? iDeneb? etc etc? I was looking to preferrably get Snow Leopard but if not possible then I can stick with OSX :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×