Jump to content

Radeon 4850HD problems


3 posts in this topic

Recommended Posts

Hi. I upgraded to 10.6.5 because seemingly I couldn't upgrade over 10.6.0 and have working graphics..


It looks like I'm close though. Safeboot can see the info for the GPU, I have Chameleon RC5 installed, graphicsenabler on and my device and vender ID's are in ati4800controller.kext's info.plist.

Just to make sure:

		  <string>0x94421002 0x944a1002</string>

ATI Radeon 4850 Series:

Chipset Model:	ATI Radeon 4850 Series
Type:	GPU
Bus:	PCIe
Slot:	Slot-1
PCIe Lane Width:	x16
VRAM (Total):	256 MB
Vendor:	ATI (0x1002)
Device ID:	0x9442
Revision ID:	0x0000
ROM Revision:	113-B7710C-176
EFI Driver Version:	01.00.318
Resolution:	1400 x 1050
Pixel Depth:	32-Bit Color (ARGB8888)
Main Display:	Yes
Mirror:	Off
Online:	Yes
 Display Connector:


 <key>Graphics Mode</key>
 <key>Kernel Flags</key>

Safe boot works, obviously, but if I boot normally when I think it is supposed to change the resolution, it just scrambles the screen. The dongle trick doesn't work here. Anyone have any better ideas? I'm also stuck at 1400x1050, that might just be a restriction of the generic driver.


I just noticed - it seems to be detecting 256MB for a 512MB card, my card is a Gigabyte GA-R485ZL-512H. The DEVID's and VEN's match windows' detections. (1002 and 9442). I am not sure how I'd fix that though.



Name	ATI Radeon HD 4800 Series
PNP Device ID	PCI\VEN_1002&DEV_9442&SUBSYS_21C01458&REV_00\4&2273D500&0&0008
Adapter Type	ATI display adapter (0x9442), ATI Technologies Inc. compatible
Adapter Description	ATI Radeon HD 4800 Series
Adapter RAM	512.00 MB (536,870,912 bytes)
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,
Driver Version	8.782.0.0

Link to comment
Share on other sites

Strangely, booting it up to Windows and back to OS X seems to have fixed the problem. OS X is also now detecting the right amount of RAM for the card. Must have been some sort of NVRAM setting the CCC on windows cleared out or something, but it's working great now.




Link to comment
Share on other sites


  • Create New...