Jump to content

Can't See PATA Hard Drive For Install 10.4.6


4 posts in this topic

Recommended Posts

Here's my configuration:


Motherboard Model NF-CK804

Processor Version AMD Athlon 64 Processor 3500+

Procesor ID 00020FF0-078BFBFF


ATA Hard Drive

Devices: ST3802110A

Controller Primary Controller

Position Master Drive

Model Number ST3802110A

Firmware Revision 3.AAE


I've tried using the HotIso and JAS 10.4.6 images.


System boots off DVD no problem.


Get to the install screen, and no disk is visible.


I've done all the configuration for the drive. Set the primary partition as active. Set the ID=AF. I've tried every combination of initialization possible.


I can see the drive in Disk Utility and Terminal when booted from the Mac OS DVD. The installer just does not see it.


When I try to erase the drive in Disk Utility, the system hangs. When I try to verify, I get errors, but they will not repair, no matter how many times I try.


I plugged in an external FireWire drive, and the installer saw that instantly. I did a full install to that, checking off the appropriate customizations. I wasn't able to boot off the external FireWire. I took that drive and put it into my system. Still no luck.


I get the feeling my PATA controller just isn't compatible. Anybody have any hints?


FYI, my system has two hard drives. SATA and PATA. The SATA I'm using as my main WinXP system disk. The PATA is 80GB and will be used exclusively for OS X.

Link to comment
Share on other sites

Whenever you make changes to the hard drive (erase the partition or re-partition) with 10.4.6 Install DVD, you must reboot your machine to make the changes permanent.


Try booting up, erasing and re-partitioning your hard drive with 10.4.6's disk utility, then reboot back into 10.4.6 and see if the installer picks up that you have an active partition to write to. I'm just speaking from experience, as sometimes I had that problem when testing various motherboards at work.

Link to comment
Share on other sites

No good unfortunately. Disk Utility won't format the drive. It starts, then just hangs. I've left it for along time to see if that helped, but it just jams up at the beginning. Nothing I have tried allows Disk Utility to partition the drive.

Link to comment
Share on other sites

I would get yourself a Knoppix boot CD from here. Knoppix then boot up off the CD, and run fdisk. Knoppix is a linux CD build that runs off CD. For me that's the easiest way to check low level stuff on the disk. I would then format the drive with fdisk and make sure that you set the Partition type to af and set the partition as primary and bootable (if you are booting off of it). This will erase everything off the drive, but should give you an empty partition that you can format.


like this.


Boot knoppix,

run terminal

fdisk /dev/hda (this is where you put the device ID)

Devices in linux are named /dev/hda, or hdb, hdc etc for IDE and sda, sdb...for SCSI or sata if you don't know the ID watch the boot up and see what it's named or just run fdisk /dev/hd(a,b,c) and type p to see which disks they are.

if you see your drive isn't set to af as disk type, then type t and 'af' when prompted...

if you want to kill the partition and start over type d to delete, then c to create, create a primary partition (option 1) and then type t to set the type as above to af...just type 'af'

then type 'w' to write out the partition table turn off the system and put in your apple disk...reboot and start from there.


I'm assuming a lot here. If your partition is fine except for the type, just fix that and reboot no need to recreate the partion by deleting and recreating. If you don't have a clue on your device ID, I would just test through all the hda,b,c options till you hit one with the right size, but be careful not to kill any partions that you want to keep.


I'm also assuming this is not dual boot...mine is not and this worked fine for me, except I forgot to set the partition as bootable (type b in fdisk). because it wasn't bootable it would only boot with the apple CD in the drive.


I hope this helps more than confuses.

Link to comment
Share on other sites


  • Create New...