Jump to content

SATA Native Install: No SATA Drive Detected

Kururu So-cho-

3 posts in this topic

Recommended Posts

Hello all. I'm using JaS 10.4.6 ISO and I would like to have native installation of OSX86 on the my SATA harddisk.


My Hardware Configurations:

A64 3000+ (939 w SSE3)

Abit AN8 Ultra (nForce 4 chipset)

512MB DDR400 * 4

Lite ON DVD SOHO-1693S on IDE0:0

WD1600JS on First Device, First ATA channel, Hardware ID 005410de

WD2500KS on First Device, Second ATA channel, Hardware ID 005510de, Disabled during installation to prevent confusion


I tried to boot with the JaS's DVD and started the installer. Everything seems fine but not the SATA drives. When I open the Disk Manager, I can't see any harddisk on the list but only my Optical drive.

I tried to install the OSX86 via VMWare. Installation finished gracefully, boot well in VMWare, but not natively.

When I boot it I got various problems, like "Still waiting for root device" or even kernel panic. So I give up the VMWare method.

I saw the AppleVIAATA.kext in the HFS+ partition containing my SATA controller hardware ID (005410de , 005510de), but I've no clues why the installer does not detect the SATA harddisk. Do I need to further patch the installer ISO or play some tricks when booting up the installer ISO?


Your kindly assistance will be thankful.

Link to comment
Share on other sites

The JaS PPF works. Now the installer detects my SATA harddisk.

But I experienced error while installing translation packs, so I skipped that and the installation goes well.

Once after the installation I need to go back to Disk Utility in boot disc and repair the HFS+ partition or I can't create any new user in welcome screen.

I dunno why this happen, but anyway I found the way to pass that through.

Anyway thanks for your tips.

Link to comment
Share on other sites


  • Create New...