Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


How to remove FakeSMC.kext? (Kernel Panic)

5 posts in this topic

Recommended Posts

I have OSX 10.6.4 iatkos Version 2 installed


I tried to install FakeSMC to monitor my 8800GS temperature from this tutorial:




I installed with Kext helper the following files






after installed FakeSMC my OSX got kernel panic and frozen with the message "You must restart..." at the Apple Logo Loading.


I've tried to use Single user mode boot (-s), but was unable to remove FakeSMC.kext. So I tried safemode (-x). I was able to get in and deleted FakeSMC.kext from /System/Library/Extensions/.


When try to boot normally I got hung at loading without any message. on Verbose mode I found it is hanging at:

"ACPI_SMC-PlatformPlugin::registerLPCDriver - failed to locate SMC driver"


Once again when I try to go to safemode (-x), it hung at blue screen before login logo.


How do I completely remove FakeSMC and its plugin and back to the way it was before?



Share this post

Link to post
Share on other sites
I don't get what you mean. I am trying to remove FakeSMC and its related extensions from my system.



are you using dsmos? or.. how is the encrypted files being decrypted on the fly


facesmc is not primarily for monitoring temp, it's for filesystem decryption, same as the old dsmos kext

Share this post

Link to post
Share on other sites

no worry. I just reinstalled the sucker back to 10.6.3 with iatkos s3 v2 and everything is working again.


I've read somewhere that I must remove FakeSMC.kext and IOPlatformFamily...kext, then reinstall IOPlatformFamily...kext. However, I couldn't find a link to download IOPlatformFamily and I've wasted 2 days to figure it out. It took me about an hour to reinstall from fresh with all kexts working. I am looking into backup for osx from now on. I've heard apple time machine is not that great comparing to windows backup but that is another issue.


Anyhow, thanks for your feedbacks


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.