Jump to content

Native install on 2nd Harddrive


6 posts in this topic

Recommended Posts

First of all: :)We're Happy.




Basically I have been craving for x86 OS X eversince I joined Aqua-soft a few years ago to learn about the OSX-skinning ('Aqua-fying') and even more when I got to experiance the real thing through PearPC. And since the move from IBM PowerPC to Intel announcement by Steve Jobs at the WWDC I knew I had to have it. Been following forums about it from then on, getting more-and-more an enthausiast from reading other people's progress, and this weekend I finally tried myself to a great amount of success.





As a reference I used a file called "The Ultimate Moron's Guide to OSX Native Install.rtx" by Goober which is truely great, thank you

for this great Guide.

Basically you change the x86 Marklar Tiger image to .iso through UltraIso and install through PearPC in a 3-or-6 Gb image. Then you use VMware to install Darwin on your second hardrive. Copy the 3/6 Gb image to the Darwin-isedhardrive. Install the stuff from the Patches.iso (CoreGraphics, ditto, oah750d & PS2 controller). Then boot the native Tiger HD and install the Maxxuss 0.5c patch, IDE tweak, Safari fix and other.



The Good


OS X & WindowsXP don't get in each others way

The great thing is that I can choose from which HD to boot from in my bios, so I don't have mo mess with bootloaders or physically swap disks and the jumper-swithing that comes along.

In the Advanced Bios Features swap the 1st and 2nd HD's under Harddisk Boot Priority. Works like a charm.


keyboard & mouse

At first I have no success in getting my keyboards & mouse to work natively. Fiddeling with my Award bios resulted eventually in success.

Here's what I did:

In the Integrated Peripherals section change On-chip USB from v1.1+v2.0 to v1.1. That fixed it for me. I find it a tad slow compared to running OSX through VMWare under WinXP, but it's working and that's what counts imo. Also VMware doesn't have this problem.


DVD drive

OS X sees my AOpen DVD-RW (DUW1608/ARR) out of the box and displays them on the desktop when loaded, reads the CD's & DVD's I feed it, though I haven't tried burning a CD/DVD yet...


USB works

My USB works fine with the sticks I plug into it, they appear on the desktop like they should and I can read/write to them. I can't help but to think that since I had to revert to 1.1 instead of 2.0 in order to get my mouse working it could faster, though I dont notice lag on this area.


Other drives visible

OS X also sees my other (XP) disk and it's partitions and delivers blazingly fast results from them when using spotlight. I noticed Tiger has putten a tiny .DS_Store file in every directory, but it doesn't hinder my XP, so I don't really mind.



Lastly I'd like to mention the fact that whenever I screwed up essential parts of OSX like com.apple.Boot.plist (like for instance when adding “Graphics Mode”=”1024×768x32@85? and then find out GeForce 6600 is fixed @60hz at this moment, though it is a VESA 3.0 card) and the dang thing won't boot natively anymore (not even in safe mode), it still boots great through VMware and you can revert your mistakes from there. ;)



The Bad


- Can't get sound to work.

Though my MoBo has an onboard AC'97 chip (ALC850), OS X doesn't see it under ATM-->more info under Audio (Built in). Tried HoZy's sollution, but to no avail. Dang! :P

Suggestions? Some .kext? Alternatively some cheap compatible PCI card perhaps? Unsatisfying, for many people report success on the AC'97/ALC850, even quite a few working-out-of-the-box reports, so why the heck doesn't mine work too?


- Refresh rate is stuck @60

I don't understand because my GeForce 6600 is definitely a VESA 3.0 card (Darwin even reports it as such. But changing “Graphics Mode”=”1024×768x32@85? in com.apple.Boot.plist

Ouch, it hurts my eyes :blink: The WiKi.osxproject.org HLC overview reports this a a known problem on Geforces, unfortunately :(

This problem doesn't occur through VMware where my refresh-rate is crisply opdating @85hz.


Maybe we have to wait for The hunt (x86 nVidia driver for OSX research) may prove helpful for us in the end? Fortunately I will switch my current 17" CRT for a 19" TFT in a few months and I've been told that low refresh rates aren't really noticable on TFT's. :lol:

Again, suggestions or sollutions are very welcome.


- No networking

This kinda puzzles me,for ATM-->more info does see a Ethernet card...but when I try so setup a connection, the Assisten doesn't see it (all options like modem, cable, a.o. are greyed out).

Maybe I should load a certain .kext that I don't know of.

suggestions?. I'm considering a cheap compatible Realtek PCI networkcard, for a working network connection improves OSX x86's usefullness very much of course.





I had been lingering for OSX on x86 for very long.

Currently if you buy a real (G5) Mac then you would have to buy a WindowsPc besides it to play pc games. Mac's simply aren't a serious gaming platform for pc's like Windows is. Mainly because of M$'s exclusive DirectX based games dominance over OpenGL. I sometime think of what would happen if DirectX would work on OS X too... :P


Back to topic.


Would Apple release OS X for vanilla x86 pc's I'd probably be one of the first to go out and buy it. But since Apple is mainly a hardware seller, this probably isn't going to happen. That's why I jumped the osx86 scene.


How's the experiance so far? Is it worth it yet? For me it isn't.

Surely it's much more workable than PearPC speedwise.

Still my OSX is at this moment is way too crippled without LAN (Safari), sound (iTunes, Quicktime) and the fixed 60hz refresh rate plays mayhem on my eyes.


Obviously the Patches.iso and Maxxuss's SSE3>SSE2 & TPM patches are a godsend. Wihout those people's effort my AMD (non Intel, non SSE3) would never have been able to boot in the first place.

This gives me hope for the future. For now WindowsXP stays to be my main os. Then again I'll keep OS X on my second harddrive too. Ready to apply every improvement that comes available through boards like these. I'l probably ain't gonna use PearPC all that much anylonger.


I'll probably buy that cheap Realtek LAN card this week just to get OS X to surf the net (even though it hurst my eyes @60 Hz)... ;)



In short


- CPU (AMD3500+, s939, Winchester, no SSE3) works patched through Maxxuss

- MoBo (Gigabyte GA-K8NF-9, nForce4 (x4) <span style='color:blue'>works</span> <span style='color:red'>partially</span>:

- Onboard LAN (VITESSE 8201 phy (10/100/1000 Mbit) <span style='color:red'>Not working</span>

- Sound (Onboard AC'97 ALC850) <span style='color:red'>Not working</span>, but I have hopes.

- GPU Geforce 6600 PCi (256 mb/VESA 3.0) <span style='color:blue'>Working</span>, but unfortunately fixed @60 Hz... :angry:

- Keyboard (Logitech Easy Internet kb (PS2) <span style='color:blue'>works</span> with the ApplePS2Controller.kext from the Patches.iso

- Mouse (Microsoft IntelliMouse Explorer USB) <span style='color:blue'>Working</span> when is changed my On-chip USB from 2.0 to 1.1. and through a USB-to-PS2 plug.



Sollution (so far)


The recent RC of VMware (version 5.5 build 16958) is so much faster than earlier versions that I decided to go with that for now instead of Native.

In my case we're talking about: 260.57% performance gain compared to the previous version I was using and 73.61% of my native score (as can be read in further details here.

Together with

  • Maxxuss SSE3->SSE2 and Anti-TPM Patch
  • Maxxuss Exec_10.4.2 Patch
  • Maxxuss VMWare/PCNet-II Network Driver for Darwin & Mac OS X
  • Maxxuss VMWare/Ensoniq AudioPCI (ES1371) Driver for Darwin & Mac OS X

I now have reasonable speed, network & sound, thus I find myself using os X for most of my common pc usage (surfing, e-mail, forums) instead of Windows XP (the exception, off course, being gaming).

Link to comment
Share on other sites

  • 3 weeks later...


the original posting of the UM's guide was removed and i think if i post it again it will be removed again. if there is anyone who wants it just let me know.


Your sound should work using the ac97 sound guide mine works great. I have a Identical motherboard to your own. I also havnt gotten networking to work as of yet im still trying. Currently im trying cheapo cards that I found from past machines.

Link to comment
Share on other sites

Your sound should work using the ac97 sound guide mine works great. I have a Identical motherboard to your own. I also haven't gotten networking to work. As of yet im still trying. Currently im trying cheapo cards that I found from past machines.
You have a Gigabyte GA-k8nf-9 too? And got the ALC 850 sound working natively? What method? By editing the nvidia part of the AC'97 .kext? Could you copy that part to a posting here, so I can compare and see what I have done wrong then?

For now I go with VMware. Performance has improved immensely in the most recent build (16958) and together with

  • Maxxuss VMWare/PCNet-II Network Driver for Darwin & Mac OS X
  • Maxxuss VMWare/Ensoniq AudioPCI (ES1371) Driver for Darwin & Mac OS X

I dig os X through VMware quite well allready (as can be read in my modified article on top of this thread).

Link to comment
Share on other sites


  • Create New...